Reading plan & search links open new tab

Page 1 of 1 (17 items)
This post has 16 Replies | 2 Followers

Posts 59
BillW | Forum Activity | Posted: Mon, Jun 18 2018 8:41 AM

When I click a link in a search tab or my reading plan, the moble reader app opens a new tab rather than using an existing tab where the resource is already open.  Even if I begin using this new tab for this resource, my primary bible, (closing the original one) at some point later when I click on either search or my reading plan the app will add yet another new tab!

This behavior started several revisions ago.  Since no one has fixed this bug yet, I wanted to report it and ask for you to please address it.

Thanks!

- BillW

Posts 21847
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Jun 18 2018 8:46 AM

I'm not seeing this on my iPad.

Which version of the app are you using and on which platform?

Posts 59
BillW | Forum Activity | Replied: Mon, Jun 18 2018 9:47 AM

Graham Criddle:

I'm not seeing this on my iPad.

Which version of the app are you using and on which platform?

Thanks Graham, I should have included that info... the problem is with the Android version, on both my devices:

 - Asus ZenPad 8 tablet, Android 7.0 - Logos Bible version 6.5.1 (build 605011191)
 - Samsung Galaxy J7 Sky phone, Android 6.0.1 - Logos Bible version 6.4.1 (build 604011131)

As stated, it has persisted for several updates now.

- BillW

Posts 21847
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Jun 18 2018 9:55 AM

Thanks BillW

I've checked on my Android phone and I can't reproduce what you are seeing either  - and I have the same build of the Logos app on a Samsung Galaxy J3 phone.

So something strange is going on!

Posts 59
BillW | Forum Activity | Replied: Mon, Jun 18 2018 11:56 AM

Thanks so much for checking Graham, I really appreciate it!  That's pretty interesting you don't have the same result, it's a consistent problem on both my devices.  What android version is your J3 running?  For me the first time I click a link from my reading plan (or search), it always creates a new tab, but if I close my original tab it does use the new tab it created for a while (rather than opening yet another new tab).  However, after I do anything with that tab (like move it to a different position or add a split screen to it) then next time I click a link for that resource it just creates another new tab again.

I've just cleared all data, uninstalled the app, rebooted the tablet, and reinstalled the app...  Still have the same problem. 

Graham, would you mind terribly trying this again on your android phone?  But first, open a separate tab for a bible reading plan or a bible search (if not already done), then add a split screen on your main Bible tab to some additional resource and link the 2 splits.  Finally, move that Bible tab to a different position among the other tabs you have open.  After this, click a new passage from your reading plan or search tab.  What is your result now?

I think I need to contact Tech Support on this one, but if you have the time to test this, your results may help.

- BillW

Posts 59
BillW | Forum Activity | Replied: Tue, Jun 19 2018 11:13 AM

Tech Support is working on this issue for me, fyi.

- BillW

Posts 21847
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Jun 19 2018 12:16 PM

BillW:
What android version is your J3 running? 

Its running Android 5.1.1

BillW:
Graham, would you mind terribly trying this again on your android phone?  But first, open a separate tab for a bible reading plan or a bible search (if not already done), then add a split screen on your main Bible tab to some additional resource and link the 2 splits.  Finally, move that Bible tab to a different position among the other tabs you have open.  After this, click a new passage from your reading plan or search tab.  What is your result now?

I set up the following - from left to right:

  1. Bible search panel
  2. Preferred Bible
  3. Pillar commentary
  4. BDAG lexicon

I added the Faithlife Study Bible in a split screen to the NIV (my preferred Bible) and linked the splits

I moved the split tab to the end - so after the lexicon

Running a search in the search tab and tapping on one of the results updated the NIV in the split tab but - interestingly - the FSB didn't track with it. But it did when starting to scroll through the NIV.

But then I tried another search and tapped on one of the results and a new copy of the NIV was opened at the search result - this tab was immediately after the search panel, so in spot 2 just before the Pillar commentary.

So I can reproduce what you are seeing in this way.

Hope this helps and tech support can get to the bottom of it.

Posts 59
BillW | Forum Activity | Replied: Wed, Jun 20 2018 10:14 AM

Thanks VERY MUCH Graham, I was thinking this may be unique to my install somehow...  will update when I hear back from tech support.

- BillW

Posts 59
BillW | Forum Activity | Replied: Mon, Jun 25 2018 11:17 AM

Just to update, It's now been a full week since I initially reported this problem and I've still not heard back from Tech Support after customer service requested I send a problem report from the app last Tuesday.  I'm sorry, but this is really poor tech support!

Would someone from Logos tech support PLEASE respond? 
(I've also sent an email to tech support requesting a response)

- BillW

Posts 10
LogosEmployee
Roy Dammarell | Forum Activity | Replied: Mon, Jun 25 2018 1:40 PM

Thank you for the report and for the repro instructions. I expect this to be fixed in the next stable release.

Posts 60
Stephen Harper | Forum Activity | Replied: Mon, Jun 25 2018 10:44 PM

I reported this behaviour on 13 June when using 6.4.1 on Samsung galaxy Tab S3 .

At that time seemed to be only KJV but is now worse (6.5.1)and affecting ESV (and maybe other versions too). It's very frustrating as I use the app for preaching and I'm disappointed Faithlife haven't sorted out what must be a simple issue by now. 

Posts 59
BillW | Forum Activity | Replied: Tue, Jun 26 2018 9:22 AM

Roy Dammarell:

Thank you for the report and for the repro instructions. I expect this to be fixed in the next stable release.

Thanks Roy. 

From your response I'm assuming that you're Logos support (or development)?  Sorry, but I don't see anything in your profile to indicate you're an employee, shouldn't all of you be clearly identified?

- BillW

Posts 59
BillW | Forum Activity | Replied: Tue, Jun 26 2018 9:27 AM

Stephen Harper:

I reported this behaviour on 13 June when using 6.4.1 on Samsung galaxy Tab S3 .

At that time seemed to be only KJV but is now worse (6.5.1)and affecting ESV (and maybe other versions too). It's very frustrating as I use the app for preaching and I'm disappointed Faithlife haven't sorted out what must be a simple issue by now. 

Thanks Stephen, it's doing it with the NIV84 (my primary Bible), with your input and Graham's it seems this is an issue for any Bible.

- BillW

Posts 4911
DIsciple II | Forum Activity | Replied: Wed, Jun 27 2018 1:54 AM

Bill take a look below Roy’s picture on his post, there is a Faithlife Logo which indicates he is a Faithlife employee. Hope this helps you with determining  when a FL employe is responding to you in the future.

BillW:

Roy Dammarell:

Thank you for the report and for the repro instructions. I expect this to be fixed in the next stable release.

Thanks Roy. 

From your response I'm assuming that you're Logos support (or development)?  Sorry, but I don't see anything in your profile to indicate you're an employee, shouldn't all of you be clearly identified?

Posts 27546
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Jun 27 2018 4:12 AM

doc:
Bill take a look below Roy’s picture on his post, there is a Faithlife Logo which indicates he is a Faithlife employee.
'

It wasn't there to begin with, and then there was an MVP logo! 

OSX & iOS | Logs |  Install

Posts 59
BillW | Forum Activity | Replied: Wed, Jun 27 2018 9:50 AM

JT (alabama24):

doc:
Bill take a look below Roy’s picture on his post, there is a Faithlife Logo which indicates he is a Faithlife employee.
'

It wasn't there to begin with, and then there was an MVP logo! 

JT's right, it was an MVP Logo before.  Roy, thanks for updating your profile...  but much more importantly, thanks for responding to my question, looking forward to the next update!

- BillW

Posts 59
BillW | Forum Activity | Replied: Mon, Jul 9 2018 12:08 PM

Roy Dammarell:

Thank you for the report and for the repro instructions. I expect this to be fixed in the next stable release.

Today I updated Logos to v6.5.2 Beta and it appears this issue has been resolved!

Thanks very much Faithlife!

- BillW

Page 1 of 1 (17 items) | RSS