Android Reader Suite Beta Release Notes

Page 1 of 1 (5 items)
This post has 4 Replies | 1 Follower

Posts 435
Faithlife Announcements | Forum Activity | Posted: Wed, Aug 22 2018 2:41 PM

The Android team is pleased to announce the Android Suite Beta release of the Faithlife apps.

ARM device version code: 606006171
x86 device version code: 606006172

If you are already signed up for the beta via Google Play you will automatically receive the beta update over the next few hours.

If you are a new beta user or haven't previously tried one of our beta apps before, we have switched to Google's Open Beta test model so you don't need to sign up - just use the opt-in links shown below.

If you find a bug please see for instructions on how to report it.

Versions in this release

Bible! 6.6.0 (Build 0617) - [Bible! Beta opt-in page]
Faithlife Study Bible 6.6.0 (Build 0617) - [FSB Beta opt-in page]
Biblia! 6.6.0 (Build 0617) - [Biblia! Beta opt-in page]
Noet 6.6.0 (Build 0617) - [Noet Beta opt-in page]
Verbum 6.6.0 (Build 0617) - [Verbum Beta opt-in page]
Faithlife Ebooks 6.6.0 (Build 0617) - [Faithlife Ebooks Beta opt-in page]


- History now works as expected
- Recent verses now work as expected

Posts 549
L.A. | Forum Activity | Replied: Thu, Aug 23 2018 5:05 AM

URGENT!!!! App does not start! (Bible!)

After uninstalling the app, restarting the device and a new install, the app worked until quitting and trying to re-open. Same behavior on two devices:

  • Samsung A3 Duos (SM-A300M) Android 5.0.2
  • Sony Xperia Z3 Tablet Compact (SGP 611) Android 6.0.1 
Posts 229
André Kamphuis | Forum Activity | Replied: Thu, Aug 23 2018 6:07 AM

I can confirm this bug. Same on my phone (Samsung Galaxy4 running on Android 6.0.1). Have sent in the logs. 

Posts 10
Roy Dammarell | Forum Activity | Replied: Thu, Aug 23 2018 2:21 PM

Thanks for the reports. We are planning to ship a fix today.

Posts 549
L.A. | Forum Activity | Replied: Fri, Aug 24 2018 5:57 AM
Thank you very much for the fast tec response! The app is working fine now, and (what I did not expect) downloaded all resources I had downloaded previously before uninstalling.
Page 1 of 1 (5 items) | RSS