Resources on Android Phone not in Sync with Desktop App

Page 1 of 1 (6 items)
This post has 5 Replies | 0 Followers

Posts 1399
Rick Ausdahl | Forum Activity | Posted: Fri, Sep 28 2018 9:26 AM

I recently switched from a Windows phone to an Android phone.  When I open Logos resources on my phone, they are not in sync with the resources when viewed on the desktop app and I don't see a way to request/force syncing on the phone.  Is there a way to keep the resource in sync when viewed on the phone?

Posts 21989
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Sep 28 2018 9:33 AM

When you say "not in sync" what exactly do you mean?

How the mobile apps / desktop app should sync resources is that if the resource is not open on mobile when you are reading it on desktop then when you open it on mobile it should open to the same place as the desktop.

If you have them open on both platforms at the same time they don't stay in sync

Is this what you are seeing?

Posts 1399
Rick Ausdahl | Forum Activity | Replied: Sat, Sep 29 2018 7:28 AM

Graham Criddle:

When you say "not in sync" what exactly do you mean?

How the mobile apps / desktop app should sync resources is that if the resource is not open on mobile when you are reading it on desktop then when you open it on mobile it should open to the same place as the desktop.

If you have them open on both platforms at the same time they don't stay in sync

Is this what you are seeing?

Hi Graham!  Sorry for not responding sooner--have not been near a computer.

Here's the scenario.  I've been reading some of Walton's "Lost World" monographs (Lost World of Adam and Eve; Lost World of Genesis One).  When I open them on my laptop, they open to where I left off the last time I had them open on the laptop.  When I opened them on my phone (desktop version of Logos was not open), they opened to the beginning of the book and I didn't see any sync tools/options on the phone.

Can you clarify one thing for me, please?  You said "...if the resource is not open on mobile when you are reading it on desktop then when you open it on mobile it should open to the same place as the desktop."  I'm assuming the phrase "...when you are reading it on desktop" implies while the desktop version of Logos is open to a layout that has the resource in question (in this case a "Lost World" resource) open.  In my situation, my laptop wasn't even on when opening the resources on my phone, but I'm assuming the resource should have synced on the phone even if the desktop app had been open, provided that same resource was not open in the active layout on the desktop app.

Since you said they should sync under the conditions you noted, I'll play around with the scenario a little more to see if I can get the phone to sync.  I.e.  I'll make sure the app on the phone is closed AND that the resource was not open (not assigned to any tab) on the phone when the app was closed there.  Then I'll open the desktop, open the resource, then close the desktop app while the resource is still included in the active layout.  Then I'll try opening the app on the phone again.  If that doesn't work, I'll run through the above process again, but try removing the resource from the active layout on the desktop app before closing the app, then checking the resource on the phone again.

Posts 1399
Rick Ausdahl | Forum Activity | Replied: Sat, Sep 29 2018 8:40 AM

As noted in the last paragraph of my previous post I did the following.

I made sure the app on the phone was closed AND that neither of the "Lost World" resources was open (not assigned to any tab) on the phone when the app was closed there.  Then I opened the desktop app, opened the two "Lost World" resources, did a sync, then closed the desktop app while the resources were still included in the active layout.  Then I opened the app on the phone again and opened the two resources.  Strangely, "The Lost World of Genesis One" was then in sync but "The Lost World of Adam and Eve" was not.  So I closed both resources on the phone again, selected the "Home" screen for the phone app, then closed the app.  Then I opened the desktop app again which still had both resources in the active layout.  I did another sync and then closed the desktop app.  I then reopened the phone app and opened both resources.  This time, both were in sync with the desktop.  Soooooooo ...it's still not clear to me just what the trigger/triggers is/are in regard to syncing the resources.  Huh?    

Posts 21989
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Sep 29 2018 9:09 AM

Rick Ausdahl:
Then I opened the desktop app, opened the two "Lost World" resources, did a sync, then closed the desktop app while the resources were still included in the active layout.  Then I opened the app on the phone again and opened the two resources.  Strangely, "The Lost World of Genesis One" was then in sync but "The Lost World of Adam and Eve" was not.  So I closed both resources on the phone again, selected the "Home" screen for the phone app, then closed the app.  Then I opened the desktop app again which still had both resources in the active layout.  I did another sync and then closed the desktop app.  I then reopened the phone app and opened both resources.  This time, both were in sync with the desktop

It sounds like a strange bug - maybe some sort of sync event is being missed on the app.

As I understand it the scenario you describe here should result in the resources being synced on mobile.

Posts 1399
Rick Ausdahl | Forum Activity | Replied: Sat, Sep 29 2018 10:30 AM

Graham Criddle:

Rick Ausdahl:
Then I opened the desktop app, opened the two "Lost World" resources, did a sync, then closed the desktop app while the resources were still included in the active layout.  Then I opened the app on the phone again and opened the two resources.  Strangely, "The Lost World of Genesis One" was then in sync but "The Lost World of Adam and Eve" was not.  So I closed both resources on the phone again, selected the "Home" screen for the phone app, then closed the app.  Then I opened the desktop app again which still had both resources in the active layout.  I did another sync and then closed the desktop app.  I then reopened the phone app and opened both resources.  This time, both were in sync with the desktop

It sounds like a strange bug - maybe some sort of sync event is being missed on the app.

As I understand it the scenario you describe here should result in the resources being synced on mobile.

Thanks, Graham!  If it is a strange bug, maybe the bug is me.  Wink    I'll see what happens going forward.

Page 1 of 1 (6 items) | RSS