Logos Crashes When Opening

Page 1 of 1 (11 items)
This post has 10 Replies | 1 Follower

Posts 9
David Mark Rathel | Forum Activity | Posted: Wed, Nov 28 2018 4:20 AM

Greetings, 

I presently cannot open Logos on my Mac. The application begins and then immediately (on its own) closes. I presume it crashes. I have deleted the application from my machine and reinstalled in from the Logos website on several occasions.  Even so, it still will not open. I cannot get to the screen where a user inserts their password. I would appreciate any help. Thanks! 

Posts 21918
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Nov 28 2018 4:26 AM

Hi David 

Do the suggestions at https://community.logos.com/forums/p/175794/1015371.aspx#1015371 help?

Posts 9
David Mark Rathel | Forum Activity | Replied: Wed, Nov 28 2018 4:44 AM

Thanks, Graham. I appreciate your help. I just read the posts on the link that you sent. I am opening from the applications folder and not the dmg folder. I  copied the application there when I downloaded it. Do you have any other suggestions? Thanks again. 

Posts 21918
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Nov 28 2018 4:51 AM

Thanks David

Please enable diagnostic logging and post logs after a crash in a reply to this thread (use the paperclip icon in the forum editor)

Details at https://support.logos.com/hc/en-us/articles/360015776171-Report-a-Problem-in-Logos-Mac 

Posts 9
David Mark Rathel | Forum Activity | Replied: Wed, Nov 28 2018 4:54 AM

Thanks again, Graham. I have downloaded that tool and followed the instructions, but it  says "you must restart Logos for the changes to take effect." I am unable to capture any logs. 

Posts 9
David Mark Rathel | Forum Activity | Replied: Wed, Nov 28 2018 4:56 AM

Correction: I may have some logs. 5430.LogosLogs.davidrathel.20181128-125513.zip

Posts 21918
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Nov 28 2018 5:00 AM

Thanks for the logs

They show the crash but I can't work out from them what is wrong.

Hopefully someone else will be able to provide some more insight and suggestions.

Posts 9
David Mark Rathel | Forum Activity | Replied: Wed, Nov 28 2018 5:04 AM

Okay I understand. Thanks for your time! All the best!

Posts 27678
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Nov 28 2018 5:35 AM

David Mark Rathel:
I have deleted the application from my machine and reinstalled in from the Logos website on several occasions.

That is rarely a fix for anything related to Logos. Most problems are either a bug (which you would just be redownloading until a fix is provided) OR some sort of corruption in your data files. A FULL reinstall <might> fix the problem, but that is a big task. 

David Mark Rathel:
I cannot get to the screen where a user inserts their password.

Did you press and hold the command key immediately upon startup? 

OSX & iOS | Logs |  Install

Posts 9
David Mark Rathel | Forum Activity | Replied: Wed, Nov 28 2018 5:40 AM

Thanks. I tried the command button as you suggested. For some reason, Logos worked. I just signed in. Many thanks. I'm not sure what this means--but at least it is working. All the best, 

Posts 27678
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Nov 28 2018 6:59 AM

David Mark Rathel:
I tried the command button as you suggested. For some reason, Logos worked.

David Mark Rathel:
I'm not sure what this means--but at least it is working.

When you sign in with this method, it opens to a "blank layout." If you had some sort of corruption in a layout (or the homepage), this will help you to bypass it. If you continue to have problems with a particular layout, you may need to create a new one. If you have any other issues, let us know! 

OSX & iOS | Logs |  Install

Page 1 of 1 (11 items) | RSS