Bug: My tags not syncing

Page 1 of 1 (16 items)
This post has 15 Replies | 1 Follower

Posts 570
Schumitinu | Forum Activity | Posted: Sun, Dec 9 2018 1:33 AM

I have Logos 8 installed on three different machines (all Mac OS 10.13.6). I have added my tags on two different machines, but none of them sync to other Logos applications. I have given it several weeks. I have started them all up with having to login afresh. What would help to get them syncing again?

I can upload log files. But I'd like to know from which machine? One I have added my tags? should I do anything else while the logging is running?

Thanks for any help!

Posts 26269
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Dec 9 2018 2:11 AM

First, I'd need to know what you are adding the mytags to.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 570
Schumitinu | Forum Activity | Replied: Sun, Dec 9 2018 5:20 AM

In the library to resources/books

Posts 26269
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Dec 9 2018 3:36 PM

Your not apt to like my answer but...

  1. triple check that you are logged into the same account - it appears that you have checked
  2. triple check that all installations are set to use the internet - it appears that you have checked
  3. check if a collection using the missing tag, picks up the resource even though you can't see the tag. If it does, it is simply a display problem. Report as a bug.
  4. a) triple check that some other item e.g. a note is synced - if not assume that the problem requires a Logos tech so give them a call
    b) if it is, assume that it is a bug in the library, report it as such and call a Logos tech

Sorry I don't have a quick and easy fix.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 570
Schumitinu | Forum Activity | Replied: Sun, Dec 9 2018 7:29 PM

Thanks MJ. Smith

1. Checked
2. Checked
3. The collection does not pick it up
4. Notes and highlights sync instantly, as do new collections and guides.

It appears that when I add a tag to a resource, that the syncing wheel turns, but somehow it does not download them on the other machines. But if I search for mytag:_ on the mobile app, it finds it.

Posts 26269
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Dec 9 2018 8:22 PM

Yes, I think you'll have to call in the big guns ... I suspect data corruption but have no reasonable way of checking which machine or server is most likely the culprit.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 21862
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Dec 10 2018 12:46 AM

Schumitinu:
But if I search for mytag:_ on the mobile app, it finds it.

This is an interesting detail

This suggests that "up sync" of tags is working - otherwise the mobile apps wouldn't find them - but "down sync" - from the cloud to desktop isn't

It would be interesting to see logs from one of the Mac machines.

Please enable diagnostic logging as per https://support.logos.com/hc/en-us/articles/360015776171-Report-a-Problem-in-Logos-Mac 

Then start Logos, click the sync button, and when it has finished syncing stop Logos and upload logs in a reply to this thread (using the paperclip icon)

Posts 570
Schumitinu | Forum Activity | Replied: Mon, Dec 10 2018 5:23 AM

Thanks Graham,

here is the log file:

6545.LogosLogs.schumitinu.20181210-202105.zip

Posts 21862
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Dec 10 2018 7:21 AM

Thanks Schumitinu

I can't see any notification of any tag / sync related issue.

Hopefully someone from Faithlife will be able to comment further

Graham 

Posts 24843
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Dec 10 2018 11:45 AM

Schumitinu:

Thanks Graham,

here is the log file:

Anything to do with an Urdu bible which may be  LLS:SL_UR_BI_URDERV? Paste the full LLS.... name into GO/Command box to get its title.

Dave
===

Windows & Android

Posts 570
Schumitinu | Forum Activity | Replied: Mon, Dec 10 2018 4:50 PM

Dave Hooton:
Anything to do with an Urdu bible which may be  LLS:SL_UR_BI_URDERV? Paste the full LLS.... name into GO/Command box to get its title.

Dave, this is the ERV: Urdu Bible. It opens up fine. So I'm not sure why it would flag up in the log file and whether it has anything to do with mytags?

Posts 24843
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Dec 10 2018 10:52 PM

Schumitinu:
Dave, this is the ERV: Urdu Bible. It opens up fine. So I'm not sure why it would flag up in the log file and whether it has anything to do with mytags?

A metadata warning was flagged:

2018-12-10 20:19:52.9190 |  WARN | 33 | MetadataServiceUtility | Invalid Titles (Count=1), Languages (Count=1), or MilestoneIndexes (Count=1); rejecting metadata record for LLS:SL_UR_BI_URDERV.

It was a long shot as I think it would have said "user metadata" (tags and ratings).

Dave
===

Windows & Android

Posts 570
Schumitinu | Forum Activity | Replied: Tue, Dec 11 2018 6:14 AM

I wrote an email to customer support. My only reasonable option since I live on the other side of the globe. Hope to get help in due time.

Posts 4624
Forum MVP
Mike Binks | Forum Activity | Replied: Wed, Dec 12 2018 12:16 AM

Schumitinu:

I wrote an email to customer support. My only reasonable option since I live on the other side of the globe. Hope to get help in due time.

From the Uk I find that calling with Skype offers an inexpensive method of getting in touch.

Posts 570
Schumitinu | Forum Activity | Replied: Wed, Dec 12 2018 6:14 AM

Thanks Mike, I'll remember that.

Support got back to me right away and they had a solution for me. It solved the issue. Here it is:

  1. Open Finder
  2. On the top left you’ll see File, Edit … etc. until you find Go, click on Go.
  3. Hold Alt or /- key on your keyboard, you’ll see an option that says Library appear, click on it.
  4. Click on Application Support, then find Logos
  5. Right click Documents folder, then move to trash.
  6. Start Logos and allow it to synchronize, then attempt to use mytags again.
Posts 4624
Forum MVP
Mike Binks | Forum Activity | Replied: Wed, Dec 12 2018 8:22 AM

Glad you got it working.

Now you will have something to play with over Christmas :-)

Page 1 of 1 (16 items) | RSS