Page 1 of 1 (15 items)
This post has 14 Replies | 1 Follower

Posts 14
Rich Kauzlarich | Forum Activity | Posted: Wed, Dec 26 2018 8:10 AM

Ever since I purchased my new MacBook Pro neither Logos 7 or Logos 8 will open beyond a few seconds before it closes. Here are the files created with the Logos Logging U4380.LogosLogs.RichKauz.20181226-110453.ziptility.

Posts 10592
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Dec 26 2018 10:16 AM

Which versions of Logos 7 & 8? What Mac OS? How are you attempting to open the apps?

The symptoms you describe are quite similar to what occurs when attempting to open from the disk image. Have you placed the app in the Applications folder and opened it from there?

Posts 14
Rich Kauzlarich | Forum Activity | Replied: Wed, Dec 26 2018 11:03 AM

I'm using Mojave version 10.14.2. Logos 8 closes before I can get the version number. I'm opening it from the applications folder.

Posts 152
Pastor Greg | Forum Activity | Replied: Wed, Dec 26 2018 2:36 PM

Was it a fresh install, or did you copy a backup from a previous machine?

Posts 14
Rich Kauzlarich | Forum Activity | Replied: Wed, Dec 26 2018 2:38 PM

Fresh install from December 7, 2018

Posts 18007
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Dec 26 2018 3:29 PM

Rich Kauzlarich:
Ever since I purchased my new MacBook Pro neither Logos 7 or Logos 8 will open beyond a few seconds before it closes.

Logos.log shows 8.1.0.0016 on macOS 10.14.2 crashing while processing community metadata for one resource:

Error detail: ArgumentException: An item with the same key has already been added.

An idea for Launching Logos is sign-in tip to work offline => https://wiki.logos.com/Keyboard_Shortcuts_For_Mac (trying to avoid download & processing of community metadata)

Apologies since personally have Program Settings for Community Ratings and Tags set to No (so have not experienced this bug).

Keep Smiling Smile

Posts 10592
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Dec 26 2018 4:50 PM

Rich, the fatal error seems to be with

/Users/richardkauzlarich/Library/Application Support/Logos4/Data/d0khvg4i.034/ResourceManager/Resources/LIONINTOT.logos4

Can you find this file and transfer it to the trash. Then, try starting Logos. Let us know what happens then.

Posts 14
Rich Kauzlarich | Forum Activity | Replied: Wed, Dec 26 2018 8:30 PM

How do I find the file? Thought I did it but still get same error message in trying to open Logos 8. This should not be difficult. Why can't I just uninstall and reinstall?

Posts 25092
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Dec 26 2018 8:58 PM

Rich Kauzlarich:
How do I find the file?

To see the hidden Library folder  => http://www.macworld.com/article/161156/2011/07/view_library_folder_in_lion.html

Dave
===

Windows 10 & Android 8

Posts 18007
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Dec 27 2018 12:43 AM

Rich Kauzlarich:
Thought I did it but still get same error message in trying to open Logos 8. This should not be difficult. Why can't I just uninstall and reinstall?

My apologies Embarrassed for earlier reply lacking suggestion to contact Faithlife technical support => https://www.logos.com/contact

Uninstall and reinstall is a way to verify Bug in Community Metadata processing. Logos wiki OS X Troubleshooting includes Uninstalling Logos for Mac Logos 8 installation => https://www.logos.com/install has download link while lacking macOS step of copying application bundle from downloaded disk image to desired folder (e.g. Applications) before opening application. Help Center has => https://support.logos.com/hc/en-us/articles/360020137252-Install-Logos-Bible-Software-Mac so updated Logos wiki OS X Troubleshooting => Installing Logos for Mac

Found a support bug. Logos 7 install page => https://www.logos.com/install-logos-7 has link for Logos 6 on Mac => https://www.logos.com/support/logos6/mac/install that redirects to Help Center "Previous Versions" article => https://support.logos.com/hc/en-us/articles/360015520412-Previous-Versions that has Logos 6 link back to Logos 7 install page.

Personal hypothesis is Community Metadata about "Introducing the Old Testament" by John Drane has a Bug during processing: error trying to insert a resource key that already exists, which is not affected by deleting resource file (causes download of resource file). Hiding/unhiding resource may affect community metadata processing, but quick crash presents challenge for hiding.

Keep Smiling Smile

Posts 14
Rich Kauzlarich | Forum Activity | Replied: Thu, Dec 27 2018 5:30 AM

Found the file (finally!) put it in trash. Launched Logos 8 and got the same error message -- tried holding command key -- no response.

Posts 2033
Forum MVP
Reuben Helmuth | Forum Activity | Replied: Thu, Dec 27 2018 5:53 AM

Rich Kauzlarich:
tried holding command key -- no response.

What do you mean my "no response". No difference in behavior (after launching), total failure to launch, or something else. Did you hold the Cmd key immediately AFTER clicking to launch the program (click the dock icon, then immediately press and HOLD the Cmd key)? Doing this should bring up the sign in dialogue so you can choose "work offline".

Posts 1600
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Dec 27 2018 5:57 AM

Rich Kauzlarich:
tried holding command key -- no response.

Be sure you click on the Logos icon and THEN press the Command key a half second later. Don't press it simultaneously with clicking.

Posts 14
Rich Kauzlarich | Forum Activity | Replied: Thu, Dec 27 2018 5:59 AM

I did that. Same thing happened after hitting work off line -- Logos didn't open.

Posts 1600
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Dec 27 2018 7:16 AM

I suggest that you call Tech Support (See Keep Smiling's post above). They can work directly with your computer via Screen Sharing.

Page 1 of 1 (15 items) | RSS