Bug RC1: Updates Available in Cloud mode

Page 1 of 1 (15 items)
This post has 14 Replies | 1 Follower

Posts 24952
Forum MVP
Dave Hooton | Forum Activity | Posted: Wed, Feb 27 2019 4:36 AM

Used Set Update Channel to Beta after a 'standard' installation with Auto Download Updates = No, restarted Logos, and was presented with the Download Logos 8 Library window. I chose Recommended.

When complete, All resources is the same as v8.2 - so no more Hidden resources!

The only problem is a download notification for 10.75 GB (the remainder of my resources).

There is an option to Cancel Download for resources "Not on this device", but it doesn't work, even after a restart. Info shows the resources as "Downloading".

Dave
===

Windows & Android

Posts 2641
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Feb 27 2019 10:16 AM

Dave,

Can you please post your logs?

Thanks,

Philana

Posts 91
David Mullens | Forum Activity | Replied: Wed, Feb 27 2019 11:15 AM

I may be very confused, but did the partial download of resources go a way? I saw the message about keeping it in Beta, but seems like its gone in the version I'm using (8.3.0018). I'm assuming that is RC1? 

If it did go away, is there any way I can keep on the Beta version that has it? Logos has completely filled up my drive again....

Thanks!

Posts 2085
LogosEmployee
Andrew Batishko (Faithlife) | Forum Activity | Replied: Wed, Feb 27 2019 11:20 AM

David Mullens:
I may be very confused, but did the partial download of resources go a way? I saw the message about keeping it in Beta, but seems like its gone in the version I'm using (8.3.0018). I'm assuming that is RC1? 

That's probably because you never explicitly set the channel to "beta". Note that this would also prevent you from receiving additional RC updates after RC 1, so you probably want to make that change.

Posts 24952
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Feb 27 2019 12:53 PM

Philana R. Crouch:
Can you please post your logs?

The first log has gone as I restarted to see if a bulk Cancel would work.

4251.LogosError.zip

Dave
===

Windows & Android

Posts 91
David Mullens | Forum Activity | Replied: Wed, Feb 27 2019 5:21 PM

Andrew Batishko (Faithlife):

David Mullens:
I may be very confused, but did the partial download of resources go a way? I saw the message about keeping it in Beta, but seems like its gone in the version I'm using (8.3.0018). I'm assuming that is RC1? 

That's probably because you never explicitly set the channel to "beta". Note that this would also prevent you from receiving additional RC updates after RC 1, so you probably want to make that change.

Right you are Andrew. Thanks! Got it taken care of. 

Posts 2641
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Thu, Feb 28 2019 3:00 PM

Dave Hooton:

Used Set Update Channel to Beta after a 'standard' installation with Auto Download Updates = No, restarted Logos, and was presented with the Download Logos 8 Library window. I chose Recommended.

Dave,

What version did you use for your "standard" installation?

Posts 2641
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Thu, Feb 28 2019 3:14 PM

Dave Hooton:

Used Set Update Channel to Beta after a 'standard' installation with Auto Download Updates = No, restarted Logos, and was presented with the Download Logos 8 Library window. I chose Recommended.

When complete, All resources is the same as v8.2 - so no more Hidden resources!

The only problem is a download notification for 10.75 GB (the remainder of my resources).

There is an option to Cancel Download for resources "Not on this device", but it doesn't work, even after a restart. Info shows the resources as "Downloading".

Dave,

Can you state the specific steps you took? What version did you start with and so forth?

Posts 24952
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Feb 28 2019 6:27 PM

Philana R. Crouch:
Can you state the specific steps you took? What version did you start with and so forth?

  1. Uninstalled 8.3 Beta 4 and deleted the Logos folder
  2. Started Custom Installation of 8.3 RC1  (8.3.0.0018)
    1. Install to D: drive
    2. Set Auto Download of Updates to NO
  3. Signed In
  4. Sync of Docs and Settings started
    1. Skip fairly quickly
  5. Logos GUI loaded
    1. No layout and Program Settings hadn't sync'd
    2. Notified of 15.4 GB download
    3. Set Update Channel to Beta
    4. Restarted
  6. "Download Your Logos 8 Library" window appeared
    1. Chose Recommended
    2. Click "Start download" button
    3. When finished, pressed button "Open Logos"
  7. Logos GUI was loaded
    1. Got Download notification for 10.75 GB
    2. Tried to Cancel Download for all resources "Not on this Device" (over 2000)
      1. Unsuccessful. After a restart all resources were still "Downloading"

Dave
===

Windows & Android

Posts 24952
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Feb 28 2019 7:29 PM

I performed another installation with Auto Download Updates set to YES (default). The end result was the same, but the process was worse. This would correspond to a default (non-custom) installation for most users (I needed Custom for the installation location)

  1. Uninstalled 8.3 RC1 and deleted the Logos folder
  2. Started Custom Installation of 8.3 RC1  (8.3.0.0018)
    1. Install to D: drive
    2. Didn't alter Auto Download of Updates (defaults to YES)
  3. Signed In
  4. Sync of Docs and Settings started --> see logos.zip
    1. I let this proceed for much longer
    2. 377 MB of resources was downloaded
    3. Skip after a few minutes
  5. Logos GUI loaded
    1. My layout loaded, and Program Settings had clearly sync'd
    2. Notified that 9 resources and 14 datasets had downloaded
    3. Indexing began for 9 resources.
    4. Download of 26 GB (!) started
      1. Cancelled it
      2. Library shows 49 resources, but only 9 had indexed.
    5. Set Update Channel to Beta
    6. Notified that 13.69 GB updates was available (Auto Download Updates still set at YES)
    7. Restarted Logos 
  6. "Download Your Logos 8 Library" window appeared --> see logos  (2).zip
    1. Chose Recommended
    2. 11.91 GB download began
      1. It was 3.4 GB previously, and I thought  the number of resources was similar
    3. Closed the window
    4. Restarted Logos
  7. Logos GUI was loaded --> see logos (3).zip
    1. Got Download notification for 10.54 GB
    2. 150 resources "On device"
    3. Indexing for 137 resources began (137 + 9 = 146)
    4. Tried to Cancel Download for 8 resources "Not on this Device"
      1. Unsuccessful.
      2. All resources were still "Downloading", even after a restart (see logos (4).zip)

6574.Logos.zip

2158.Logos (2).zip

8422.Logos (3).zip

6787.Logos (4).zip

Dave
===

Windows & Android

Posts 2085
LogosEmployee

Thanks for including all 4 of your log files.

One bug I can see is that the "Download Your Logos 8 Library" window should not be appearing after you have already run once before without cloud resources turned on. Despite many attempts, we have not yet been successful at recreating your experience with that. We'll probably have to add some additional logging and repeat the test again with another release.

Currently when you cancel a download, it will actually continue the download, and then on completion, the downloaded resource will be removed. This is a known issue that we hope to improve in the next beta cycle (although I can't make any promises as to whether or not it will actually happen).

I'm not completely sure what the expected behavior is for starting downloads with cloud resources turned off, and then turning on cloud resources and trying to cancel the download. We'll have to investigate this scenario some more.

Posts 24952
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Mar 1 2019 2:59 AM

RC1 Release Notes:
Turned off the Cloud Resources features for those who are on the stable channel. This will not affect beta users who remain on the beta channel."
The first part was true after installing RC1, and I presume it would be true if explicitly not on beta channel before updating to RC1.  The second part implies changing to the beta channel before updating to RC1, else do what I did!

Andrew Batishko (Faithlife):
Despite many attempts, we have not yet been successful at recreating your experience with that.

Seems that it would be easy to reproduce. I used Setup from the RC1 Release thread in a Administrator User account. Did you try a Custom install as above?

Andrew Batishko (Faithlife):
Currently when you cancel a download, it will actually continue the download, and then on completion, the downloaded resource will be removed.

If it only affects the resource (or resources) whose download has actually started, it is not too bad. It certainly doesn't "continue" until completion of the scheduled download.

Dave
===

Windows & Android

Posts 2085
LogosEmployee

Andrew Batishko (Faithlife):
One bug I can see is that the "Download Your Logos 8 Library" window should not be appearing after you have already run once before without cloud resources turned on.

We managed to track this issue down, and the fix will be in RC 2.

The other problem with canceling the downloads is most likely not fixed.

Posts 2641
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Mar 4 2019 11:14 AM

Andrew Batishko (Faithlife):

Andrew Batishko (Faithlife):
One bug I can see is that the "Download Your Logos 8 Library" window should not be appearing after you have already run once before without cloud resources turned on.

We managed to track this issue down, and the fix will be in RC 2.

The other problem with canceling the downloads is most likely not fixed.

This has now been fixed in 8.3 RC 2.

Posts 24952
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Mar 5 2019 2:48 AM

Updated RC1 to RC2 on default Update Channel. The "Download Your Logos 8 Library" window did not appear after setting the Channel to Beta and restarting. And, yes, there is still a large download available (10.2 GB) and cancelling does not work.

Dave
===

Windows & Android

Page 1 of 1 (15 items) | RSS