Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 7
Kimberly Tenhor | Forum Activity | Posted: Sun, Mar 24 2019 6:11 PM

Hello,

Just to let someone know, my Logos 8 desktop app would not open today. There was no error message, it just didn't respond to my clicking on it to launch it from either the dock or the Applications folder.  I tried restarting my computer several times with no change in response. I tried the Font Test and there were no errors there either. My Mac software is up to date, macOS Mojave 10.14.3.

I had to uninstall Logos and reinstall it to get it to open, based on this support page that I found somewhere in a forum:  https://support.logos.com/hc/en-us/articles/360007923512-What-to-do-if-Logos-Crashes-Mac

I lost an hour's work to this issue, so I thought I'd let you know about it and log it here in case anyone else was having issues as well.

I noticed when Logos finally opened that it had updated to 8.3 SR-3, so not sure if that was the cause or not.

Posts 29915
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Mar 24 2019 8:00 PM

Welcome! Smile Sorry you had troubles. Tongue Tied

Kimberly Tenhor:
I had to uninstall Logos and reinstall it to get it to open, based on this support page

I don't know if I agree with FL's suggestions on that page, although I do agree in your case. I am curious, however, that you mentioned that you did step #2 (check fonts) but the fix came with step #1 (update Logos). Is there a reason you went out of order? 

Kimberly Tenhor:
There was no error message, it just didn't respond to my clicking on it to launch it from either the dock or the Applications folder.

That is indicative of a corrupted (or failed) installation. Reinstalling should be the first thing to try. If a crash occurs (which isn't what happened to you), trying to load to a blank layout should be the first step. Second, would be to enable and read the logs to see if a .db file has become corrupted. 

macOS, iOS & iPadOS | Logs |  Install

Posts 7
Kimberly Tenhor | Forum Activity | Replied: Mon, Mar 25 2019 7:05 AM

Hi JT,

Thanks for your response.

JT (alabama24):
Is there a reason you went out of order?

I was trying to avoid an uninstall/reinstall as much as possible since I've never had to do that yet since I've had the software since 2015.  I had read about the fonts being a potential issue on other threads, and though I didn't recently add any fonts, I thought a simple test was easy to eliminate.

JT (alabama24):
trying to load to a blank layout should be the first step

The application wouldn't even "bounce" when I tried to launch it, let alone having it open and loading a layout.

JT (alabama24):
Second, would be to enable and read the logs to see if a .db file has become corrupted.

I did try to enable the logs and tried to open it again, but I could not find any log files had been generated.  It may have been something I did wrong in enabling them (I followed this page:  https://wiki.logos.com/diagnostic_logging) or maybe it was because it wouldn't even launch so it didn't even start any logging?  Not sure.  And since there was no support on Sunday, and my assignment is still due, it was at this point I decided to try the uninstall/reinstall, which thankfully worked.

Now that I know the uninstall/reinstall worked so easily, and everything rebuilt perfectly, I know to do that first in the future.

Posts 29915
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Mar 25 2019 11:54 AM

Kimberly Tenhor:
Now that I know the uninstall/reinstall worked so easily, and everything rebuilt perfectly, I know to do that first in the future.

In your case, reinstalling the app was the right step. Since it didn’t bounce, it wasn’t crashing and logs would not have been produced. It was a corrupted or failed installation. For an actual crash, however, reinstalling is seldom the best solution. I should point out that reinstalling the app as you did is fairly simple and was not a full reinstall. That would have been a much more significant process and should be done as a last resort. 

macOS, iOS & iPadOS | Logs |  Install

Posts 7
Kimberly Tenhor | Forum Activity | Replied: Tue, Mar 26 2019 4:08 AM

Thanks JT!  Glad to have validation that I ultimately did the right thing, and understood correctly why logs weren't being produced.  So that corruption would have occurred during the update process?  If so, it's probably not possible now to know if it happened during the download process while the app was open, or if it happened upon opening when the update was being installed, correct?

I am curious though, because the "much more significant process" was exactly my hesitation to drag the app to the Trash (uninstall it) and then redownload and install it from their website. But if that wasn't the "full" reinstall, where are the instructions to do so and in what instances would that be warranted?  So, what is the difference between what I did, and what a "full" reinstall is?

Thanks so much,

Kim

Posts 10847
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Mar 26 2019 7:42 AM

Kimberly Tenhor:
I am curious though, because the "much more significant process" was exactly my hesitation to drag the app to the Trash (uninstall it) and then redownload and install it from their website.

Deleting the app from the Applications folder does not remove your resources which are stored in the Library folder of your Home directory. Deleting and reinstalling that is a major project—depending on the size of your library.

Posts 7
Kimberly Tenhor | Forum Activity | Replied: Tue, Mar 26 2019 7:46 AM

Ah, got it.  Thanks Jack!

Posts 29915
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Mar 26 2019 8:12 AM

In addition to what Jack wrote, deleting the app also does not remove the .db files and indices. In my experience, crashes most often occur when those become corrupted. Reinstalling the app would not fix the problem. That does not appear to have been your problem. When a .db file becomes corrupted, grabbing logs of a crash should point those out. Often deleting the corrupted file and allowing Logos to rebuild is a much less painful operation than redownloading and reindexing everything! 

macOS, iOS & iPadOS | Logs |  Install

Posts 7
Kimberly Tenhor | Forum Activity | Replied: Tue, Mar 26 2019 8:31 AM

Great to know, thanks JT!

So, if that ever happens to me (and I would know this because the app would open but not build my resources, correct?) then I would turn on the logging using the instructions in that support page I found?   https://support.logos.com/hc/en-us/articles/360007923512-What-to-do-if-Logos-Crashes-Mac  

Then I would contact support before attempting to delete the corrupted file (and hope that wouldn't happen on a Sunday!)?

Thank

Posts 29915
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Mar 26 2019 11:25 AM

Kimberly Tenhor:
I would know this because the app would open but not build my resources

No... You would open the app and it would crash (shut down). In your case, it never even opened (so it didn't "crash"). 

Kimberly Tenhor:
Then I would contact support before attempting to delete the corrupted file (and hope that wouldn't happen on a Sunday!)?

For "official" help, you will need to contact FL directly (preferably by phone). Otherwise, you can create a thread in the forums, explain your issue clearly, and upload logs. I am a "quasi techie" and can sometimes diagnose issues... but there are often others who will be able to diagnose the issue quickly. The forums are not a primary means of communication with FL, but rather is a "crowd sourced" help from fellow users like us. 

macOS, iOS & iPadOS | Logs |  Install

Posts 1
Christian | Forum Activity | Replied: Wed, Mar 27 2019 6:44 PM

Thank you for your post Kimberly! I had the very same issue. The uninstall/reinstall took me less than 10 minutes.

Posts 7
Kimberly Tenhor | Forum Activity | Replied: Thu, Mar 28 2019 4:11 AM

JT (alabama24):
No... You would open the app and it would crash (shut down). In your case, it never even opened (so it didn't "crash"). 

Okay, very good to know the difference.

Thanks so much for your help JT, I appreciate it!

Posts 7
Kimberly Tenhor | Forum Activity | Replied: Thu, Mar 28 2019 4:13 AM

Sorry to hear you had the same issue Christian, but so very glad you were able to find this thread and get it resolved so quickly!  That's the main reason I posted it!

Page 1 of 1 (13 items) | RSS