Page 1 of 1 (4 items)
This post has 3 Replies | 0 Followers

Posts 25
Raffaele Paglialunga | Forum Activity | Posted: Sat, May 11 2019 6:45 AM

I have an older Iphone and I wanted to download Logos but it saying something like I need OS 11..... I believe I have an Iphone either 5 or 7.... Is there an older version of Logos I can use other than using Biblia on the net 

Posts 10043
Denise | Forum Activity | Replied: Sat, May 11 2019 2:40 PM

Not really. This need comes up periodically. Sometimes you can download an older version of an ios app, but typically not Logos. They burn bridges as quick as they can. My Accordance, Olivetree and Laridian all survive much longer on older hardware.

When you wrote 'Biblia', I assume you knew of the newer  Logos web app (app.logos.com).


Posts 298
Bernhard | Forum Activity | Replied: Sun, May 12 2019 8:34 AM

Yes, you can, download it from the list of purchased apps. If you don't own the Logos app yet, you need to temporarily borrow a newer iOS device to purchase it first, see https://community.logos.com/forums/t/175165.aspx .

Posts 10043
Denise | Forum Activity | Replied: Sun, May 12 2019 8:54 AM

Smart, Bernhard. Key is purchased panel.


Page 1 of 1 (4 items) | RSS