Logos 4 Unable to login.

Page 1 of 1 (4 items)
This post has 3 Replies | 0 Followers

Posts 5
Josh | Forum Activity | Posted: Tue, Jul 30 2019 7:46 AM

My current PC died, and I had to go back to an old XP computer. I tried using Libronix, and I am missing books that were released after my Libronix 2.1 CD's were created. After that I called support, and was told I could download Logos 4. I have it installed, but when I try and do the initial login I get an unable to login message. I also tried using app.logos.com, but it doesn't work on XP, and biblia.com doesn't have enough features. I just want access to my library.

Thank you,


Posts 1487
Myke Harbuck | Forum Activity | Replied: Tue, Jul 30 2019 7:55 AM

Did you know you can get Logos 8 for free?


Myke Harbuck
Lead Pastor, www.ByronCity.Church
Adjunct Professor, Georgia Military College

Posts 5
Josh | Forum Activity | Replied: Tue, Jul 30 2019 8:00 AM

Logos 8 doesn't run on Windows XP. My Windows 10 PC died and I pulled this one out of storage. To get me something.

Posts 13428
Mark Barnes | Forum Activity | Replied: Tue, Jul 30 2019 9:26 AM

Windows XP was launched in 2002, and Microsoft ended support for it in 2014. Because Logos requires internet connectivity to install and validate your licence, it's therefore no longer possible to install run Logos on Windows XP.

You may find that app.logos.com will work on Google Chrome on XP - if you can find an old version. Alternatively, you could try this browser: https://www.slimjet.com/ which I believe still supports XP.

This is my personal Faithlife account. On 1 March 2022, I started working for Faithlife, and have a new 'official' user account. Posts on this account shouldn't be taken as official Faithlife views!

Page 1 of 1 (4 items) | RSS