Page 1 of 1 (11 items)
This post has 10 Replies | 3 Followers

Posts 36
Michael Hyatt | Forum Activity | Posted: Thu, Sep 19 2019 4:36 AM

When I try to create a new sermon, I get a blank screen in the writing area. I am using and MacOS Catalina 10.15 Beta (19A558d).

Posts 589
Bob Deacon | Forum Activity | Replied: Thu, Sep 19 2019 7:51 AM

I have a similar problem. 

Bob Deacon

Surface Pro 6

MacBook Air (2017) Big Sur

Ipad Air 2 (ios 9.7 (0014)

Samsung A50 (9.7 907000152)

Posts 16


I'm shocked that my productivity guru would be on a beta! My productivity has been shocking under Catalina. Never again!

I have had the same problem, along with others (such as the Media Tool being blank and not being able to export my Sermons to PowerPoint) with Catalina (despite being on the Logos 8 beta program). The official response from FL will be that OS betas are not supported, which is their prerogative.

In the meantime, to deal with your problem. I go to and simply duplicate an earlier sermon that does populate in the application and then edit it in the application. For some reason, that works!

Hope that helps, and your beta secret is safe with me - I won't mention it anywhere near the FFP community!

In Christ.


Posts 36
Michael Hyatt | Forum Activity | Replied: Thu, Sep 19 2019 9:12 AM

Thanks, Rob. I am always on the “bleeding edge” of technology. Indifferent

I assumed that the Logos beta would be working to achieve compatibility with Catalina. Maybe I'm just too early.

Thanks for the workaround!

By the way, I ran the Catalina all summer on my MacBook Pro without any issues, so I decided to install it on my iMac. I haven't had any issues other than this.

Posts 16

I'm sure you are! I feel like I've been hemorrhaging all summer!

Quite apart from the incompatibility with Logos, I've also suffered from iCloud Drive issues (although to be fair that's been syncing issues rather than loss of data). But I guess most other things have been working OK.

As a Salvation Army officer with two sermons a week to write, maybe it's the Logos incompatibility that's made me feel the most unproductive!

Here's to the GM of Catalina and a speedy update from Logos with Catalina compatibility.

Happy preaching!

Posts 36
Michael Hyatt | Forum Activity | Replied: Fri, Sep 20 2019 3:01 AM

Rob, I tried your workaround, but it still doesn’t work. The sermon shows up in Docs, but when I try to load it in the app, no text appears.

It's somewhat of an improvement. At least it shows up. I just can't see the text or edit it. In the meantime, I will just use the online version.

Posts 16

Hi Michael

Maybe try updating to the latest Logos beta (8.8 Beta 4 ( And ensure the sermon you are duplicating is one that you can see fully in the app.

You might also discover that the one you write in the online app will then show up fully in the desktop app. That happened to me at one point and that seemed to free up some of the other problems with sermons. Not sure of course if it was the creation and completion of the sermon in the online app that did it or a beta update.

In the meantime, join me in praying (with a number of other users!) for Catalina support!

Posts 36
Michael Hyatt | Forum Activity | Replied: Fri, Sep 20 2019 4:30 AM

I'm on beta 4, but I'm getting the same result. I'm thinking I might just downgrade from macOS Catalina. 

Posts 496
Adam Borries (Faithlife) | Forum Activity | Replied: Fri, Sep 20 2019 8:04 AM

This is a known issue on Catalina, which affects the Sermon and Atlas panels in Logos. We are working on a fix, which we will have ready in time for the stable release of Catalina. 

Adam Borries | Product Manager, Logos desktop application

Message me on >>

Posts 36
Michael Hyatt | Forum Activity | Replied: Fri, Sep 20 2019 8:24 AM


Posts 36
Michael Hyatt | Forum Activity | Replied: Sat, Sep 28 2019 4:32 AM

This is now fixed in! Kudos, guys.

Page 1 of 1 (11 items) | RSS