BUG: 8.9 Beta 2 Highlights and Notes Extremely Slow

Page 1 of 1 (8 items)
This post has 7 Replies | 2 Followers

Posts 3056
David Taylor Jr | Forum Activity | Posted: Sun, Oct 20 2019 5:21 AM

When highlighting text it takes 2-3 seconds before the highlight will show up. I would post logs, but it seems that since updating to 8.9 beta no logs are being recorded, odd.

Teacher, Ministry Leader, Student, Author, Husband

How to upload logs

Visit My Site: Reformed Truths

Posts 25032
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Oct 20 2019 4:20 PM

Look in C:\Users\Username\AppData\Local\Faithlife\Logs\ (since version 8.4)

Logs may not help in this situation.

How are u highlighting?  Does it make a difference how u highlight? How many highlights/notes in your Notes tool?

Dave
===

Windows & Android

Posts 3056
David Taylor Jr | Forum Activity | Replied: Sun, Oct 20 2019 4:47 PM

Dave Hooton:

Look in C:\Users\Username\AppData\Local\Faithlife\Logs\ (since version 8.4)

Logs may not help in this situation.

How are u highlighting?  Does it make a difference how u highlight? How many highlights/notes in your Notes tool?

Well that would answer why I don't have logs. As far as highlighting I have tried it with shortcut keys, the highlight panel, and the selection popup.  It is the same result each time.  Total in my tool I have combined 4800 notes/highlights.

71206.Logos.zip

Teacher, Ministry Leader, Student, Author, Husband

How to upload logs

Visit My Site: Reformed Truths

Posts 25032
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Oct 20 2019 9:44 PM

David Taylor Jr:

I cannot see where that lag occurs. When I compare my log with yours, highlighting events take about the same time.

But log comparison, would indicate you have a much slower computer than mine

  • Milestone 1 (line 96)  2s vs.40s
  • Milestone 2 (line 169)  3s vs. 46s
  • Milestone 3 (line 241)  4s vs. 56s
  • Show Main Window   8.4s vs. 74s (for some reason your log states 109s elapsed, but I'm measuring from the log start time)
    • blank window
  • Finished startup  12.2  vs.  120s    (for some reason your log states 153s elapsed, but I'm measuring from the log start time)
    • I have loaded 10 panels vs 20

The first three milestones cover the same software events. You have a First Sync event after that, whereas I don't (probably different At Startup options), but it only takes about 2.5s.

You have a about 110 Visual Filters taking from 4s to 8s to cache, but that does seem to interfere with Highlighting

Dave
===

Windows & Android

Posts 3056
David Taylor Jr | Forum Activity | Replied: Mon, Oct 21 2019 5:22 AM

Dave Hooton:

David Taylor Jr:

I cannot see where that lag occurs. When I compare my log with yours, highlighting events take about the same time.

But log comparison, would indicate you have a much slower computer than mine

  • Milestone 1 (line 96)  2s vs.40s
  • Milestone 2 (line 169)  3s vs. 46s
  • Milestone 3 (line 241)  4s vs. 56s
  • Show Main Window   8.4s vs. 74s (for some reason your log states 109s elapsed, but I'm measuring from the log start time)
    • blank window
  • Finished startup  12.2  vs.  120s    (for some reason your log states 153s elapsed, but I'm measuring from the log start time)
    • I have loaded 10 panels vs 20

The first three milestones cover the same software events. You have a First Sync event after that, whereas I don't (probably different At Startup options), but it only takes about 2.5s.

You have a about 110 Visual Filters taking from 4s to 8s to cache, but that does seem to interfere with Highlighting

It's odd, they showed up pretty much instantly before the latest update.

Teacher, Ministry Leader, Student, Author, Husband

How to upload logs

Visit My Site: Reformed Truths

Posts 3056
David Taylor Jr | Forum Activity | Replied: Tue, Oct 22 2019 2:43 PM

Any thoughts anyone?

Teacher, Ministry Leader, Student, Author, Husband

How to upload logs

Visit My Site: Reformed Truths

Posts 3154
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Oct 22 2019 3:32 PM

Hi David,

Your log file indicates that there is a 34 second delay between the time when you try to start the application and when the application first gets the chance to log the first line of the log file. There is very little that actually occurs in the period of time that is dependent on the Logos application. This usually indicates that something else is running on your system that is using a lot of system resources (very heavy use of the hard-drive seems most likely). This seems to be backed up by a lot of log messages indicating longer than expected times for a very broad variety of unrelated tasks in the application.

 

Posts 3056
David Taylor Jr | Forum Activity | Replied: Wed, Oct 23 2019 7:37 PM

I don't know what changed, but the problem does not exist with beta 3 that dropped today.

Teacher, Ministry Leader, Student, Author, Husband

How to upload logs

Visit My Site: Reformed Truths

Page 1 of 1 (8 items) | RSS