I can't highlight any more. HELP!!!

Page 1 of 2 (28 items) 1 2 Next >
This post has 27 Replies | 1 Follower

Posts 138
s f-k | Forum Activity | Posted: Tue, Jun 22 2010 4:27 PM

For some reason I can't highlight in L4 any more. Not sure what happened.

My process: 1. Select the text I want highlighted. 2. Click the highlight color and style.

Result: Nothing! I do notice, however, that one of the three, little overlapping circles flashes (green, I think) when I click the highlighter. But nothing appears on the text.

Ideas?

Costa Rica

ESEPA Seminary

Posts 4768
RIP
Fred Chapman | Forum Activity | Replied: Tue, Jun 22 2010 4:33 PM

Do you have highlighting turned on?

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 5:22 PM

I don't recall ever having turned it on, and it used to work just fine. I'm not even sure I know how to turn it on.

Costa Rica

ESEPA Seminary

Posts 34363
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Jun 22 2010 5:26 PM

Stefan Feliz-Kent:

I don't recall ever having turned it on, and it used to work just fine. I'm not even sure I know how to turn it on.

 

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 5632
Todd Phillips | Forum Activity | Replied: Tue, Jun 22 2010 6:04 PM

You shouldn't have to turn anything on.  In fact, if I turn off all the palletes listed on the Visual Filters menu, it turns them back on when I apply a highlight to a resource.  Plus, in resources without any highlighting, there isn't anything listed in the Visual Filters menu to turn on.

 

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 6:06 PM

Wow, I've never seen so many options in that drop-down menu! Here's what I get, in 3 different resources...

 

Costa Rica

ESEPA Seminary

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 6:09 PM

Todd Phillips:

You shouldn't have to turn anything on.  In fact, if I turn off all the palletes listed on the Visual Filters menu, it turns them back on when I apply a highlight to a resource.  Plus, in resources without any highlighting, there isn't anything listed in the Visual Filters menu to turn on.

 

So what's the deal? Why has it stopped working?

Costa Rica

ESEPA Seminary

Posts 5632
Todd Phillips | Forum Activity | Replied: Tue, Jun 22 2010 6:11 PM

Stefan Feliz-Kent:

Todd Phillips:

You shouldn't have to turn anything on.  In fact, if I turn off all the palletes listed on the Visual Filters menu, it turns them back on when I apply a highlight to a resource.  Plus, in resources without any highlighting, there isn't anything listed in the Visual Filters menu to turn on.

 

So what's the deal? Why has it stopped working?

Which resource are you trying to add highlighting to?

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 6:13 PM

A Spanish Bible, NA27 and a Septuagint. The screen shots are above.

Costa Rica

ESEPA Seminary

Posts 19356
Rosie Perera | Forum Activity | Replied: Tue, Jun 22 2010 6:17 PM

Stefan Feliz-Kent:
Wow, I've never seen so many options in that drop-down menu!

What you see will depend on what resource is open and what Notes files you have. As you can tell, MJ (Martha) makes extensive use of Notes. That's why she has so many items on her menu.

As has been mentioned before, the Highlighting options on the Visual Filters menu will only show up if you have any highlighting applied in that resource. When you are trying to apply highlighting, what are you doing? What happens when you select some text in a resource, open your Highlighting tab (Tools > Highlighting), and click on one of the highlighting styles in it?

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 6:21 PM

Thanks for that info, Rosie.

Rosie Perera:
When you are trying to apply highlighting, what are you doing?

See my original post.

Costa Rica

ESEPA Seminary

Posts 5632
Todd Phillips | Forum Activity | Replied: Tue, Jun 22 2010 6:23 PM

Posting a log file would help us see what Logos is doing when you try to highlight. 

(If you're not already logging, see here: http://wiki.logos.com/Diagnostic_Logging. To post a log, see here: http://wiki.logos.com/Uploading_Logs)

 

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 6:30 PM

Ok. Let me see what I can do. Thanks.

Costa Rica

ESEPA Seminary

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 6:50 PM

Here it is.

8345.Logos4_22-6-10.zip

Did it work?

Costa Rica

ESEPA Seminary

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 6:56 PM

.

Costa Rica

ESEPA Seminary

Posts 5632
Todd Phillips | Forum Activity | Replied: Tue, Jun 22 2010 6:58 PM

Stefan Feliz-Kent:
Did it work?

Yes.

This is logged several times in the logs:

2010-06-22 19:46:23.9869    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette NO_PALETTE; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:23.9869    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette Emphasis Markup; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:23.9869    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette Highlighter Pens; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:23.9869    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette Solid Colors; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:23.9869    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette Inductive; expect to remove filter after raising resource settings changed.

I don't know what it means...Logos will have to add their voice.

I would try creating a new highlighting palette and add some new styles to it, and see if that worked in the mean time.

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 19356
Rosie Perera | Forum Activity | Replied: Tue, Jun 22 2010 7:01 PM

Stefan Feliz-Kent:

Here it is.

8345.Logos4_22-6-10.zip

Did it work?

Yes it worked. Here are the relevant lines from the log file which show Highlighting is unable to complete its task, but I'm not sure why it is failing. Someone from Logos will have to take a look at this:

2010-06-22 19:46:21.5181 1 Info HighlightingUserVisualFilterProvider No text range intersection data found for palette NO_PALETTE; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:21.5181 1 Info HighlightingUserVisualFilterProvider No text range intersection data found for palette Emphasis Markup; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:21.5181 1 Info HighlightingUserVisualFilterProvider No text range intersection data found for palette Highlighter Pens; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:21.5181 1 Info HighlightingUserVisualFilterProvider No text range intersection data found for palette Solid Colors; expect to remove filter after raising resource settings changed.
2010-06-22 19:46:21.5181 1 Info HighlightingUserVisualFilterProvider No text range intersection data found for palette Inductive; expect to remove filter after raising resource settings changed.

It might be due to a corrupted VisualFilter.db (in Logos4\Documents\{random}\Documents\VisualFilter). You could try making a copy of that file somewhere else (just in case) and deleting the original and seeing if it gets regenerated and fixes the problem. Or the other file that might be the problem could be VisualMarkup.db (in Logos4\Documents\{random}\VisualMarkup). But be careful messing around with these files. They are backed up on the server, but they are NOT designed to have users messing with them, and we MVPs have not been instructed on which ones are safe to delete in case problems arise with them. So I'd prefer that you wait until business hours and talk to Logos Customer Support about the problem. Give them this info I've dug up from the log file (or they might want you to email the log file to them, or you could point them to this thread on the forum).

Posts 138
s f-k | Forum Activity | Replied: Tue, Jun 22 2010 7:23 PM

Alright; I'll send this info to Logos tomorrow.

Thanks a bunch for your help, everyone! It's appreciated. Yes Paradise

Costa Rica

ESEPA Seminary

Posts 27419
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Jun 23 2010 1:35 AM

Rosie Perera:
Yes it worked. Here are the relevant lines from the log file which show Highlighting is unable to complete its task,

You also get those Info lines when it works! eg. from my log after successfully applying Yellow highlighter:-

2010-06-23 18:29:57.3750    1    Info    PanelViewModel    Got panel settings for Preferences: CollapsedSections=SolidColor;Emphasis;Inductive|StyleName=YellowHighlighter
2010-06-23 18:29:57.6250    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette NO_PALETTE; expect to remove filter after raising resource settings changed.
2010-06-23 18:29:57.6250    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette Emphasis Markup; expect to remove filter after raising resource settings changed.
2010-06-23 18:29:57.6250    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette Solid Colors; expect to remove filter after raising resource settings changed.
2010-06-23 18:29:57.6250    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette Inductive; expect to remove filter after raising resource settings changed.
2010-06-23 18:29:57.6250    1    Info    HighlightingUserVisualFilterProvider    No text range intersection data found for palette 51dd75b6-0786-4948-aee9-61a3521bd57f; expect to remove filter after raising resource settings changed.

Dave
===

Windows 11 & Android 8

Posts 4077
Melissa Snyder | Forum Activity | Replied: Wed, Jun 23 2010 11:26 AM

Stefan Feliz-Kent:

For some reason I can't highlight in L4 any more. Not sure what happened.

My process: 1. Select the text I want highlighted. 2. Click the highlight color and style.

Result: Nothing! I do notice, however, that one of the three, little overlapping circles flashes (green, I think) when I click the highlighter. But nothing appears on the text.

Ideas?

Stefan,

Are you using the Logos 4 Spanish User Interface? If you are, does the problem only occur with pre-defined styles, not custom styles?  If this is the case, the problem will be fixed in version 4.0d. Changing to the English UI is the current workaround.

Page 1 of 2 (28 items) 1 2 Next > | RSS