Logos 4 Problem

Page 1 of 1 (11 items)
This post has 10 Replies | 1 Follower

Posts 23
Mike | Forum Activity | Posted: Mon, Jun 28 2010 11:11 AM

Hello,

Ever since the recent update to version Pre-Release Alpha 22.1 for Mac I cannot sustain the operation of the program.

What this means is that when I select the program from the dock or from the applications folder it boots up fine, then closes itself.  Not too happy about this ...

I sent a help request to Logos along with my log files, they suggested I post here to see if anyone else is having this issue. 

Meanwhile, I'm dead in the water and I have a study to complete by this Wednesday ...

 

Thanks,

 

Mike

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Jun 28 2010 11:14 AM

Michael,

We just released Alpha 23. You can download it from www.logos.com/logos4mac and see if it fixes your issue. If not, please post your logs in this thread, specifically your Console Log, which is most helpful in the case of sudden crashes. You can find some information on how to post your logs by looking at the FAQ link in my signature, item #6.

Thanks,

Tom

Mobile Development Team Lead

Posts 23
Mike | Forum Activity | Replied: Mon, Jun 28 2010 11:52 AM

Tom,

Downloaded Alpha 23 and installed it - same issue exists.  I've attached the logs.

 

Mike30511.Archive.zip

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Jun 28 2010 12:13 PM

Michael,

Can you attach your layouts.db to this thread?

It is located at: /Users/duganmrcs/Library/Application Support/Logos4/Documents/12chjnd2.80e/LayoutManager/layouts.db

We need to figure out which resource is trying to load that is causing the app to crash.

As a work around, after you post this file, you can rename it to layouts_old.db and see if you get up and running again.

Thanks,

Tom

Mobile Development Team Lead

Posts 23
Mike | Forum Activity | Replied: Mon, Jun 28 2010 12:24 PM

Tom,

Here you go ...5873.layouts.db

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Jun 28 2010 12:35 PM

Thanks Michael,

With your layouts.db the app crashes directly on my machine too. I'll take a look.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Jun 28 2010 2:19 PM

Michael,

I've submitted a bug for this. This is a bug that could potentially affect the Windows users to, so we'll have to create a fix and do an update.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Jun 28 2010 5:26 PM

Michael,

Did you try deleting the layouts.db file and restarting? Will that at least get you up and running?

Mobile Development Team Lead

Posts 23
Mike | Forum Activity | Replied: Tue, Jun 29 2010 2:31 PM

Tom,

No - hits forehead!  So, I did, deleted the app as well, downloaded new app from Logos, it is now downloading 2Gb of data.  Good thing I have a fast network... I'll let you know if I am back up and running once the application has finished.

 

Mike

Posts 23
Mike | Forum Activity | Replied: Tue, Jun 29 2010 6:52 PM

Tom,

Ok, good to go!  Lets go one BIG sigh of relief!  I'd be really interested in knowing what caused the db file to be corrupted.

Thanks again!

Mike

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Wed, Jun 30 2010 9:32 AM

Mike,

You didn't do anything. Some reorganizing of our code caused a bug to creep in which was leading to the crash which you were experiencing. We've fixed the code in question and it will be in the next release.

Mobile Development Team Lead

Page 1 of 1 (11 items) | RSS