Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 384
PJ | Forum Activity | Posted: Thu, May 21 2020 9:32 PM

Last week Thrusday the 14th Windows 10 updated unexpectedly. After the update all my applications started to crash. I even lost a few files. As I was in the middle of several projects with a deadline for Sunday I decided to do the drastic. I made a BackUp of my complete Logos installation and did a clean installation of Windows (10 Pro Build 18363)

I installed Logos and got it up and running. As I didn't had the time to download 45G of data neither the speed to complete it in time I tried all possible configurations to get it to work. The reason is because each and everytime Logos opened it crashed around 10 seconds later. The log files gave me a hint, "Invalid database". So I started to kind of debug to figure out what it could be. I ended up realising that each and every db in Data and Document folders seem to be corrupt. I did not try to validate this by opening my databases with a SQLLiteBrowser. I had only one thing in mind, I need to get Logos running to complete my work. (The online app was not an option as it took almost 5 minutes, thats how it seemed to be under presure, to open a resource or do a search)

I tried to copy, scan, you name it, I tried every possible way to get my resources back in to Logos. I eventually ended up downloading them all. It's one week and one day later and everything seem to be downloaded and indexed.

Finally I can start to work again ... right-click in ESV, click on a Greek Lemma ... and hang... hang ... crash.

Error detail: SQLiteException: unable to open database file: unable to open database file

The PronunciationsResourceCore seem to be the sinner as you will see the confession in my logfiles.

Currently I'm running Logos on a custom install on a seperate partition as this is the only conffiguration I got this far. It's also the fastest way to recover from a complete system crash. I'm tired of struggling ... I know I'm only missing something small, but can't figure it out.

And then again, I have a deadline of 10 Sermons starting this Sunday. While I wait for a genius solution I'm going to try and repair Logos. If not working I'll backup Users, Documents and Data Folders, reinstall Logos. Copy the Users, Document and Data Folder back or Scan for Resources without copying the Data folder.

May my cry for help be answered ... any help would be appreciated.

3757.Logos.zip

Posts 23232
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, May 21 2020 10:45 PM

Sorry to hear you are having problems.

Do you have a Logos.log file as well?

If so, please upload it.

And, under Windows, have you checked the disk for errors? The fact that all your applications started crashing suggests this may be some sort of system-wide problem

Posts 384
PJ | Forum Activity | Replied: Thu, May 21 2020 11:00 PM

Thank for response Graham,

..\AppData\Local\Faithlife\Logs\Logos\cef.log

I'm rebuilding the Index (53%) so I copied the data to cef.txt as the log file is locked when logos is open. If you are referring to another log file please inform me on the location.

Thanks for the help

6014.cef.zip

Posts 384
PJ | Forum Activity | Replied: Thu, May 21 2020 11:05 PM

Graham Criddle:
have you checked the disk for errors?

Yes, when I installed Windows I checked everything.

All other applications are working again, it's only Logos that doesn't.

As a last possible solution I'll take complete ownership of the Logos Directory and Files if the Indexing doen't work.

I'm desperate, I'll try anything.

Not that my preparation is dependent on Logos, but this is my goto Library to be a responsible interpreter of the voice of the Lord.

Posts 384
PJ | Forum Activity | Replied: Thu, May 21 2020 11:18 PM

After Rebuilding the Index it's still not working.

I deleted all log files so I can have newly created logs when it crash.

Find them attached.0045.Logos.zip

Posts 23232
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, May 21 2020 11:21 PM

PJ:
If you are referring to another log file please inform me on the location.

I am referring to a file called Logos.log - it should be at the same location as the others.

If you are not seeing it, it probably means you don't have full diagnostic logging enabled.

See https://support.logos.com/hc/en-us/articles/360027869132 for details on how to invoke this - either one-time or permanently.

Posts 384
PJ | Forum Activity | Replied: Thu, May 21 2020 11:40 PM

Graham Criddle:
If you are not seeing it, it probably means you don't have full diagnostic logging enabled.

This is weird, I actually did this almost 10 times till this morning to try and find the issue,

this is the first time it is available, here it is

1007.Logos.zip

Posts 23232
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, May 22 2020 12:10 AM

The file the log is complaining about is GREEK-LEMMAS-KOINE.lbsprn

which you should find in L:\Logos\Data\wzjxggrt.i4i\ResourceManager\Resources

Try deleting that and see if it helps.

A couple of things:

  1. This error didn't actually seem to cause a crash - it would be worth looking in Windows Event Viewer for a crash event at the relevant time
  2. You are using a drive L:. What sort of drive is this, is it an internal or external device?

Posts 384
PJ | Forum Activity | Replied: Fri, May 22 2020 12:34 AM

Graham Criddle:
GREEK-LEMMAS-KOINE.lbsprn

There was no such file named exactly like this. There was a GreekLemmasKoine.lbsprn file.

I deleted it and downloaded it again.

It's working ...

You are a true Genius ... thanks for your professional help.

I appreciate it with all my heart.

Posts 23232
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, May 22 2020 12:52 AM

PJ:

It's working ...

You are a true Genius ... thanks for your professional help.

That's so good to hear - great news

And  apologies for the incorrect file name - I used the internal name not the file name itself.

Hope you are able to successfully complete the work you need to do

Posts 384
PJ | Forum Activity | Replied: Fri, May 22 2020 2:26 AM

Actually it seems not all to be resolved ...

I did a WordStudy on ὑπέρ just to test.

When I click the Close Button on the WordStudy Panel the application crash.

2337.Logos.zip

Posts 23232
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, May 22 2020 2:37 AM

Sorry to hear that - this was related to the file ARAMAICPRONUNCIATIONSBUTH - hopefully removing that will get things working again

But I am concerned there is a deeper, underlying, problem here.

I recognise you are under a tight schedule at the moment but when you have the time I would encourage you to contact Customer Services and ask them to take a look

Posts 384
PJ | Forum Activity | Replied: Fri, May 22 2020 3:48 AM

There's a pattern emerging indicating that all resources with a "pronunciation" in the filename are somehow affected by what ever manifest these errors.

I searched them all and deleted them. After downloading those files again the system seem to be stable again. I hope this resolved it. If not I'll contact support.

Thanks for your time and help.

Page 1 of 1 (13 items) | RSS