Search Fail on some Resources

Page 1 of 1 (17 items)
This post has 16 Replies | 2 Followers

Posts 384
PJ | Forum Activity | Posted: Mon, Jul 27 2020 8:48 AM

I have a problem with some of my Resources like the ESV and The Lexham Cultural Ontology Glossary.

When doing any Inline Search it returns no results and it doesn't show up in any relevant Search Panel.

I completely reinstalled Logos, did a ReIndex of each resource separately and a complete index build, nothing solved the problem.

What else do I need to check?

Posts 22833
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Jul 27 2020 9:53 AM

Please post a screenshot of an Inline Search in the ESV not returning any results

And, in general, it is rare that a reinstall fixs this type of issue

Posts 3018
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Jul 27 2020 12:55 PM

PJ:

I have a problem with some of my Resources like the ESV and The Lexham Cultural Ontology Glossary.

When doing any Inline Search it returns no results and it doesn't show up in any relevant Search Panel.

I completely reinstalled Logos, did a ReIndex of each resource separately and a complete index build, nothing solved the problem.

What else do I need to check?

What are searching for?

And which of these options is selected?

Posts 3018
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Jul 27 2020 1:30 PM

PJ:

I have a problem with some of my Resources like the ESV and The Lexham Cultural Ontology Glossary.

When doing any Inline Search it returns no results and it doesn't show up in any relevant Search Panel.

I completely reinstalled Logos, did a ReIndex of each resource separately and a complete index build, nothing solved the problem.

What else do I need to check?

PJ,

Can we also get your logs? Follow the instructions in my post signature to get them.

Posts 384
PJ | Forum Activity | Replied: Mon, Jul 27 2020 8:54 PM

Graham Criddle:

Please post a screenshot of an Inline Search in the ESV not returning any results

And, in general, it is rare that a reinstall fixs this type of issue

Philana R. Crouch:

What are searching for?

And which of these options is selected?

Anything I search for in any option fails.

Whether I use the Context Menu or entering a Search manually doesn't matter.

6116.Logos.28.07.2020.zip

Posts 25739
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Jul 28 2020 5:51 AM

PJ:

The Indexer log would have been useful, as you get results for some bibles (15 out of  80 or more, given your large resource count). Please upload if you have one, or use command Rebuild Bible Index with logging already initialised, and upload the log.

Dave
===

Windows 10 & Android 8

Posts 384
PJ | Forum Activity | Replied: Tue, Jul 28 2020 10:09 AM

Dave Hooton:
use command Rebuild Bible Index with logging already initialised, and upload the log

2161.LogosIndexer.zip

Posts 3018
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Jul 28 2020 1:12 PM

PJ:

I have a problem with some of my Resources like the ESV and The Lexham Cultural Ontology Glossary.

When doing any Inline Search it returns no results and it doesn't show up in any relevant Search Panel.

I completely reinstalled Logos, did a ReIndex of each resource separately and a complete index build, nothing solved the problem.

What else do I need to check?

I've written up a bug report, thank you for providing the requested information.

Posts 8244
LogosEmployee

PJ:
I completely reinstalled Logos, did a ReIndex of each resource separately and a complete index build, nothing solved the problem.

This probably already happened as a side-effect of the uninstall but I would still recommend deleting the following folder, restarting Logos, let it reindex, and post the LogosIndexer.log if you are still experiencing problems: C:\Users\PJ Kotze\AppData\Local\Logos\Data\tama4nvg.xto\LibraryIndex\

Posts 384
PJ | Forum Activity | Replied: Tue, Jul 28 2020 10:23 PM

Bradley Grainger (Faithlife):
This probably already happened as a side-effect of the uninstall but I would still recommend deleting the following folder, restarting Logos, let it reindex

Thanks, Bradley, it's working.

I'm curious as to why this fixed the problem.

I thought that the first indexing process after installation should have taken care of this or any other Rebuild I did later. The only thing I didn't try was to delete the LibraryIndex folder. Why did I need to delete the folder to fix it? Should I always try this in the event of such an error?

Just to be clear on the history of this error. I re-Installed Logos to fix another problem with Biblical People not working. I discovered that Biblical People doesn't like a custom path, it only work in the default installation directory. Logos was on a partition on my C drive dedicated to Logos only. It always worked but suddenly crashed on any Biblical People Guide. The re-installation fixed this error but then after installation the ESV and other Resource errors started. This error did not exist before reinstallation.

Thanks again, you made my day, now I can explore the depths of the Word with peace.

Posts 384
PJ | Forum Activity | Replied: Wed, Jul 29 2020 12:18 AM

Crying O no. . . , just discovered that my Biblical People crash Logos again.

4214.Logos28.07.2020.BP.zip

Posts 25739
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Jul 29 2020 4:01 PM

PJ:
I thought that the first indexing process after installation should have taken care of this or any other Rebuild I did later. The only thing I didn't try was to delete the LibraryIndex folder. Why did I need to delete the folder to fix it? Should I always try this in the event of such an error?

The ResourceAuditLog... file from the first set of logs showed me that you have over 6000 resources, but the Indexer log from the Bible indexing stated that the Library index only had 2139 resources! Which means that the Library index was corrupt and has to be deleted to fix it (Bradley probably knew how many resources you have from your Account details at Faithlife).

The Indexer log from your later post now shows you have 6001 indexed resources.

Dave
===

Windows 10 & Android 8

Posts 25739
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Jul 29 2020 4:16 PM

PJ:
I discovered that Biblical People doesn't like a custom path, it only work in the default installation directory. Logos was on a partition on my C drive dedicated to Logos only. It always worked but suddenly crashed on any Biblical People Guide. The re-installation fixed this error..

PJ:
Crying O no. . . , just discovered that my Biblical People crash Logos again.

There is nothing wrong with a custom path, as I always install Logos in a partition of the System drive. The failure seems to occur in a Biblical People section of a Guide, so it would help to know:

  • is there a specific passage that causes the crash?
  • does Bible Search now work correctly?

Dave
===

Windows 10 & Android 8

Posts 8244
LogosEmployee

PJ:
I thought that the first indexing process after installation should have taken care of this or any other Rebuild I did later. The only thing I didn't try was to delete the LibraryIndex folder. Why did I need to delete the folder to fix it? Should I always try this in the event of such an error?

Deleting the folder is usually not necessary; however, there are some cases where the LibraryIndex can get out-of-sync with your library in an unrecoverable way. I posted some more details here: https://community.logos.com/forums/p/191995/1107770.aspx#1107770

Posts 8244
LogosEmployee

PJ:

Crying O no. . . , just discovered that my Biblical People crash Logos again.

4214.Logos28.07.2020.BP.zip

It looks like you have a corrupt resource file. Tech Support has a script that can scan your drive and check the resource files; I would recommend contacting them, referencing this thread, and getting that scan done.

Posts 384
PJ | Forum Activity | Replied: Fri, Jul 31 2020 7:31 AM

Bradley Grainger (Faithlife):
It looks like you have a corrupt resource file. Tech Support has a script that can scan your drive and check the resource files;

I did make contact with Tech Support a view weeks back. The script is unavailable as google give a message "No Preview Available. File is in Owners Trash." I notified them and they are investigating. I also notified them last week that my Guide is working again after reinstallation. The problem is that sorting one issue developes another.

I decided to go the really hard way and wiped everyting Logos related from my laptop and then reinstall and download everything. This will take about a week to complete. I'll just use the webapp untill everything is back to normal.

If after this step it doesn't work I'll make contact again.

Thanks for the help.

Posts 384
PJ | Forum Activity | Replied: Fri, Jul 31 2020 7:34 AM

Dave Hooton:

  • is there a specific passage that causes the crash?
  • does Bible Search now work correctly?

When I can search I can't use Biblical People and when I get Biblical People to work I can't search. It is not related to a specific passage, I tried random places with unrelated people across the bible.

Page 1 of 1 (17 items) | RSS