Video player not capturing mouse clicks on 2019 MacBook Pro laptop with Catalina

Page 1 of 1 (4 items)
This post has 3 Replies | 1 Follower

Posts 22
Robert Sussland | Forum Activity | Posted: Wed, Nov 25 2020 10:33 PM

I have a MacBook Pro, macOS Catalina v 10.5.7

Playing Mobile Ed videos has been incredibly frustrating -- the videos won't play. After some experimentation, I found that my mouse clicks weren't registering anywhere in the embedded QuickTime player. I could easily start and pause the video by pressing the space bar, but if I tried to press the right arrow with my mouse the video won't start. I also can't pause the video, make the video full screen, none of the mouse controls work. 

Unfortunately the ability to control the player via the keyboard is very limited. For example, if I want to replay something, I can't do that, I have to close the entire window, open a new window, press the space bar, and wait to reach the point I wanted to see again. 

I also notice one other thing. If I try to launch the course from the course, the mouse won't register in the player no matter what I do. If I find the videos resource in the library and try to play the video from that, then also no mouse clicks will register. But if I open the book for the course from the resource pane and click on the link to open a video then clicking will sometimes work, but often the player opens with different dimensions. Subsequent plays will not catch clicks, so I need to close the video pane, go back to the book resource and click on a video image to open the video resource pane again and then the click will work the first time

I have QuickTime build 1015.2.1

This happens with every single course, whether the Quickstart for Logos 9, or the LA171, or any other course. 

This has significantly impeded my ability to take the classes, as it means I can't pause the player, make it full screen, or go back and replay a section of the video. It also means my Logos app doesn't remember the progress I made in the course since I can only take the courses from the book resource rather than from the course object.

Posts 22
Robert Sussland | Forum Activity | Replied: Fri, Nov 27 2020 10:52 PM

In case anyone has the same issue, I believe I found the problem. In my system I have scaled display of the panels and this sometimes causes the visual position of the mouse pointer to be above where the click is sent. I noticed this when scrolling through a list, the list item would be highlited below the position of my mouse pointer.  A decent fix for this problem is to change the scale of the window using command+ and command- so that the mouse pointer again accurately shows the position of where clicks are fired. Of course this undoes the benefit of the display scaling, but at least it makes the videos usable and the rescale is only applied to the panel containing the video player. 

Of course a better fix would be to correctly implement the display scaling feature so that mouse clicks are sent at the position of the current mouse, but the course videos are usable for me now.

Posts 9138
LogosEmployee

This is a known bug with the video player and content scaling on macOS that's already fixed in v9.1 (currently in beta testing: https://wiki.logos.com/9.1_Beta_2).

Posts 22
Robert Sussland | Forum Activity | Replied: Sat, Nov 28 2020 3:22 PM

Thanks, that's good to hear!

Page 1 of 1 (4 items) | RSS