Performance Issue with MacBook M1 Chip

Page 1 of 1 (15 items)
This post has 14 Replies | 4 Followers

Posts 6

Hey.  I've done quite a bit of reading in the forums, and it seems everyone is generally having a good experience with Logos 9 and the new Macs with the M1 chip, but I am not.  Everything works, just with a horrible stutter, lag, whatever you'd like to call it.  Simply scrolling in an open book is horribly choppy.  I had no issues installing, and I upgraded from an older MacBook Air with lower specs than the new M1 MacBook Air I just purchased and in everything I do, I've noticed a great performance increase, with Logos being the exception.  I thought at first it was just where Logos was indexing my library; no big deal, but even when it's finished, there is a lag to the point where it's just not feasible to use the sermon manager.  This type of performance issue is only happening with Logos 9.  Surely someone else out there is experiencing this.  Any information or advice would be greatly appreciated.

MacBook Air M1, 8GB RAM, 256GB SSD

Big Sur 11.0.1

Logos 9.1.0.0018

Logs are attached.

Posts 25971
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Dec 15 2020 2:03 PM

Some people have reported improvements after upgrading to Mac OS 11.1

Worth a try.

Posts 6
Johnathan Bass | Forum Activity | Replied: Tue, Dec 15 2020 3:14 PM

  Thanks, I will try that and report back. 

Posts 6
Johnathan Bass | Forum Activity | Replied: Tue, Dec 15 2020 11:28 PM

Upgraded to 11.1 and it’s working much better. Thanks for the suggestion!

Posts 25971
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Dec 15 2020 11:59 PM

Johnathan Bass:

Upgraded to 11.1 and it’s working much better. Thanks for the suggestion!

That’s great news - thanks for letting us know

Posts 30656
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Dec 16 2020 6:22 AM

I don't use the sermon editor, and I <rarely> use the homepage. I can confirm the improvement on the latter. Smile

macOS, iOS & iPadOS | Logs |  Install

Posts 10
Matthew Russell | Forum Activity | Replied: Mon, Jan 24 2022 7:10 AM

Hey Johnathan, 

I am planning on buying the new M1 air next week for work, but my one concern was its ability to run Logos, as that is exclusively the most resource intensive program I run. 

I see you started with issues; how has Logos been working on your m1 mac since? 

I write lessons and curriculum weekly for my role and I want to know that it will hold up well. 

Thanks! 

Posts 373
Pastor Michael Huffman | Forum Activity | Replied: Mon, Jan 24 2022 11:49 AM

Since upgrading to the M1 Chip, Logos crashes every time I use the sentence diagram tool. Does not do it on the other three MacBooks I have, just the M1. So, beware! I opened a case with Technical support 6 months ago and they still have no resolution. Sentence diagramming is a vital part of my study process, it is a shame that I have to use Logos' competition to be able to diagram sentences. 

Posts 30656
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Jan 25 2022 6:05 AM

Pastor Michael Huffman:
Since upgrading to the M1 Chip, Logos crashes every time I use the sentence diagram tool. Does not do it on the other three MacBooks I have, just the M1. So, beware!

I understand your frustration, but it is important to be clear: Just because you are having issues does not mean that the problem is with the M1. Are you aware of other users having troubles on the M1? I did see one thread of yours. There was one user who responded about having the same problem, but he is on windows. 

macOS, iOS & iPadOS | Logs |  Install

Posts 373
Pastor Michael Huffman | Forum Activity | Replied: Tue, Jan 25 2022 9:08 AM

JT (alabama24):

Pastor Michael Huffman:
Since upgrading to the M1 Chip, Logos crashes every time I use the sentence diagram tool. Does not do it on the other three MacBooks I have, just the M1. So, beware!

I understand your frustration, but it is important to be clear: Just because you are having issues does not mean that the problem is with the M1. Are you aware of other users having troubles on the M1? I did see one thread of yours. There was one user who responded about having the same problem, but he is on windows. 

I have no idea that the real problem is with the M1 Chip, and neither does Logos. The common thread in all or this, as I said in my post, is that the sentence diagramming is working fine on the three other MacBooks that I have that are not the M1 chip and the one windows desktop I have. The ONLY computer that I am having problems with the sentence diagramming is the one that has the M1 chip. And I have already done a complete removal and reinstall of Logos. So, that led me to believe that that could be the problem; especially since Logos is not native to the M1 but requires Rosetta to work. 

Posts 2642
Forum MVP
John Fidel | Forum Activity | Replied: Tue, Jan 25 2022 10:46 AM

Hi Michael,

I have a MBP 16" M1pro. I can open the sentence diagrammer and enter text. I opened 2 text in the flow mode and one in the line mode as shown below. I opened three different bibles as well. Can you provide the steps that causes Logos to crash so I can test it for you? I am using the latest OS and  Logos.

Thanks

Posts 373
Pastor Michael Huffman | Forum Activity | Replied: Wed, Jan 26 2022 5:37 AM

John Fidel:

Hi Michael,

I have a MBP 16" M1pro. I can open the sentence diagrammer and enter text. I opened 2 text in the flow mode and one in the line mode as shown below. I opened three different bibles as well. Can you provide the steps that causes Logos to crash so I can test it for you? I am using the latest OS and  Logos.

Thanks

Good Morning John, 

Thanks for the reply. On my M1 the sentence diagram tool will open and I can bring in text just fine and, in fact, can use the tool from anywhere between 15-20 minutes, that is the frustrating part. Perhaps, if it crashed at the time same every time, it would be easier to detect what is wrong. I cannot draw straight lines with the tool. When I chose the line option all it does it want to draw "shadow" boxes. Then usually as I am trying to bring over one of the brackets for the diagram, I get Apple's pinwheel and then Logos crashes. But only after the tool has worked for several minutes. I do get form Apple of summary of the crash and it says something about a "display window pass through," not sure what that means, but it says that every time that the crash occurs. So, I thought maybe it does not like that I am using a dual monitor, (My computer, not Logos), so I disconnected the second monitor, but it did not make any difference. I am at a loss. The guys at Logos say that they have not been able to duplicate the problem. That they have obtained an M1 laptop and have not been able to duplicate (I am impressed that they obtained a new computer on my account) but that may be that they are not using it long enough. It is frustrating, I feel sometimes that I go three steps forward and four steps back with Logos. 

Posts 2642
Forum MVP
John Fidel | Forum Activity | Replied: Wed, Jan 26 2022 1:04 PM

Michael,

I am not at that computer, but will play with it later to see if I can duplicate. I do not diagram, so it is a bit of a shot in the dark.

Posts 2642
Forum MVP
John Fidel | Forum Activity | Replied: Wed, Jan 26 2022 3:46 PM

Michael,

Not really using the diagramming tool it was really hard for me to try and duplicate your issue, especially if it occurs after 20 minutes. Sorry, but couldn't get it to crash, but probably just due to lack of skill in diagramming.

Posts 373
Pastor Michael Huffman | Forum Activity | Replied: Thu, Jan 27 2022 11:03 AM

John Fidel:

Michael,

Not really using the diagramming tool it was really hard for me to try and duplicate your issue, especially if it occurs after 20 minutes. Sorry, but couldn't get it to crash, but probably just due to lack of skill in diagramming.

Thanks!

Page 1 of 1 (15 items) | RSS