Bible Word Study not recognizing English words

Page 1 of 1 (20 items)
This post has 19 Replies | 1 Follower

Posts 74
Rod Bergen | Forum Activity | Posted: Wed, Apr 7 2021 10:25 PM

The Bible Word Study used to accept English words as input and provided me a drop down menu of various English words as I typed a word in.

However, since Logos 9, the BWS no longer gives me any English words.  I expect something has changed in the settings and I have tried to edit them to no avail.

Suggestions?

Thanks!

Posts 25768
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Apr 7 2021 10:54 PM

Rod:
However, since Logos 9, the BWS no longer gives me any English words. 

It is still working for me - and I don't know of anything in settings that would affect this

Image


Please post a screenshot showing what you see when you try this.

Posts 74
Rod Bergen | Forum Activity | Replied: Sun, Apr 11 2021 7:43 AM

Graham Criddle:
I don't know of anything in settings that would affect this

I don't know what settings would affect this either... hence my question.  But I get zero English words in the dropdown menu.

Screenshot 2021-04-11 074517

Posts 30484
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Apr 11 2021 7:46 AM

I don't know if it would help or not, but can you post a screenshot? 

macOS, iOS & iPadOS | Logs |  Install

Posts 74
Rod Bergen | Forum Activity | Replied: Sun, Apr 11 2021 7:47 AM

Screenshot 2021-04-11 074517

Posts 74
Rod Bergen | Forum Activity | Replied: Sun, Apr 11 2021 7:49 AM

JT (alabama24):

I don't know if it would help or not, but can you post a screenshot? 

I did post a screenshot under my response but have posted it again.  It doesn't really help... other than to show that there is no dropdown.

Posts 25768
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Apr 11 2021 7:54 AM

When someone experienced a similar problem some time ago Andrew suggested a corrupt autocomplete database was the possible cause - https://community.logos.com/forums/p/165039/969522.aspx#969522 - and requested you post logs.

So please enable diagnostic logging and post logs after seeing the problem

Details of doing this are at https://support.logos.com/hc/en-us/articles/360027869132-How-to-Enable-and-Submit-Log-Files 

Posts 30484
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Apr 11 2021 7:55 AM

Rod:
I did post a screenshot

Sorry! It did not load the first time. 

macOS, iOS & iPadOS | Logs |  Install

Posts 30484
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Apr 11 2021 7:58 AM

Graham Criddle:
When someone experienced a similar problem some time ago Andrew suggested a corrupt autocomplete database was the possible cause

Graham may have the right direction, but the only two other things I can think of: 

1. Have you tried restarting your computer? That is a fix for many glitches, and want to make sure the easy things have been tried first.

2. Did you edit the guide in any way? Click the kebob menu. 

macOS, iOS & iPadOS | Logs |  Install

Posts 12492
Forum MVP
NB.Mick | Forum Activity | Replied: Sun, Apr 11 2021 8:01 AM

(Re-Post - I answered and while I was typing you deleted your post - Graham goes into the same direction, I think)

Rod:

JT (alabama24):

I don't know if it would help or not, but can you post a screenshot? 

I did post a screenshot under my response but have posted it again.  It doesn't really help... other than to show that there is no dropdown.

Well, it does help to show you are using the English UI - in fact the non-Greek, non-Hebrew, non-Latin suggestions come from the UI language. Running Logos in German language, for example, will also give no English word suggestions, and "love" then looks the same as for you.

I expect that there's a file somewhere that has the list of potential words per language in it - maybe you need to delete this file and have it redownload and index again. Dave used to know about such things. Maybe turning on logging (start Logos with the CTRL key pressed until a logoin screen appeasr) will show an error in the Logos.log file, when you invoke the BWS function. Check http://wiki.logos.com/diagnostic_logging  

Running Logos 9 latest (beta) version on Win 10

Posts 74
Rod Bergen | Forum Activity | Replied: Sun, Apr 11 2021 9:01 AM

Graham Criddle:
So please enable diagnostic logging and post logs after seeing the problem

Log files attached.

Thanks!

Logos.zip

Posts 25768
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Apr 11 2021 9:28 AM

Thanks Rod

There is nothing in the log file that indicates an error (at least that I can see).

But there is reference to an autocomplete database at C:\Users\Rod\AppData\Local\Logos\Data\yirssngk.vyr\AutoComplete\AutoComplete.db

If no one else can see anything else that might be causing the problem, I recommend:

  • shutting Logos
  • deleting the file above
  • restarting Logos and allowing it to download the file again
  • see if that has resolved the issue

Posts 12492
Forum MVP
NB.Mick | Forum Activity | Replied: Sun, Apr 11 2021 9:56 AM

Graham Criddle:
deleting the file above

I concur, but just in case it doesn't download again and its absence causes problems, I'd go for renaming the file as ....db_old or such, to be able to get it back.

Running Logos 9 latest (beta) version on Win 10

Posts 74
Rod Bergen | Forum Activity | Replied: Sun, Apr 11 2021 11:27 AM

Graham Criddle:

If no one else can see anything else that might be causing the problem, I recommend:

  • shutting Logos
  • deleting the file above
  • restarting Logos and allowing it to download the file again
  • see if that has resolved the issue

Tried this and it did generate a new autocomplete database file.  However, other than an initially long delay, nothing happened.

Still no English word dropdown and no response to the English word that I typed in the search field.  The display remains as in the screenshot posted above.

I have sent an email to support with the log file.

Posts 25768
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Apr 11 2021 12:02 PM

Thanks for trying - sorry it didn’t resolve it.

Please let us know how you get on with support

Posts 3196
LogosEmployee
Thomas Ball | Forum Activity | Replied: Mon, Apr 12 2021 9:55 AM

Rob Called in today. We reset the Bible Word Study to fix the problem. You will find this option when right-clicking the guide in question from the Guides menu.

 

Posts 74
Rod Bergen | Forum Activity | Replied: Mon, Apr 12 2021 10:01 AM

Graham Criddle:
Please let us know how you get on with support

Thanks to tech support  for fixing the problem.  Took about a half hour.  Resetting the Bible Word Study finally did the trick as noted above. 

Posts 25768
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Apr 12 2021 10:32 AM

Thanks Thomas - that’s helpful to know

Posts 25768
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Apr 12 2021 10:32 AM

Rod:

Graham Criddle:
Please let us know how you get on with support

Thanks to tech support  for fixing the problem.  Took about a half hour.  Resetting the Bible Word Study finally did the trick as noted above. 

Glad it is all sorted now- and thanks for letting us know

Posts 30484
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Apr 12 2021 11:08 AM

Thomas Ball:
We reset the Bible Word Study to fix the problem. You will find this option when right-clicking the guide in question from the Guides menu.

Would this have been needed because of a corruption, or would settings for that guide have been changed at some point? Can someone knowingly make a change that causes this (undesirable to Rod) behavior?

macOS, iOS & iPadOS | Logs |  Install

Page 1 of 1 (20 items) | RSS