BUG: L9.4: CBV can't parse multi-verse reference with punctuation at end

Page 1 of 1 (3 items)
This post has 2 Replies | 0 Followers

Posts 19692
Rosie Perera | Forum Activity | Posted: Sat, Apr 24 2021 2:01 PM

Copy and paste the following reference (including the period at the end) into the reference box for the Copy Bible Verses tool:

John 10:2,3, 14-16.

It can't read it and the tool reverts back to whatever verse was in there before.

But remove the period and it can parse that multi-verse reference just fine.

Now enter some other single verse reference with a period at the end, such as Gen 1:1.

It parses that just fine too.

It seems it can't do it when there are comma-separated verse numbers. It also can't do it if I simplify the original paste to John 10:2,3.

I'm sure this is going to be your highest priority bug to fix. [Sarcasm.] Big Smile Seriously, I would not be surprised if this is pushed to the bottom of the heap. But I just thought I'd report it anyway.

Posts 75
Warren Dane | Forum Activity | Replied: Tue, Apr 27 2021 9:39 AM


I get the same result in 9.4. Remove the period and it parses find. BTW, why is there no reference to 9.4 being released. When I opened Logos it was downloaded when I approved the download. 

Posts 30672
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Apr 27 2021 10:01 AM

Warren Dane:
why is there no reference to 9.4 being released

There was  

https://community.logos.com/forums/t/200221.aspx 

macOS, iOS & iPadOS | Logs |  Install

Page 1 of 1 (3 items) | RSS