CRASH: Android App closes when I try to Swipe to Highlight.

Page 1 of 1 (10 items)
This post has 9 Replies | 1 Follower

Posts 892
Tim Hensler | Forum Activity | Posted: Tue, Jun 15 2021 8:20 AM

Android 9.6.2 (Build 906001901)

When I swipe to highlight something, the app closes and prompts me to send feedback (which I did several times).

This happens with monographs, Bibles and commentaries.

Posts 29589
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Jun 15 2021 10:48 AM

Have you tried restarting the device?

macOS, iOS & iPadOS | Logs |  Install

Posts 892
Tim Hensler | Forum Activity | Replied: Tue, Jun 15 2021 7:23 PM

JT (alabama24):
Have you tried restarting the device?

Yep.  No change.

Posts 694
LogosEmployee
Joe McCune (Faithlife) | Forum Activity | Replied: Wed, Jun 16 2021 8:55 AM

Tim,

It sounds like you have already tried to send us your logs, but we have not received them.  Please try sending them again.

Please do the following:
1. Open the app.
2. Tap the Menu icon (this icon has three horizontal lines).
3. Tap Help.
4. Press “Report a Problem”

Posts 892
Tim Hensler | Forum Activity | Replied: Wed, Jun 16 2021 12:28 PM

I tried the swipe highlight and the app crashed/closed.

I then launched the App again, grabbed the logs and have attached them here.

4628.Swipe Highlight Crash.zip

I'd appreciate a prompt fix on this - it adversely impacts my lesson/sermon preparation now that I can't quickly mark passages and resources with the swipe-highlight tool.  (FYI, this was a problem once in the past, so this looks like a regression problem.)

Thanks.

Posts 694
LogosEmployee
Joe McCune (Faithlife) | Forum Activity | Replied: Thu, Jun 17 2021 8:53 AM

Thanks for your logs, Tim.

We are working on a fix for this problem, which we hope to include with the next Beta update.

Posts 892
Tim Hensler | Forum Activity | Replied: Thu, Jun 17 2021 2:36 PM

Excellent.  Thank you.

Posts 892
Tim Hensler | Forum Activity | Replied: Fri, Jun 18 2021 10:29 AM

I updated to Bible 9.6.0 (Build 0201).

Now it doesn't crash, but it also doesn't highlight.  Nothing happens when I swipe to highlight.

Posts 30
LogosEmployee
Martin Denham (Faithlife) | Forum Activity | Replied: Mon, Jun 21 2021 3:29 AM

Please open Notes and change the highlight color of one of the highlights you have just created to the required style.

This should also set the default highlight color for when you use Swipe to Highlight in the future.

I suspect that the default Highlight color was set to No-Highlight, which originally caused a crash and now does not highlight.

Posts 892
Tim Hensler | Forum Activity | Replied: Mon, Jun 21 2021 7:00 AM

Hi Martin,

That did fix the highlighting (Thank you), however it takes about 5 seconds to render compared to about 2 seconds before the crashing problem.  Could it be tuned for better response speed?

Disregard the speed problem.  After a while, it want back to normal speed - apparently there was a busy background routine being run and it slowed the whole thing down.  It's working fine now.

Page 1 of 1 (10 items) | RSS