Request for testing: CEF panels in 9.10

Page 1 of 1 (15 items)
This post has 14 Replies | 1 Follower

Posts 495
LogosEmployee
Adam Borries (Faithlife) | Forum Activity | Posted: Fri, Nov 19 2021 11:43 AM

Summary

In the 9.10 beta cycle, we'd like to ask our testers to pay special attention to any loading or rendering problems in the Home page, Factbook, Notes, and other panels that are shared with the web app. 

Background

Most of the Logos desktop interface is rendered "natively" by the operating system. However, there is a growing list of tools that are shared with the Logos web app, which are necessarily written in HTML. We use the Chromium Embedded Framework (CEF) to render that UI. 

As we do periodically, we've upgraded the version of CEF we are using in the desktop app. We don't anticipate any problems, but we want to be sensitive to any side effects that might arise. 

What to look for

Here are the panels that use CEF: 

  • Home 
  • Notes
  • Factbook
  • Sermon Builder 
  • Sermon Manager
  • Atlas
  • Charts
  • Canvas
  • Faithlife Assistant
  • Workflow Editor
  • Interactive resources

As well as some parts of:

  • Media tool
  • Text Comparison
  • Bible Browser
  • Courses tool

Please be on the lookout for and report any issues like: 

  1. Panels suddenly going blank or refreshing unexpectedly
  2. Incorrect scaling, especially on high DPI monitors and/or second displays
  3. Unresponsive UI elements, like buttons or context menus 
  4. Performance issues like slow loading times or choppy animations
  5. Any of the above after the panel has been open for a long time, and/or after the machine has gone to sleep

As always, thank you very much to our beta testing community!

Adam Borries | Product Manager, Logos desktop application

Message me on Faithlife.com >>

Posts 35595
Forum MVP
MJ. Smith | Forum Activity | Replied: Sat, Nov 20 2021 8:01 PM

Bumping for the attention of the beta testing community ... this requires some genuine concentration on testing.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 495
LogosEmployee
Adam Borries (Faithlife) | Forum Activity | Replied: Tue, Nov 23 2021 2:21 PM

Thank you, MJ.

Adam Borries | Product Manager, Logos desktop application

Message me on Faithlife.com >>

Posts 27860
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Nov 24 2021 6:59 PM

Adam

I devoted sometime to each of:

  • Home 
  • Notes  (crash in another thread)
  • Factbook
  • Charts
  • Interactive resources  (Morph Charts)
  • Text Comparison
  • Bible Browser

No issues.

Dave
===

Windows 11 & Android 8

Posts 1730
Forum MVP
Veli Voipio | Forum Activity | Replied: Thu, Nov 25 2021 10:33 AM

I tested the Atlas, roughly half an hour.

No issues.

Actually I was surprised how well it works, have not used Atlas for a long time.

Four year old (relatively fast when bought) PC laptop, Mobile network connection (4G), Windows 11, Logos 9.10 Beta 2

Gold package, and original language material and ancient text material, SIL and UBS books, discourse Hebrew OT and Greek NT. PC with Windows 11

Posts 2526
GaoLu | Forum Activity | Replied: Fri, Nov 26 2021 9:53 AM

I worked with

  •  Faithlife Assistant
  • Courses tool

All seems to be well. 

Posts 35595
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Nov 30 2021 7:05 PM

I used the Media tool - I reported one problem of a missing field which may or may not be related.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 1270
Armin | Forum Activity | Replied: Mon, Dec 13 2021 5:31 AM

For a long time (over a year?), I have had issues with some guides. There are occasions when I have to click about 1-2 cm above a link in a Guide in order to select the link. This issue occurs intermittently. When it happens, then it stays this way until I restart Logos. But even this does not guarantee that it works again.

I thought it was my particular Mac. But it still happens after I purchased a new Mac.

Am I the only one with this issue? Maybe I need to do a recording next time it happens.

Posts 1153
EastTN | Forum Activity | Replied: Mon, Dec 13 2021 6:57 AM

The discussion of display issues in this thread may be relevant.

Posts 1270
Armin | Forum Activity | Replied: Mon, Dec 13 2021 8:01 AM

EastTN:

The discussion of display issues in this thread may be relevant.

My issues are different. I will try to record it next time it happens.

Posts 1153
EastTN | Forum Activity | Replied: Mon, Dec 13 2021 2:15 PM

I am having a problem with the passage guide. Here's a screenshot:

I'm running Windows 10 Pro on an AMD Ryzen 7 5800X desktop with an NVIDIA RTX 3070 graphics card. I'm using Logos 9.9.0.0016. The last time I reported this, I had my screen scaled to 125%. This last screen capture is after resetting the scaling to 100%.

Posts 3899
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Dec 13 2021 2:30 PM

EastTN:

The discussion of display issues in this thread may be relevant.

Hi EastTN,

I've replied to this thread asking for more information. Since these changes were made on 9.10, and you are reporting your issues on 9.9.

Posts 1153
EastTN | Forum Activity | Replied: Tue, Dec 14 2021 6:57 AM

Philana R. Crouch:

EastTN:

The discussion of display issues in this thread may be relevant.

Hi EastTN,

I've replied to this thread asking for more information. Since these changes were made on 9.10, and you are reporting your issues on 9.9.

Got it - sorry for the distraction.

Posts 2526
GaoLu | Forum Activity | Replied: Sun, Dec 26 2021 1:43 PM

I don't think "double vision" is related, so I posted it elsewhere, but just in case:

https://community.logos.com/forums/p/204707/1190481.aspx#1190481 

Posts 737
Frank Sauer | Forum Activity | Replied: Wed, Jan 19 2022 11:27 AM

I know that Linux is not supported officially by Faithlife, but figured I'd post this as we are working on it - in case it may lead to issues for Windows users down the road.

https://bugs.winehq.org/show_bug.cgi?id=52380

Starting with Logos 9.10, we've seen the issue listed here and the first post contains a video of the glitch. All Logos versions prior do not have the issue.

Double clicking the Menu Header allows access after the first use. 

Page 1 of 1 (15 items) | RSS