Page 1 of 1 (3 items)
This post has 2 Replies | 1 Follower

Posts 1343
Harry Hahne | Forum Activity | Posted: Fri, Feb 4 2022 11:28 AM

When I click on the play video button in the Media Tool in Logos, nothing appears to happen.

What is not obvious to the user is that a tab is opened in the default Web browser which attempts to show the media.

I say "attempts" because while the link is entered in Firefox, nothing happens.The link is inserted as a URL, but the screen in the browser is blank.

I have several concerns about this behavior:

  1. It is not intuitive to the user that the video attempts to play in the Web browser. In Windows 10, the Web browser is not made the active program, so unless an active browser window is displayed alongside Logos, you would never know anything is supposed to happen. I ended up clicking on the video several times and opening up many new browser tabs.
  2. The videos do not play in Firefox, Chrome or Microsoft Edge on my Windows 10 computer. In Chrome the video popped up for 1/2 second, but then disappeared. This is clearly a bug. The videos are useless to me since I cannot play them.
  3. Why not simply play the videos within Logos itself? I would expect the video to either play in the Media tool or to open another window in Logos and play it there. When there is a play button on a video, other programs would just play the video within the active window. If Logos opens up another window, it should be made the active window. Logos can clearly play videos, such as courses. Even if the video is stored on the cloud, it could be streamed (preferred behavior) or downloaded before playing (with a suitable indicator that the video is downloading). .

*Running Logos 9.11 on Windows 10.

Posts 26056
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Feb 4 2022 11:37 AM

Harry Hahne:
Why not simply play the videos within Logos itself? I would expect the video to either play in the Media tool or to open another window in Logos and play it there.

I agree this would be much better

Incidentally, it does work better on Mac in that the video is playable in the browser tab that is opened.

Posts 19600
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Feb 4 2022 11:51 AM

Harry Hahne:
Why not simply play the videos within Logos itself? I would expect the video to either play in the Media tool or to open another window in Logos and play it there.

+1 Yes for Media Tool playing video within Logos/Verbum.

Using Logos 9.11 SR-1 on macOS Monterey 12.2, replicated Media Tool opening new tab in Firefox 96.0.3 that was playable.

Keep Smiling Smile

Page 1 of 1 (3 items) | RSS