Page 1 of 1 (11 items)
This post has 10 Replies | 1 Follower

Posts 1308
Armin | Forum Activity | Posted: Wed, Jul 6 2022 10:40 PM

For a long time (over a year?), I am having intermittent sync issues on my Mac. 

The problem occurs when I have a complex layout with linked panels and numerous open resources and floating windows. I then get the red "!" in the sync circle. Clicking the sync circle causes it to spin for a bit, but then the "!" comes back stating that there are sync errors.

When I close all panels and resources, click again on the sync circle, the sync works successfully.

I have a good Internet connection and have tried different locations and countries. The same problem occurs.

Here is a log with 

1) sync error

2) closing all panels and resources

3) successful sync

3365.LogosLogs.20220707-060744.zip

Posts 1308
Armin | Forum Activity | Replied: Thu, Jul 7 2022 9:27 PM

Just to clarify: The problem only occurs intermittently.

Posts 288
Jackie Watts | Forum Activity | Replied: Fri, Jul 8 2022 8:24 AM

I experience this as well. I usually just close Logos and restart, which fixes the issue.

Posts 1308
Armin | Forum Activity | Replied: Fri, Jul 8 2022 9:33 AM

Jackie Watts:

I experience this as well. I usually just close Logos and restart, which fixes the issue.

Yes, this is also what I do. However, it is a bit annoying how we got used to the quirks of Logos and just put up with them. I hope that Logos 10 will fix some of these long-standing bugs, as well as the interface inconsistencies that I regularly complain about.

Posts 36379
Forum MVP
MJ. Smith | Forum Activity | Replied: Fri, Jul 8 2022 9:45 AM

Interesting - I get this problem only when my entire internet connection is slow or unavailable, never as a random bug.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 1308
Armin | Forum Activity | Replied: Fri, Jul 8 2022 9:57 AM

MJ. Smith:

Interesting - I get this problem only when my entire internet connection is slow or unavailable, never as a random bug.

With me, it happens about 80% of the time after using a complex layout with many open resources and guides for ~30 mins. I initially also thought it was my Internet connection, however, since we got Fiber in our area, this cannot be the issue anymore. In addition, it happens independent of the location, ISP, and even country.

Posts 36379
Forum MVP
MJ. Smith | Forum Activity | Replied: Fri, Jul 8 2022 10:51 AM

I rarely have a large number of resources open but when I've been working for several hours, I do see what I suspect is a memory leak.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 1308
Armin | Forum Activity | Replied: Fri, Jul 8 2022 12:12 PM

MJ. Smith:

I do see what I suspect is a memory leak.

That's what I assume as well. But I thought that today's programming tools can prevent this from happening. Long time since I last programmed.

Posts 3947
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Fri, Jul 15 2022 12:51 PM

Armin:
For a long time (over a year?), I am having intermittent sync issues on my Mac. 

Can you provide a screenshot of a layout where you have this occur and how long it's open? That will help narrow things down. 

Posts 1308
Armin | Forum Activity | Replied: Mon, Jul 18 2022 8:36 PM

Here are screenshots of the three Logos windows that I often use when I get the sync issues:

Armin

Posts 1308
Armin | Forum Activity | Replied: Wed, Jul 20 2022 8:57 PM

Regarding the time it takes for the problem to appear: I haven't found a reliable pattern so far. This morning, the issue started immediately after the layout was loaded.

Page 1 of 1 (11 items) | RSS