Re-indexing every time

Page 1 of 1 (15 items)
This post has 14 Replies | 1 Follower

Posts 55
Seth I. Grotzke | Forum Activity | Posted: Tue, Aug 31 2010 5:42 AM

Any ideas?1033.Archive.zip

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Aug 31 2010 9:29 AM

Are you putting your machine to sleep?

Your logs seem to indicate that indexing is paused for several hours, and hasn't finished:

08/29/2010 16:58:32 |  INFO | 3 | LogosIndexerWorker | 12 resources in the library index need updating
08/29/2010 16:58:32 |  INFO | 3 | LogosIndexerWorker | (Timed) Updating Bible Index from Resource

...

08/29/2010 16:58:33 |  INFO | 3 | LogosIndexerWorker | 1 resources in the Bible index need updating
08/29/2010 16:58:33 |  INFO | 3 | LogosIndexerWorker | (Timed) Indexing.
08/29/2010 16:58:33 |  INFO | 3 | LogosIndexerWorker | Waiting for library indexing to finish.

...

08/29/2010 16:58:51 |  INFO | 1 | LogosIndexerWorker | 'Pause indexing' context menu command was invoked.
08/29/2010 16:58:53 |  INFO | 4 |         Indexer | Merged lexicon (in 00:00:09.5208720) totaling 719,013 terms
08/29/2010 17:42:00 |  INFO | 1 | LogosIndexerWorker | 'Resume indexing' context menu command was invoked.
...

08/29/2010 19:03:49 |  INFO | 1 | LogosIndexerWorker | 'Pause indexing' context menu command was invoked.
08/30/2010 06:46:59 |  INFO | 1 | LogosIndexerWorker | 'Resume indexing' context menu command was invoked.

...

08/30/2010 06:47:57 |  INFO | 1 | LogosIndexerWorker | 'Pause indexing' context menu command was invoked.
08/30/2010 07:39:55 |  INFO | 1 | LogosIndexerWorker | 'Resume indexing' context menu command was invoked.
08/30/2010 07:40:01 |  INFO | 1 | LogosIndexerWorker | 'Pause indexing' context menu command was invoked.
08/30/2010 10:50:40 |  INFO | 1 | LogosIndexerWorker | 'Resume indexing' context menu command was invoked.
...

08/30/2010 10:55:34 |  INFO | 1 | LogosIndexerWorker | 'Pause indexing' context menu command was invoked.
08/30/2010 11:11:22 |  INFO | 1 | LogosIndexerWorker | 'Resume indexing' context menu command was invoked.

Mobile Development Team Lead

Posts 55
Seth I. Grotzke | Forum Activity | Replied: Tue, Aug 31 2010 9:37 AM

Every time I reopen logos it indexes. I let it finish and it does it again the next time.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Aug 31 2010 9:41 AM

After it finishes, will you re-post your Indexer.log?

Mobile Development Team Lead

Posts 55
Seth I. Grotzke | Forum Activity | Replied: Tue, Aug 31 2010 10:06 AM

Here it is.3058.Indexer.log

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Aug 31 2010 10:56 AM

Can you post your ConsoleMessages.log too? The Indexer.log doesn't have any errors in it.

Alternatively, you might just try "rebuild index" from the command bar to have the indexes rebuilt from scratch rather than trying to merge (which seems to be causing a problem).

Mobile Development Team Lead

Posts 55
Seth I. Grotzke | Forum Activity | Replied: Tue, Aug 31 2010 11:06 AM

Here is the syncerrors, is that what you want?

4863.SyncClientErrors.log

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Aug 31 2010 11:14 AM

No, open "Console" from Spotlight, select "Console Messages" from the left hand side, do a Save As... "Console Messages.log" and post that.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Aug 31 2010 12:02 PM

Yep... you need to "Rebuild index" from the command bar:

8/30/10 11:11:58 AM    [0x0-0x1dc1dc].com.logos.Logos_Bible_Software_4    Unhandled Exception: System.IO.EndOfStreamException: Unable to read beyond the end of the stream.
8/30/10 11:11:58 AM    [0x0-0x1dc1dc].com.logos.Logos_Bible_Software_4      at Libronix.Utility.BitReader.ReadInt32 (Int32 nBits) [0x00000] in <filename unknown>:0
8/30/10 11:11:58 AM    [0x0-0x1dc1dc].com.logos.Logos_Bible_Software_4      at Libronix.Utility.BitUtility.ReadRice (Libronix.Utility.BitReader reader, Int32 nParameter) [0x00000] in <filename unknown>:0
8/30/10 11:11:58 AM    [0x0-0x1dc1dc].com.logos.Logos_Bible_Software_4      at Libronix.SearchEngine.TermDocumentPostingReader.MoveNext () [0x00000] in <filename unknown>:0

Let it finish, and that should fix the problem.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Aug 31 2010 1:36 PM

Seth,

Did you try to rebuild your indexes? Was this the same file you posted earlier or a new one?

Mobile Development Team Lead

Posts 55
Seth I. Grotzke | Forum Activity | Replied: Tue, Aug 31 2010 7:37 PM

Sorry, disregard those. Multiply refreshes on my browser as my internet connection went in and out. I will rebuild and post tomorrow. Sorry again.

Posts 55
Seth I. Grotzke | Forum Activity | Replied: Wed, Sep 1 2010 6:55 AM

rebuilt the index and that seemed to help. Thanks

Page 1 of 1 (15 items) | RSS