Logos 4.0d will not log into my account

Page 1 of 1 (9 items)
This post has 8 Replies | 1 Follower

Posts 10
Bob Mattes | Forum Activity | Posted: Sat, Sep 25 2010 5:55 PM

I sent an email to tech support a week ago on this but never received a reply. My Logos 4d (4.04.4.1385) hasn't been able to connect to my account in several weeks. It worked fine before that, and I haven't made any changes to the system. I'm running WinXP SP3 in a VMWorkstation 7 virtual machine under Ubuntu 10.04 as I have been for several years (varying versions of Ubuntu and VMW). It all worked perfectly until a few weeks ago. When I click on my email address at the top of Logos 4, it brings up Firefox and connects right to my account. My account is fine, my Internet 20 Gbps connection works great. Only Logos has the problem. Any help would be greatly appreciated.

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Sat, Sep 25 2010 6:23 PM

Bob,

Have you doubled checked your Program Settings to be sure you have Use Internet checked Yes?

Have you tried to run Update Now from the Command Bar to download and install the newer version of 4.0d that is available?

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 10
Bob Mattes | Forum Activity | Replied: Sat, Sep 25 2010 6:34 PM

OK, I found the answer to the problem at the end to this thread: http://community.logos.com/forums/p/20819/156734.aspx

Bottom line is that the Logos root certificate looks like it either expired or changed in the last month or two. Firefox would log in fine, but not Logos 4 (nor IE apparently, but I don't use IE so didn't see that). I downloaded and installed the Go Daddy Class 2 Certification Authority Root Certificate and Go Daddy Class 2 Certification Authority Root Certificate - G2 from https://certs.godaddy.com/anonymous/repository.seam . The second one may not have been necessary. After this, Logos 4 connected and started syncing.

This is something that I would not have guessed. Perhaps Libronix should put a sticky post about this on the tech support forum.

Posts 10
Bob Mattes | Forum Activity | Replied: Sat, Sep 25 2010 6:39 PM

Yes, use Internet was checked. Update Now wasn't present on the command bar. As best I could tell, there was no way out until I learned from a tech supt fellows tag line about logs and holding down the Ctrl key. When I did that, Logos presented the dialog with my login info, a little error box, and the option to work offline. That error box said that Logos could not connect to the logos.com server. But Firefox could log onto the Logos server with no problems. I googled on the specific error message and found the answer with the server certificate.

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Sat, Sep 25 2010 6:50 PM

I'm glad you figured it out. I never heard that one before.

You are at least one cycle behind in your Logos software. If you type Update Now in the Command Bar and hit Enter you should ultimately see that an update is available to download and install. The current version is 4.04.4.3415. You may have triggered that just by opening Logos and logging in.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 10
Bob Mattes | Forum Activity | Replied: Sat, Sep 25 2010 7:07 PM

Thanks, Mark. It just finished updating to that version. It logged in several times during the update process, so all is functioning nominally now.

I tend to get behind in the updates a bit these days. Since migrating to Linux several years ago, I don't use Logos nearly as much as did in the past. The virtual machine works great, but Logos and Activesync are the only two Windows programs I use anymore - and probably only once a month or so. The Bible resources in Linux are rudimentary by comparison, but I get by OK. I miss Logos when I'm not using it, but I don't miss Windows at all. I still have to live with at work, and it's very painful.

Posts 47
Jeffrey S Gordon | Forum Activity | Replied: Sat, Sep 25 2010 7:08 PM

I can't connect either.  Downloading the two aforementioned godaddy certificates did not work at all.  Of course, it's not possible to upgrade any software without logging in.  I can't think of any good reason why this would have changed...

Posts 47
Jeffrey S Gordon | Forum Activity | Replied: Sat, Sep 25 2010 7:11 PM

Jeffrey S Gordon:

I can't connect either.  Downloading the two aforementioned godaddy certificates did not work at all.  Of course, it's not possible to upgrade any software without logging in.  I can't think of any good reason why this would have changed...

Well, my fault... My clock had been reset to 2007.  Apparently that was enough (I guess I was a bit fooled by others reporting the same problem)

 

Posts 10
Bob Mattes | Forum Activity | Replied: Sat, Sep 25 2010 7:22 PM

Jeffrey S Gordon:

(I guess I was a bit fooled by others reporting the same problem)

Been there, done that, have a drawer full of t-shirts.

Page 1 of 1 (9 items) | RSS