WBC and indexing

Page 1 of 1 (14 items)
This post has 13 Replies | 1 Follower

Posts 70
Robert le Clus | Forum Activity | Posted: Thu, Sep 30 2010 11:09 PM

Bought WBC 59vol set at the discount price yesterday. Let Logos4Mac download all the files. (230MB+-) Now I only see 5 of the commentaries and I can't seem to get Logos to reindex my library. 

Also I notice that most of the books in the Resource folder for Logos4 are in the old Libronix format. Is that even supported on Logos4Mac?

 

PS. I have the Mac Gold Master Logos4Mac version running. 

 

Posts 1246
David Mitchell | Forum Activity | Replied: Fri, Oct 1 2010 6:47 AM

Robert le Clus:
Bought WBC 59vol set at the discount price yesterday. Let Logos4Mac download all the files. (230MB+-) Now I only see 5 of the commentaries and I can't seem to get Logos to reindex my library. 

There are a couple of known issues with downloading updates that we're trying to fix for the next release. See this thread for details and a possible workaround: http://community.logos.com/forums/t/23383.aspx. If you do delete the files that Tom suggested, it would be great if you would also upload them to this forum so that we have another point of reference in tracking down the bug.

Robert le Clus:
Also I notice that most of the books in the Resource folder for Logos4 are in the old Libronix format. Is that even supported on Logos4Mac?

Yes. In fact, we support everything back to the old format used by Logos Library System.

David Mitchell
Development Lead
Faithlife

Posts 70
Robert le Clus | Forum Activity | Replied: Sat, Oct 2 2010 5:26 AM

I tried updating to the latest SR-1. Didn't help. The download of 700MB+ starts and then crashes. My indexer crashes. Can't access my documents. This is very annoying. Seems the download option isn't so good after all. 

 

Here are the dbs 0724.databases.zip

And here is the logs 4812.Logs.zip

The logs seem to indicate the problem is with the indexer app. But the downloads don't seem to work either.

Posts 70
Robert le Clus | Forum Activity | Replied: Sat, Oct 2 2010 10:29 AM

Tried to install an older version. It didn't work but it did allow the download to complete. So I now have all my new resources on the harddrive. However the indexing refuses to start. This of course means I cannot access any of those wonderful resources I paid plenty bucks for. This annoys me. 

As a programmer myself (I write iPhone software) I understand the concept of bugs. I also understand that there are sometimes problems that one doesn't pick up till the app is released. Unfortunately it doesn't make me very happy. And since I have wacked all my indexes trying to get the indexing to work, I can't search anything. 

I guess the upside is that the WBC resources are mostly in Libronix format so Libronix 1 for the Mac should be able to read them. Go me. 

I guess I'll wait for the next update....

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Oct 2 2010 1:29 PM

Robert le Clus:

And here is the logs 4812.Logs.zip

The logs seem to indicate the problem is with the indexer app. But the downloads don't seem to work either.

Observation: near top of Logos4.log file are 3 lines containing "/Library/InputManagers/SafariBlock/SafariBlock.bundle/Contents/MacOS/SafariBlock" that do not appear in my Logos4.log file.

Observation: Safari 5 extensions and FireFox add-ins have browser specific ad-blocking capabilities (compared to system wide ad blocking via an Input Manager).

Concur Indexer is crashing - wonder about uninstalling SafariBlock and restarting Mac ?

If Indexer crashes again, please post new set of logs.

Robert le Clus:
I tried updating to the latest SR-1. ... Tried to install an older version

Once beta channel installed (SR-1 Beta 1), unwise to try older version => http://community.logos.com/forums/t/23798.aspx

Wiki has Beta information => http://wiki.logos.com/The_Logos_4_Beta_Program

Keep Smiling Smile

Posts 70
Robert le Clus | Forum Activity | Replied: Sat, Oct 2 2010 2:18 PM

Thanks for the advice. Unfortunately it didn't help. I removed both my ad blockers. So now I get all the ads again. Go me. And the indexer will still not start. And since this behaviour started with the Gold Master, I don't think its beta specific. It doesn't look like the attempt at the older version worked anyway. It didn't copy over to the Applications folder. All it did was start the lastest one. the about me still has me running the latest beta. 

And somehow I broke Libronix as well. Maybe it was some of the new resources I downloaded in the old format so that I could use them with the old software. Cause it crashes now when I do a Passage guide and try to expand to all the commentaries. So I now have no usable software for Bible study. Go me. 

 

Posts 5365
Forum MVP
Mike Binks | Forum Activity | Replied: Sat, Oct 2 2010 2:27 PM

Robert le Clus:
And somehow I broke Libronix as well. Maybe it was some of the new resources I downloaded in the old format so that I could use them with the old software. Cause it crashes now when I do a Passage guide and try to expand to all the commentaries. So I now have no usable software for Bible study. Go me.

Hi Robert 

If you need to - you can do a complete reinstall of Logos. Your resources will down-load (and should index).

It will be a right pain but it might get you working again before Monday and the return of the developers - who will - as always be asking for the Logs from the misbehaviour.

tootle pip

Mike

How to get logs and post them. (now tagging post-apocalyptic fiction as current affairs)

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Oct 2 2010 2:52 PM

Robert le Clus:
... the indexer will still not start.

Please restart Mac - Blue Icon should appear in Menu Bar (Indexer).  After Blue icon disappears, launch Logos 4, look in library for WBC - if not present, close Logos 4 and post new set of logs.

Robert le Clus:
And somehow I broke Libronix as well. Maybe it was some of the new resources I downloaded in the old format so that I could use them with the old software.

For Libronix, could close program, move recent additions to Resources folder to different folder, launch Libronix and try passage guide again.

By the way, wonder about Libronix version - last one was 1.2.2 (203).

Robert le Clus:
I removed both my ad blockers. So now I get all the ads again. 

In Safari 5, can click Safari => Safari Extensions Gallery - Productivity section

For FireFox 3.6, can click Tools => Add-ons => Get Add-ons => Browse All Add-ons => Popular  (Privacy & Security category has many choices)

Keep Smiling Smile

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Oct 2 2010 3:15 PM

Mike Binks:
If you need to - you can do a complete reinstall of Logos. Your resources will down-load (and should index).

Currently do not have direct link for downloading current Logos 4 Mac Beta version (tried 3 URL ideas - access denied), recommend against compete uninstall and reinstall - reason is sync items can have beta format changes that do not play nice with current stable version (trade one pain for another).  For new install, want sync items to complete before indexing.

Like to look at new set of logs - have potential action idea, but currently unable to find forum post from Logos suggesting action.

Keep Smiling Smile

Posts 5318
Dan Francis | Forum Activity | Replied: Sat, Oct 2 2010 10:04 PM

I guess I was lucky, worked perfectly for me. but then I am using the beta SR-1.  Mine are lbxlls too this is normal. The files get indexed so it don't matter their format. You can even use your old LLS files if you have any (my only one is Oxford bible Commentary). When and if new versions of the files are available  they should automatically download for you. I have been wanting to get WBC for a long time and almost bought the Accordance version since it was cheaper. I was happy to be able to get the Logos files for the same price.

 

-Dan

Posts 70
Robert le Clus | Forum Activity | Replied: Mon, Oct 4 2010 8:41 AM

I find it interesting how depressed I got when my Logo wouldn't work.

Arrrg. Can't download 9Gigs of data. I live in Africa. So bandwidth is slow and expensive! 

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Oct 5 2010 6:32 AM

Robert,

Try deleting this folder: /Users/rleclus/Library/Application Support/Logos4/Data/ao3wyyhs.16s/LibraryCatalog and restarting. It seems there's a problem building the Library catalog.

Mobile Development Team Lead

Posts 70
Robert le Clus | Forum Activity | Replied: Tue, Oct 5 2010 7:35 AM

No luck. Here are the logs. 3750.Logs.zip

Can't see my new books. And no indexing. The big stack trace in the indexer log may have something to do with it :(

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Oct 5 2010 7:48 AM

Robert,

I'll take a look a the code when I get into the office in about an hour and see if I can see where the error is coming from.

Tom

Mobile Development Team Lead

Page 1 of 1 (14 items) | RSS