Two Bugs

Page 1 of 1 (17 items)
This post has 16 Replies | 0 Followers

Posts 662
Jeremy | Forum Activity | Posted: Sun, Oct 10 2010 2:16 PM

In the newest beta I noticed a few bugs.

1. Logos crashes every time I try to open and edit my collections.

2. It seems that Logos forgets the books I have prioritized in my passage guide and scrambles the order of prioritization.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Oct 10 2010 6:04 PM

Jeremy:
In the newest beta I noticed a few bugs.

Wonder about version ? A stable release is newer (with several fixes).

To update from 4.10.4.6016 (newest Beta) to 4.10.4.6104 (current stable release), 

* set update channel to stable

* update now

Click download, then Install 4.10.4.6104 (4.0a SR-1)

For future Beta releases,

* set update channel to beta

Wiki page FAQ's include potential Beta risk => http://wiki.logos.com/The_Logos_4_Beta_Program

Jeremy:

1. Logos crashes every time I try to open and edit my collections.

2. It seems that Logos forgets the books I have prioritized in my passage guide and scrambles the order of prioritization.

If version 4.10.4.6104 has both issues - please:

 

* launch Logos 4 (overwrites Logos4.log file)

* Guides => Passage Guide (verify order scrambled)

* Tools => Collections (attempt edit)

* quit Logos (if not crashed)

* Compress logs and post archive file

 

For crashes, Wiki page has summary => http://wiki.logos.com/Mac_Troubleshooting#How_to_Report_Bugs_in_Logos_4_Mac

Forum http://community.logos.com/forums/t/6731.aspx has tutorial

 

Keep Smiling Smile

Posts 662
Jeremy | Forum Activity | Replied: Sun, Oct 10 2010 6:29 PM

I am well aware of the procedure.

Posts 662
Jeremy | Forum Activity | Replied: Sun, Oct 10 2010 6:42 PM

7026.Logging.zip

Logos also doesn't open in full screen for some reason. I always have to maximize it.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Oct 10 2010 7:40 PM

Jeremy:
Logos also doesn't open in full screen for some reason. I always have to maximize it.

Noticed line in Logos4.log file => CreateApplicationScreenshot called for size ([300,225])

Window 300 pixels wide by 225 tall is smallish.  Instead of maximizing, wonder about dragging window, then grab lower right corner to resize, then click Layouts menu (cause snapshot update) - quit Logos, then launch Logos.

 

While noticing 4.10.4.6104 version (latest), not see Passage Guide nor Collection in Logos4.log file.

Click Guide => Passage Guide, "Executing command: Guides|TemplateName=PassageGuide" is written to Logos4.log file.

Click Tools => Collection, "Executing command: ResourceCollections" is written to Logos4.log file

Jeremy:

I am well aware of the procedure.

Apologies, Keep Smiling Smile

Posts 662
Jeremy | Forum Activity | Replied: Sun, Oct 10 2010 7:51 PM

The screen size is fixed. Thanks.

Posts 662
Jeremy | Forum Activity | Replied: Sun, Oct 10 2010 7:58 PM

I tried the logs again. 3201.Logging.zip

Posts 1246
David Mitchell | Forum Activity | Replied: Mon, Oct 11 2010 10:19 AM

Jeremy:
2. It seems that Logos forgets the books I have prioritized in my passage guide and scrambles the order of prioritization.

Could you be a bit more descriptive regarding what you did and what you expected Logos to do in response to your actions?

David Mitchell
Development Lead
Faithlife

Posts 662
Jeremy | Forum Activity | Replied: Mon, Oct 11 2010 3:22 PM

When I type in Acts 1:1 in my own passage guide, commentaries that are supposed to come in at the bottom come in at the top. I have arranged all of mine in alphabetical order, but there are certain passages (about 50% that I have noticed) where the order gets scrambled.

Posts 1246
David Mitchell | Forum Activity | Replied: Mon, Oct 11 2010 3:36 PM

Where did you arrange them?

David Mitchell
Development Lead
Faithlife

Posts 662
Jeremy | Forum Activity | Replied: Mon, Oct 11 2010 6:55 PM

I arranged them alphabetically in my prioritization and I made a commentaries collection which I put into my passage guide template. In SR 2 I have the same problems. The prioritization does not work in many passages (it works for Acts 1:2 but not 1:1 , Logos only open up 1/4 of the way, and L4 crashes every time I try to edit my collections. For me at least, the stability and use of L4 seems to be declining for some reason. On top of that it seems to run a little slower.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Oct 11 2010 9:36 PM

Jeremy:

I arranged them alphabetically in my prioritization and I made a commentaries collection which I put into my passage guide template. In SR 2 I have the same problems. The prioritization does not work in many passages (it works for Acts 1:2 but not 1:1 , Logos only open up 1/4 of the way, and L4 crashes every time I try to edit my collections. For me at least, the stability and use of L4 seems to be declining for some reason. On top of that it seems to run a little slower.

Jeremy,

Would you mind posting a screenshot of the expected and unexpected behaviors, well as your resource prioritizations? Sometimes the issues are with specific resources and it helps us to recreate the issue if we know which resources are involved.

Secondly, when Logos crashes when editing collections, does it generate a Logos4_Crash.txt file in your Logging folder? Alternatively, there may be one in ~/Library/Logs. Those files and Console Messages.log (Open Console, Cmd-Shift-S to save a copy) would help us figure out where the crash in Collections is. There didn't seem to be anything out of the ordinary in your previous logs which would point to a crash.

Thanks,

Tom

Mobile Development Team Lead

Posts 662
Jeremy | Forum Activity | Replied: Tue, Oct 12 2010 7:25 PM

Posts 662
Jeremy | Forum Activity | Replied: Tue, Oct 12 2010 7:36 PM

When I try to even cycle through any of my collections, Logos gets incredibly slow. It takes a few minutes for L4 to respond to anything once I open up my collections. Logos doesn't shut down, but it is considered "not responding." No one else has this problem?

Looks like I finally got a crash log from the collections.

4087.Logging.zip

BTW I am using SR-402.a also.

Posts 116
B. J. Clarke | Forum Activity | Replied: Tue, Oct 12 2010 7:49 PM

Jeremy,

I went to check my collections to see if I might have the same problem. For some reason, it is working just fine with me. 

I am using 4.0b Beta, so I don't know if that is what is making the difference or not.

I know it must be frustrating for you. 

Posts 662
Jeremy | Forum Activity | Replied: Tue, Oct 12 2010 7:54 PM

I was using the newest beta a week ago and it was giving me problems so it was suggested I use a stable release. Unfortunately I am still seeing the same issue. The good thing is that I am not trying to edit my collections right now. When a new SR or beta comes out I just try to test the functions I use most to see if there are any bugs in them and I noticed it then.

Posts 662
Jeremy | Forum Activity | Replied: Thu, Oct 21 2010 8:16 PM

It looks like Logos only crashes when I try to edit my Theological Journals collection. It is the largest one, but I would still like to edit it. I don't have any idea why it is happening.

Page 1 of 1 (17 items) | RSS