Logos 4 and Quad CPU's

Page 1 of 1 (6 items)
This post has 5 Replies | 1 Follower

Posts 242
Lankford Oxendine | Forum Activity | Posted: Fri, Apr 29 2011 3:02 PM

Downloaded L4 and just finished indexing.  One thing that confuses me is that I was told that L4 will use all 4 cores but according to my Activity monitor it is not.  Am I missing something?  Thanks!

 

Posts 493
Mr. Simple | Forum Activity | Replied: Fri, Apr 29 2011 3:59 PM

Double Click on the CPU graph and it will bring up another CPU Window History with all your cores

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Apr 29 2011 5:25 PM

Lankford Oxendine:
Downloaded L4 and just finished indexing.  One thing that confuses me is that I was told that L4 will use all 4 cores but according to my Activity monitor it is not.  Am I missing something?  Thanks!

When Bible Index or Library index is reading resource files for words to index, have seen 4 cores in use.  When combining postings of resources, have seen 1 core.

For grins, can use rebuild index command then watch CPU usage in Activity Monitor along with having Indexer.log file open (by default, automatically scrolls as lines are written to log file).

Keep Smiling Smile

Posts 242
Lankford Oxendine | Forum Activity | Replied: Sun, May 1 2011 12:01 AM

Been playing around in Logos 4 and have noticed that when the information panel is updating, L4 is still only using 106% out of 800%.  Takes the program 12 seconds to launch which is ridiculously slow as I have a Vertex 3 SSD which has 500MB/s read speeds.  I have had several crashes as well at startup.  Starting to wonder if I made a mistake with this software??

Posts 10819
Forum MVP
Jack Caviness | Forum Activity | Replied: Sun, May 1 2011 3:08 AM

Lankford Oxendine:
Starting to wonder if I made a mistake with this software??

There have been numerous complaints about speed with L4 Mac (and even some for L4 Win). Improvements are being made. Progress was rapid until the latest releases of 4.2a SR-4 (SR-5 fixed most of those problems) and 4.3 Beta 1 & 2. So far Beta 3 seems to be working well for me.

Hang in there, the Mac Dev Team should get back on track very soon.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, May 1 2011 7:35 AM

Lankford Oxendine:
Been playing around in Logos 4 and have noticed that when the information panel is updating, L4 is still only using 106% out of 800%.

For interactive use, seems Logos 4 effectively uses one core (for now).

Edit: in a Logos 4 thread, developer commented about multi-threaded => http://community.logos.com/forums/p/32512/242928.aspx#242928

Lankford Oxendine:
Takes the program 12 seconds to launch which is ridiculously slow as I have a Vertex 3 SSD which has 500MB/s read speeds.

Appreciate slowness (+ puzzled).  Edit: looking at some benchmarks, 500 MB/s speed is fast => http://eshop.macsales.com/shop/turnkey/iMac_2010_27/benchmarks/

Edit: Wonder about 64 bit kernel ? Slow Performance section includes: "Enabling Snow Leopard 64 bit kernel noticeably faster, up to 30 % - some older Mac’s and software drivers limited to 32 bit kernel"  Apologies: looked at original screen shot, noticed 64 bit for kernel_task so already using 64 bit kernel.

One comparison possibility is Logos 4 in a Windows virtual machine or native (faster) via Boot Camp, see Need Logos 4 PC feature?

By way of Logos 4 Mac comparison: on a 2.4 GHz Intel Core 2 Duo Mac, launch to music playing takes 29 seconds while 57 seconds needed for previous layout to load.  If startup Logos 4.3 Beta 3 to Home Page, then 49 seconds elapse.

Lankford Oxendine:
I have had several crashes as well at startup.

Wiki Mac Troubleshooting page has How to Report Bugs in Logos 4 Mac with log posting steps.

Lankford Oxendine:
Starting to wonder if I made a mistake with this software??

Thankful Logos has a refund policy.  Likewise Thankful for ability to quickly search thousands of resources for Bible Study information.

Keep Smiling Smile

Page 1 of 1 (6 items) | RSS