Repeated Crashes after last release update

Page 1 of 1 (11 items)
This post has 10 Replies | 1 Follower

Posts 34
Matt | Forum Activity | Posted: Thu, Oct 6 2011 2:03 AM

After the last automatic update (4.3 SR-4) I get repeated crashes when I attempt to type a scripture reference into the Home Page. The Passage Guide appears and begins to populate, then issues an error. The whole page greys out and two small black square windows appear on the page. Windows informs me the program has stopped working. One time I was given an error message as follows:

+++++

Application has generated an exception that could not be handled.

Process ID=0x1670(5744)     Thread ID=0x1674(5748)

Click OK to terminate the application.

Click CANCEL to debug the application.

+++++

I can open books and use many features normally, but each time I try to open a passage from the Home Page it crashes. Any ideas?

Posts 27857
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Oct 6 2011 2:26 AM

Matt we need to have some more details and also see some logs. But can you check that you have 4.3 SR-4 or 4.3 SR-5, which is the latest update.

Dave
===

Windows 11 & Android 8

Posts 34
Matt | Forum Activity | Replied: Thu, Oct 6 2011 5:04 AM

Here's the requested info:

passage=Romans 11:1-10

46136.Logos4Crash.txt

6685.Logos4Error.log

Posts 4077
Melissa Snyder | Forum Activity | Replied: Thu, Oct 6 2011 8:55 AM

Matt:

Here's the requested info:

passage=Romans 11:1-10

Matt,

  1. Is the Romans passage the only one that causes a crash, or does any passage entered on home page screen crash the program?
  2. What are the top five Bibles and your preferred Commentary?
  3. If you run a Pasage Guide on Rom 11:1-10 by itself from the Guides menu, does the crash occur?

Thanks.

Posts 34
Matt | Forum Activity | Replied: Thu, Oct 6 2011 5:18 PM

Hi Melissa,

I've tried a few different things and here's what I've found. The problem seems to be isolated to (1) the first attempt after the program loads and (2) only occurs for Romans 11:1-10. In other words, When I first open Logos4 the home page comes up; if I immediately type in Romans 11:1-10 it crashes every time. But if (when I first open Logos4) I type in different reference, then it loads normally (i.e. it opens the Passage Guide, the Exegetical Guide, My preferred Bibles, and the preferred commentary). If I then type "Close All" into the Command Box, when the Home Page reappears I can then type in Romans 11:1-10 and it will open everything normally. So it only occurs with this reference (so far that I've found) and only on the first attempt after Logos4 first opens.

My top five Bible are (1) ESV (2) CUV (Chinese Union Version) (3) KJV (4) USB4 (5) NASB95. My preferred commentary (for Romans 11:1-10) is

Cranfield, C. E. B. A Critical and Exegetical Commentary on the Epistle to the Romans. London; New York: T&T Clark International, 2004. (Vol. 2)

If I run only a passage guide on Rom 11:1-10 from the Guides Menu it populates normally, even if it is the first thing I do after opening Logos4.

This is definitely a problem, but since I've now discovered that I can work around it, I am not so stressed over it :-) Hopefully I won't find other passages that cause this same error to occur. It seems to be a rather quirky problem and I have no idea if it is a Logos4 program problem or something related to my particular configuration (either my pc configuration or my Logos4 configuration). Let me know if you can figure it out. Thanks for your help.

Posts 27857
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Oct 7 2011 3:19 AM

Matt:
It seems to be a rather quirky problem and I have no idea if it is a Logos4 program problem or

I see from your crash log that you have SR-4. Update to the latest SR-5 version (restart L4, type update now in the Command box, or whatever method you normally use!).  Does it happen with SR-5 (resubmit the crash log if it does)?

Dave
===

Windows 11 & Android 8

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Oct 7 2011 7:59 AM

Matt:
This is definitely a problem, but since I've now discovered that I can work around it, I am not so stressed over it :-) Hopefully I won't find other passages that cause this same error to occur. It seems to be a rather quirky problem and I have no idea if it is a Logos4 program problem or something related to my particular configuration (either my pc configuration or my Logos4 configuration). Let me know if you can figure it out. Thanks for your help.

Thank you for the additional information. As Dave suggested, after updating to 4.3 SR-5, please enable logging temporarily by pressing and holding the Ctrl key down when you open the program so that the Sign In screen appears. When you click the Sign In button, logging will be enabled for that session. Then run the Home Page search on Rom 11:1-10 again, and if the program crashes, attach the full Logos4.log.  We will need that if we can't reproduce the crash here with the settings you've provided above.

Posts 34
Matt | Forum Activity | Replied: Fri, Oct 7 2011 5:42 PM

I've upgraded to 4.3 SR-5. I'm still having the same problem. So far I haven't found another reference that causes the crash. And it still only occurs on first run after program startup. Here's a little more information about my system:

Acer Aspire 5745G (Laptop)

Intel Core i-5 @ 2.53 GHz

64 bit

4 GB RAM

Windows 7 Home Premium

My crash logs are attached below. Thanks!

 

70811.Logos4Crash.txt

5100.Logos4Error.log

Posts 34
Matt | Forum Activity | Replied: Fri, Oct 7 2011 5:45 PM

btw I did go through the sign in process as Melissa instructed so the crash logs should be good.

Posts 34
Matt | Forum Activity | Replied: Fri, Oct 7 2011 5:50 PM

Sorry, I now see that Melissa asked for the full Logos4 log. Here it is:

40711.Logos4.log

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Oct 10 2011 8:25 AM

Matt:

Sorry, I now see that Melissa asked for the full Logos4 log. Here it is:

Thanks. I'll submit it to development.

Page 1 of 1 (11 items) | RSS