Removing Books from Library

Page 1 of 2 (23 items) 1 2 Next >
This post has 22 Replies | 1 Follower

Posts 4
David A. Gibson | Forum Activity | Posted: Mon, Dec 26 2011 6:11 AM

How do you remove books from your library collection? I found an answer in an article from 2006 (almost 6 years old) that no longer applies. I wish to remove a lot of the books that I don't really use at all to free up space and reduce clutter. Thanks. 

Posts 6717
Forum MVP
Lynden Williams | Forum Activity | Replied: Mon, Dec 26 2011 6:31 AM

Welcome to the forums David. See this article in the wiki. http://wiki.logos.com/Hiding_Books

Lynden Williams Communications https://www.lyndenwilliams.net 

Posts 4
David A. Gibson | Forum Activity | Replied: Mon, Dec 26 2011 7:43 AM

That's it! Thanks, Lynden. It didn't occur to me to use "hiding books" in my searches. Thanks again. 

Posts 29353
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Dec 26 2011 4:01 PM

David Gibson:
It didn't occur to me to use "hiding books" in my searches.

You make a good point David. The use of the term "hiding" is not intuitive.

macOS, iOS & iPadOS | Logs |  Install

Posts 130
Cindy | Forum Activity | Replied: Sat, Jun 30 2012 5:49 AM

I was so hopeful when I saw this had been asked, but hiding the books won't help me.  I need to remove them.  I got the Perseus collections among others, which was/is fine on my desktop computer, but my laptop can't handle them all.  Ever since it downloaded them all I haven't been able to open my bible library at all.  My desktop computer is dead so I really need to be able to access my library from my laptop.  Is there a way I can get rid of some of them?

Posts 130
Cindy | Forum Activity | Replied: Sat, Jun 30 2012 6:35 AM

I thought I should mention to that I've tried right clicking the icon and holding down the control key which I thought was going to work at first.  It did at least show the sign in.  On that I checked to have it open a blank page and continued to hold down the control key, as I clicked sign in, but it disappeared and again , I got nothing....

I tried right clicking the shortcut on my desktop too and saw that it gives me a couple of possible choices, such as restoring to a previous version.  I am running it as the admin.

I'm running Windows 7 and it says I have 174GB of 220GB Free....  So I don't have a clue what to do....

Posts 26590
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jun 30 2012 6:44 AM

You can request Logos to remove the books from your License - but I think it is all or nothing! See http://community.logos.com/forums/t/47041.aspx

When that is done you should reindex your library (rebuild index command) to remove them from your indexes and remove the books from your resource folder. My suggestion to accomplish both (after removal from your license) is to:-

  • move (not copy) your \Resources folder to a convenient location in your User folder eg.  C:\Users\Cindy\
  • in Logos, enter the command  scan C:\Users\Cindy\Resources  and restart Logos

This should copy all your resources (except Perseus) back into Logos and avoid you having to manually identify and do itself for nearly 2000 titles. I'm not sure if it will index them but if it does not you need to rebuild index to further reduce your disk spaceThen delete C:\Users\Cindy\Resources.


EDIT: just saw your previous post but have to leave to others as it's a late at night for me.

Dave
===

Windows 10 & Android 8

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Jun 30 2012 6:58 AM

Cindy LaFreniere:
I was so hopeful when I saw this had been asked, but hiding the books won't help me.  I need to remove them.

Hiding books in Logos 4 causes the resource files to be removed when Logos 4 is restarted.  Rebuild index can remove "hidden" resources from merged indexes.

Cindy LaFreniere:
On that I checked to have it open a blank page and continued to hold down the control key, as I clicked sign in, but it disappeared and again , I got nothing....

To diagnose "nothing", attaching a zip file with Logos 4 diagnostic log files would allow Logos users and employees to look at "nothing" cause.

Wiki has http://wiki.logos.com/Diagnostic_Logging

If running Logos 4.5c, other option is contacting Logos Tech Support => http://www.logos.com/about/contact

Keep Smiling Smile

Posts 130
Cindy | Forum Activity | Replied: Sat, Jun 30 2012 7:08 AM

Thank you!  I didn't realize that hiding them did that.  They were hidden on my desktop computer, so do you know if they would be when I allowed the program on my laptop to download updates and sync?  I was supposing that they would be...

I found the log files thanks to your help and will attempt to upload them here for someone to see that can make sense of them...

8662.Logos4Error.zip

7587.Logos4.zip

1731.Logos4Crash.zip

Posts 130
Cindy | Forum Activity | Replied: Sat, Jun 30 2012 8:22 AM

I sure hope someone can help me soon...I'm having withdrawals from my bible!

Posts 130
Cindy | Forum Activity | Replied: Sat, Jun 30 2012 12:52 PM

OK, I played with it some more to try and make it work.  I changed it to work with compatibility windows xp since that's what my desktop computer was. and I checked use as admin.  It did do something different after that and looked like it just might work.  It popped up a window asking me if I wanted to allow logos to make changes on my computer and I said yes, but it never loaded it.  It has full access from McAfee so I still don't know what the problem could be.  But in case someone who can makes sense out of the log file can help, here's the latest one:

0842.Logos4 PM.zip

Posts 1216
Matt Hamrick | Forum Activity | Replied: Sat, Jun 30 2012 4:37 PM

Hi Cindy,

I cannot really read the data files, but looking at them looks like some previous data files I uploaded when I was having some problems. I ended up removing Logos 4 and reinstalling it from scratch with a new index and I have a huge library so it took forever to download my resources. The entire process took about 18 hours. I do not know if you remove and reinstall if it will help you. I saw another post from you about your email address and account. On the Logos website, your user info is your account info. The email and password you have for the Logos website is the email and password you use for Logos 4 to sign in. If you reinstall, then make sure you provide the right email and password so Logos will run right.

Now about hiding resources.. check out this link:

http://wiki.logos.com/Hiding_Books

Also, I read a few months ago I read in the forum a post from Mark Barnes on how to hide multiple resources (up to 10) at once. Here is that link:

http://community.logos.com/forums/t/41127.aspx

I hope this provides some assistance for you.

Matt

Posts 26590
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jun 30 2012 8:23 PM

Cindy LaFreniere:
OK, I played with it some more to try and make it work.

There is a problem with the Notes database and it requires some expert attention (Logos Support). You could try to reinstall but it will take a long time, and you must remove the \Logos4 folder (C:\Users\Cindy\AppData\Local\Logos4) after you uninstall Logos.

Dave
===

Windows 10 & Android 8

Posts 26590
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jun 30 2012 8:26 PM

Cindy LaFreniere:
They were hidden on my desktop computer, so do you know if they would be when I allowed the program on my laptop to download updates and sync?

Yes, hidden resources will sync to other computers and the resources will be removed. Be sure to reindex afterward.

Dave
===

Windows 10 & Android 8

Posts 130
Cindy | Forum Activity | Replied: Sun, Jul 1 2012 12:48 AM

I can't believe it...I checked but didn't see any of the replies to this when I got back from the store so I unintalled and reinstalled it, but didn't know about that file you said I had to remove.  Now I just want to cry.....

Posts 26590
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Jul 1 2012 2:21 AM

Cindy LaFreniere:
I can't believe it...I checked but didn't see any of the replies to this when I got back from the store so I unintalled and reinstalled it, but didn't know about that file you said I had to remove. 

So you still have the problem? The \Logos4 folder requires you to view Hidden Files and Folders  - enable this in Control Panel | Folder Options | View.

Dave
===

Windows 10 & Android 8

Posts 130
Cindy | Forum Activity | Replied: Sun, Jul 1 2012 6:32 PM

Yes, I do.  I did get it to finish downloading and indexing but when it was finally all done, it still wouldn't open.  I did manage to get my desktop computer running again though so at least I can use my library now and won't get so stressed until I can get it up and running on the laptop.  I sent you a copy of the latest log file already too.  As far as the file goes, I found that as soon as I read your post about it, but it was too late to delete it as I'd already reinstalled Logos.  (I assume that's the file you're talking about right?)  Is doing another uninstall and reinstall my best bet still then?  If so, I'll delete that file tomorrow afternoon and start yet again, but not before I've seen an answer from you lol  Thanks so much for your help.  This was driving me nuts as it just doesn't make any sense.

Posts 26590
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Jul 1 2012 10:27 PM

Cindy LaFreniere:
Is doing another uninstall and reinstall my best bet still then?  If so, I'll delete that file tomorrow afternoon and start yet again, but not before I've seen an answer from you


You could wait for Logos Support as they should be able to fix it, otherwise you must delete the \Logos4 folder after uninstalling as it contains the corrupt Note file.

Dave
===

Windows 10 & Android 8

Posts 9069
LogosEmployee

Cindy LaFreniere:

I found the log files thanks to your help and will attempt to upload them here for someone to see that can make sense of them...

This is a bug in 4.5c that occurs when trying to migrate highlights to the new notes system at startup. This originally happened in 4.5 (see release notes), so the only explanations I can think of are:

 

  • The computer was upgraded from 4.3 (or earlier) directly to 4.5c on this machine, without going through v4.5, v4.5a, or v4.5b first. (Normally, running one of those earlier versions would migrate the highlights, so there would be nothing for 4.5c to do at startup.)
  • An old visual markup database has been reinstalled on this computer.

 

The safest thing to do would be to wait for us to release an update to 4.5c that fixes this bug; this may take a few days.

The risky thing to do would be to delete your Visual Markup database. This may permanently lose data if your visual markup (i.e., highlights) haven't already been migrated to notes on some other computer, but it should let you get into the application. To do this, rename the following file: C:\Users\Cindy\AppData\Local\Logos4\Documents\0xbhsvnu.fuo\VisualMarkup\visualmarkup.db

When 4.5c SR-2 (that fixes this crash) is released, rename the file back, and the application should migrate any remaining visual markup you have into the new integrated notes & highlighting system that was introduced in 4.5.

Posts 130
Cindy | Forum Activity | Replied: Mon, Jul 2 2012 1:07 PM

Thank you all for your help.  I'm a bit confused now though...  First, let me say that I believe the last time I allowed the library on my laptop to update was in January of this year.  Part of the reason I didn't let it update after that was because I had a lot of problems with my notes in my library after one of the updates and just didn't want to deal with it again, although I was told at the time that it probably wouldn't happen on my laptop anyway. Since I rarely used the laptop though I just didn't update it.

Now, my understanding was that the only file I was supposed to delete after I uninstalled Logos, was the \Logos4 folder (C:\Users\Cindy\AppData\Local\Logos4.  Are you saying that I should NOT delete that?  

Also I don't understand what my notes or "visual markups" have to do with Logos not opening...

Are you saying that if I just wait for the next update to be released and I update Logos on my laptop with it, that it will then open properly?  Or are you saying that I should uninstall it and wait till the update is released to reinstall it and then it will run right?  And if the later is what you mean, then why do I need to rename the file?

As you can see, I'm quite confused...sorry, but I'm not all the computer savvy....

I did contact support but haven't heard back from them again yet...

Page 1 of 2 (23 items) 1 2 Next > | RSS