Logos crashing the video driver

Page 1 of 2 (28 items) 1 2 Next >
This post has 27 Replies | 3 Followers

Posts 9
Chris Berhow | Forum Activity | Posted: Fri, Mar 9 2012 2:19 AM

Logos has started crashing my video driver followed by Logos crashing immediately after. I tried updating the driver, but it is still doing this. It happens frequently when I change windows or even when I am scrolling through text. It is constant enough that Logos is unusable. I saved a log, but I'm not completely sure what to do with it. I have seen a few other complaints about this but no resolution. Has anyone else had this problem?

 

Posts 21998
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Mar 9 2012 3:07 AM

Hi Chris - and welcome to the forums

Sorry to hear that you are having problems.

http://wiki.logos.com/Diagnostic_Logging will provide details on how to submit logs to this forum. Can you reply to this post with the logs you have?

Some questions:

  • What versions of Windows and Logos are you running?
  • When you say that Logos crashes your video driver what exactly do you mean?
  • What video card are you using?

Thanks, Graham

Posts 2416
David Ames | Forum Activity | Replied: Fri, Mar 9 2012 5:12 AM

QUESTION: Do you play any high end video games and do any of them also crash?  Logos 4 is often seen as if it were a high end video game to the computer

Posts 5337
Kevin Becker | Forum Activity | Replied: Fri, Mar 9 2012 5:41 AM

David Ames:

QUESTION: Do you play any high end video games and do any of them also crash?  Logos 4 is often seen as if it were a high end video game to the computer

It might be a good idea to run a stress test on the video card... if it's going bad replacement would be the solution.

Posts 9
Chris Berhow | Forum Activity | Replied: Fri, Mar 9 2012 7:58 AM

I run games all the time without a hitch, Logos is the only program that I am having the issue with. It is an nVidia 330M, I have 8gb RAM and running Windows 7 through Boot Camp since Mac is a worthless overpriced piece of sewage. Don't worry though, I'm not bitter ;-)

 

4024.Logos4 Log.zip

Posts 9
Chris Berhow | Forum Activity | Replied: Fri, Mar 9 2012 8:00 AM

Sorry, Logos Bible Software 4.5a (4.51.0.2048) 

Also, what happens is the screen goes black and Windows gives me an error when it comes back on saying that my video driver crashed and recovered. Then Logos crashes about 3/4 times after that. 

Posts 3163
Dominick Sela | Forum Activity | Replied: Fri, Mar 9 2012 9:17 AM

You may want to check NVIDIA's site to make sure you are on the latest driver. I have a different NVIDIA controller in my laptop but I had the exact same problems, but it was other apps crashing in the video driver.  At the time, about 3-4 weeks ago, I updated to the beta driver (you can find that on their site too) and the problems went away. That driver went into product about 2 weeks ago and I have not had a crash since.

If you need help finding the latest driver shout out; I couldn't help as you did not say if you were 32 or 64 bit Win7, or what model of NVidia you have (I think 330 matches more than 1 model type). Click the Download Drivers menu on the home page and it will walk you through the process.

Posts 9
Chris Berhow | Forum Activity | Replied: Sat, Mar 10 2012 1:59 AM

My system was a few months behind when the problem started, I updated and have the same results. It is the 64 bit Win 7. 

Posts 2
ThomasAnderson | Forum Activity | Replied: Wed, Mar 14 2012 12:19 AM

Have you check for the latest version of display driver. If not update it.

you may try to run logos it in compatible mode.

Posts 9
Chris Berhow | Forum Activity | Replied: Sat, Mar 31 2012 6:46 PM

Well, now it is getting worse and not recovering. It occurs as soon as I make a search. The screen goes black and I can't get it to come back. Driver is updated (meaning I may have to roll it back).

It gets even more strange, though. I loaded up my Mac OS and as soon as I try to search it just closes Logos completely. My guess is that the Mac is catching a similar (or the same) type of error and closing things down. This is making me think "hardware" except that I have no trouble in any other programs. Only Logos is crashing, and it is crashing in both of my OS's. I am running Win 7 in Boot Camp.

 

Posts 82
Joe | Forum Activity | Replied: Sat, Mar 31 2012 8:11 PM

Hi Chris,

I had this problem last year and my problem was that I did not have enough video ram. Maybe it might work for you to upgrade your video card?

From the Logos tech FA: http://www.logos.com/support/techfaq

 

Q: What are the system requirements for Logos Bible Software 4 on PC and Mac?

A: The minimum requirements for running Logos 4 on a PC are:

  • ....1024X600 Display
  • 256 MB DirectX 9 graphics device

The recommended requirements for running Logos 4 on a PC are:

  • ....1280X1024 display
  • 512MB DirectX10 graphics device with WDDM 1.0 or higher driver

Once I upgraded my video card (from using the on-board card), it was faster and did not fuzz out.  I'd recommend 512MB.

One nice thing is that sometimes there will be a nice graphics card on sale with a rebate from Fry's or something.

Joe  Big Smile

Posts 5564
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Sat, Mar 31 2012 8:15 PM

Chris Berhow:
Well, now it is getting worse and not recovering. It occurs as soon as I make a search. The screen goes black and I can't get it to come back. Driver is updated (meaning I may have to roll it back).

Just saw this thread.

If you have an nVidia card made by another manufacturer (e.g., Asus, eVGA), do not use the video driver updates from the nVidia site unless the card manufacturer tells you to. Instead go to the card manufacturer and get the latest drivers from them. I learned this lesson the hard way, and the symptoms I had were similar to yours.

I'm not saying that is the issue, but it could be.

If you want to take a look at what your video card is doing search for a little freeware program called GPU-Z. You can see temps RAM loads, etc. in real time as your card is being used. You might be able to tell if the problem is overheating, rather than a driver conflict, for example.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 9
Chris Berhow | Forum Activity | Replied: Sun, Apr 1 2012 7:14 AM

Joe and Richard, thank you for your input. 

Joe: I am on a laptop that has never had issues before, and I meet the recommended (which I should, since I also game on this computer!).

Total available graphics memory 4095 MB
Dedicated graphics memory 512 MB
Dedicated system memory 0 MB
Shared system memory

3583 MB

 

Richard: That could very well be the problem, I will try a rollback. My NVIDIA settings were telling me to upgrade, but being as this is a very proprietary system I will roll it back and hope for the best. I was wondering if this was the issue and if it isn't, I'm in trouble! lol

 

Thanks again.

Posts 502
Randall Hartman | Forum Activity | Replied: Mon, Apr 2 2012 5:44 AM

Chris, the same thing happens to me.  It has not gotten any worse so I just live with it...

 

Posts 9
Chris Berhow | Forum Activity | Replied: Mon, Apr 2 2012 2:04 PM

I wish I could, it is 100% unusable now. I can't even start a search on my computer. Oh well.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Apr 3 2012 2:25 AM

Chris Berhow:
It gets even more strange, though. I loaded up my Mac OS and as soon as I try to search it just closes Logos completely. My guess is that the Mac is catching a similar (or the same) type of error and closing things down. This is making me think "hardware" except that I have no trouble in any other programs. Only Logos is crashing, and it is crashing in both of my OS's. I am running Win 7 in Boot Camp.

Logos 4 on Windows has an error: "Unhandled exception: System.InvalidOperationException: An unspecified error occurred on the render thread."

Wonder about Logos 4 Mac diagnostic logging ?  Wiki Mac Troubleshooting has => How to Report Bugs in Logos 4 Mac

Also wonder if Software up to date on Mac OS X ? including Boot Camp ?  Apple Support has Boot Camp page => http://www.apple.com/support/bootcamp/

Since running stable Logos 4.5a, another option is contacting Logos Tech Support => http://www.logos.com/about/contact

Keep Smiling Smile

Posts 3154
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Apr 3 2012 11:45 AM

Hello Chris, I'm sorry you're having these issues with Logos 4. I looked at the log you posted and the issue most definitely either OS or hardware based; in this case since you've tried it on both the Mac and Windows side of the machine, and are getting a similar result on both, I am lead to believe the issue is likely hardware. I know there is a Stress Tester called Prim95 that we use when questions of hardware come up on Windows machines, but I don't think it would test the GPU. I've asked development if they recommend one we can try for you. In the mean time if you want to give us a call we can get more details from you and hopefully get to the bottom of the issue.

 

Posts 9
Chris Berhow | Forum Activity | Replied: Sat, Apr 7 2012 4:32 AM

Some new info that may help.

This ONLY happens from the home screen. If I start with blank layout I can do searches again. If I try to search or do anything from the home screen, I crash.

So, for now I just disabled the Home Screen and am hoping it stops crashing. 

Posts 6
Greg Gorby | Forum Activity | Replied: Sat, Apr 7 2012 9:17 AM

I just bought Logos last night and I have an Nvidia 560ti and I am getting the same problems. Logos starts having weird colors and black blotches then stops responding. The video driver crashes and I have to quit Logos.  For the record I have an Amd 8150, Nvidia 560ti, and Win 7 64 bit. Temps are not an issue I have a huge box with 8 fans. All games that I have run fine. I am very excited about having Logos and I would love to have this running soon. Please help.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Apr 7 2012 9:43 AM

Greg Gorby:

I just bought Logos last night and I have an Nvidia 560ti and I am getting the same problems. Logos starts having weird colors and black blotches then stops responding. The video driver crashes and I have to quit Logos.  For the record I have an Amd 8150, Nvidia 560ti, and Win 7 64 bit. Temps are not an issue I have a huge box with 8 fans. All games that I have run fine. I am very excited about having Logos and I would love to have this running soon. Please help.

Welcome Big Smile

Wonder if initial Logos 4 indexing is complete ?  Wiki Getting Started with Logos has => Installation + Indexing

For crash, curious about Logos 4 diagnostic logs ? Wiki has => http://wiki.logos.com/Diagnostic_Logging

Also wonder if any Windows logs have intriguing messages ?

Likewise curious about NVIDIA driver version ? My laptop has a GeForce GT 550M with driver 296.10

Keep Smiling Smile

Page 1 of 2 (28 items) 1 2 Next > | RSS