LS 5 FREEZES

Page 1 of 1 (10 items)
This post has 9 Replies | 1 Follower

Posts 41
Steve | Forum Activity | Posted: Sat, Dec 1 2012 4:15 AM

6114.Logos Log Files.zip

 

LS 5 Freezes after opening a created layout.  No problem with this layout untill after todays update.  I have 5 serches saved in this layout.  It that causing the freezing?

Posts 762
Patrick S. | Forum Activity | Replied: Sat, Dec 1 2012 5:21 AM

The layout seems to load OK including the search panels, there is this error though:

Error TiledFrameTabControl Unable to set focus to the content (Libronix.Utility.Windows.Controls.TiledFramePanelContent: Christianity and the Enquiring Mind) of tab item (LDLS4.OurTiledFrameTabItem Header:Christianity and the Enquiring Mind Content:Christianity and the Enquiring Mind).

Do you have a problem with that resource?

 

Then there are a large number of errors listed directly after this SyncManager entry:

2012-12-01 20:59:06.8382 21 Info SyncManager (2ms) Syncing client: Repository = (Libronix.DigitalLibrary.Documents.WordList.WordListManager+OurDocumentSyncClientRepository), Service = (Logos.Sync.WebService.JsonSyncService`1[Logos.Documents.Contracts.WordLists.WordListSyncItem])

2012-12-01 20:59:10.6084 1 Error MethodBehaviorConverter Type 'NamedObject' has no matching method 'Load'.
2012-12-01 20:59:10.6084 1 Error MethodBehaviorConverter Type 'NamedObject' has no matching method 'NamedDelete'.
2012-12-01 20:59:10.6114 1 Error MethodBehaviorConverter Type 'NamedObject' has no matching method 'Update'.

While may be due to the syncing, or maybe not.

To exclude the layout, and syncing you can launch Logos and hold the Ctrl key directly after, in the dialog box which comes up tick 'Use blank layout'  then click the 'Work Offline'  button. Use Logos for a while and see how it goes. Then try to load the layout.

Also were there only the one log file, no crash text file, or error log etc.?

"I want to know all God's thoughts; the rest are just details." - Albert Einstein

Posts 41
Steve | Forum Activity | Replied: Sun, Dec 2 2012 12:58 AM

Patrick

Thanks.  I do not know why there was only the log file.  Is there something I need to do to generate the crash text file and the error log?

 

The layout will freeze in offline mode.  I haven’t noticed the problem in other layouts as of yet.  

 

When it freezes Logos is in a loop with a continuous hourglass.  When in the loop Logos will blink ever 3-5 seconds depending on which dropdown its stuck on.  Clicking the “X” button will bring up Windows close application and search for solution screen.  The Windows close application screen will disappear in conjunction with Logos’ blinking.  The “Task Manager” shows Logos not responding.  While experimenting with the problem I have managed to close Logos and send a Windows error report and check for a solution 3 or 4 times.  That was how I closed Logos when I sent you the log files.

Posts 25209
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Dec 2 2012 2:52 AM

Steve C.:
Thanks.  I do not know why there was only the log file.  Is there something I need to do to generate the crash text file and the error log?

They should be in the Logos Log Files folder but a crash log is not generated for "not responding", particularly when you close it

Steve C.:
When in the loop Logos will blink ever 3-5 seconds depending on which dropdown its stuck on.  

Which drop downs? Is it only drop downs that cause the problem?

Steve C.:
The layout will freeze in offline mode.  I haven’t noticed the problem in other layouts as of yet.  

It is quite intensive with 50 resource panels, 5 search panels and 125 visual filters being applied to the panels (1 VF applying to many resources). The VF's appear to be applied quite efficiently. You could try to cut-down the number of search panels and/or resource panels (save your layout before making changes) to see what happens.

 

Dave
===

Windows 10 & Android 8

Posts 41
Steve | Forum Activity | Replied: Sun, Dec 2 2012 4:39 PM

Dave

Your comments are helpful. Thanks for the insights.

Dave Hooton:

Steve C.:
Thanks.  I do not know why there was only the log file.  Is there something I need to do to generate the crash text file and the error log?

They should be in the Logos Log Files folder but a crash log is not generated for "not responding", particularly when you close it

 

 

Suspected so…

 

Dave Hooton:

Steve C.:
When in the loop Logos will blink ever 3-5 seconds depending on which dropdown its stuck on.  

Which drop downs? Is it only drop downs that cause the problem?

 

It seems to be the drop downs, Library, Documents, Layouts, Tools are the specific ones.  When it loops, the drop down box retains a wide black outline in will stay as the front window over any other application (see screen shot below)

 

 

Dave Hooton:

Steve C.:
The layout will freeze in offline mode.  I haven’t noticed the problem in other layouts as of yet.  

It is quite intensive with 50 resource panels, 5 search panels and 125 visual filters being applied to the panels (1 VF applying to many resources). The VF's appear to be applied quite efficiently. You could try to cut-down the number of search panels and/or resource panels (save your layout before making changes) to see what happens.

 

Your comment is interesting, “50 resource panels.”  If the log is showing that I have 50 open then something is strange or I misunderstand the term “resource panels”.  That term must refer to more than the 26 resource book I have open.  There are likely to be 125 visual filters as I have highlighted sections in most of the books (5 markups in each book would equal that).

 

The Windows resource monitor shows only 52% of memory usage when it is frozen, upon closing Logos the memory drops to 43%.  Interestingly the disk usage is off the scale.  Trying system cleanup and defrag.  Its Monday morning here and need to work on other things.  I will experment later and give more feedback.

Posts 25209
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Dec 2 2012 7:12 PM

Steve C.:
Your comment is interesting, “50 resource panels.”  If the log is showing that I have 50 open then something is strange or I misunderstand the term “resource panels”.  That term must refer to more than the 26 resource book I have open.

L5 is loading 50 resource panels but when I check resource Id's I see it is loading 25 resources twice. My own logs never show a duplication of loading panels.

The first group of 25 is preceded by a large number of   "Error    MethodBehaviorConverter    Type 'NamedObject' has no matching method 'Load'." messages, and the second group of 25 (some 4m 15s later) is also preceded by a large number of similar errors!  Logos Tech need to take a good look.

Dave
===

Windows 10 & Android 8

Posts 41
Steve | Forum Activity | Replied: Mon, Dec 3 2012 4:21 AM

Dave Hooton:

The first group of 25 is preceded by a large number of   "Error    MethodBehaviorConverter    Type 'NamedObject' has no matching method 'Load'." messages, and the second group of 25 (some 4m 15s later) is also preceded by a large number of similar errors!  Logos Tech need to take a good look.

 

Dave and Logos Tecs

Using Logos log files I have deduced I can do anything in Logos and have a clean errorless log if I do not open the “Layout” dropdown.  Simply opening the “Layout” and clicking off of it without opening any of Layouts within I will get multiple Error Messages "MethodBehaviorConverter Type 'NamedObject' has no matching method 'Load'" . 

I deleted the “Layout” I thought was causing the problem (the one with 25 resources) and still get the errors.  I am reluctant to delete my other layouts because I do not know if that will fix the problem. 

The same thing is happening on my laptop.  Incidentally, once the “Layout” is opened other dropdowns can cause the freezing.  They do not create errors though.

Thanks for all the help and insight.

Steve

Posts 29
Rodney Staton | Forum Activity | Replied: Mon, Dec 3 2012 1:59 PM

My L5 freezes (not responding) quite a bit; didn't have this problem with L3 or L4. It seems pretty random, not just when I have a specific layout opened.  Lasts a few seconds to forever and I have to force a shut down. Get the same hourglass, etc.

Hope they fix this soon

Posts 25209
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Dec 3 2012 2:34 PM

Steve C.:
I deleted the “Layout” I thought was causing the problem (the one with 25 resources) and still get the errors.  I am reluctant to delete my other layouts because I do not know if that will fix the problem. 

Thank you, Steve.

I now realise you were opening the same layout twice and I also get the same catalog of  MethodBehaviorConverter errors when opening the menu. Deleting layouts will not fix your problem!

 

Dave
===

Windows 10 & Android 8

Posts 41
Steve | Forum Activity | Replied: Tue, Dec 4 2012 2:57 AM

Dave Hooton:
I also get the same catalog of  MethodBehaviorConverter errors when opening the menu. Deleting layouts will not fix your problem!

Dave

Thanks for the feedback and letting me know you are getting the same errors.  I suspect Rodney (above entry) is getting the same errors.  If I keep my workspace simple and small I can get by.

I suspect Logos is already working on the problem, at least I hope so.  Im not in the forum much, but I think Logos keeps tabs problems and errors noted in it and fixes them fairly quickly.

My suggestion to others having a problem is to hold down the ctrl button when launching Logos and click the box “Use Blank Layout.”  Create a new work space and work from there.  If you think Im giving bad info here, let me know and I will come back and edit it out. 

Steve

 

Page 1 of 1 (10 items) | RSS