Bug(Mac): Dock BibleFacts (Place) and Content disappeared

Page 1 of 2 (22 items) 1 2 Next >
This post has 21 Replies | 1 Follower

Posts 1002
LimJK | Forum Activity | Posted: Wed, Jul 24 2013 7:03 AM

Hi,

I cannot find my original post(s), so starting a new thread.

To recreate the problem:

  • Start BibleFacts from (Tools or Shortcut Bar) into a floating window
  • Let us use "Ephesus"
  • Everything displayed as it should be
  • Dock this tab (right mouse button click on tab - select dock this tab)
  • .... Panel is dock, however, content disappeared
  • .... it is still blank if you enter the same place again 

Work around ... enter another place.

I have tested this on Logos Bible Software 5.1 SR-2 (5.1.0.0963) for Mac

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 5265
Forum MVP
Mike Binks | Forum Activity | Replied: Thu, Jul 25 2013 1:42 AM

Sorry Lim - It all seems to work here as expected.

tootle pip

Mike

How to get logs and post them. (now tagging post-apocalyptic fiction as current affairs)

Posts 1002
LimJK | Forum Activity | Replied: Thu, Jul 25 2013 5:58 AM

Mike,

thanks ... It is fine with Logos for Windows ... I am reporting issue on logos for Mac 😊

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 10819
Forum MVP
Jack Caviness | Forum Activity | Replied: Fri, Jul 26 2013 2:48 AM

LimJK:
I am reporting issue on logos for Mac

Unless Mike has apostatized, he is also using a Mac Cool

This works correctly in 5.1a Beta 2 on Mac OS 10.8.4

Posts 1002
LimJK | Forum Activity | Replied: Fri, Jul 26 2013 3:44 AM

Jack Caviness:

Unless Mike has apostatized, he is also using a Mac Cool

This works correctly in 5.1a Beta 2 on Mac OS 10.8.4

Jack,

Smile Thanks for info that it works properly for 5.1a Beta 2

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 1002
LimJK | Forum Activity | Replied: Thu, Aug 22 2013 10:47 PM

Jack Caviness:

This works correctly in 5.1a Beta 2 on Mac OS 10.8.4

Hi

I am running Logos Bible Software 5.1a (5.1.1.0589) the issue in my original post is still not resolved.

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 10819
Forum MVP
Jack Caviness | Forum Activity | Replied: Fri, Aug 23 2013 5:35 AM

Unfortunately, I still cannot reproduce this problem. Perhaps you should contact Logos Tech Support.

Posts 1002
LimJK | Forum Activity | Replied: Mon, Aug 26 2013 7:18 AM

Hi Logos Mac Developer Smile

The Bug I originally reported in the OP is still there, Some additional information on how I work around, may give you some information to recreate this bug.

  1. I just need to do something to initiate the repainting of the Panel ... by (a) resize the Panel bigger or smaller or (b) click on the navigational square at the top
  2. Another way ... instead of docking the tab into a blank layout which I did for my test in the original post, add the information Window ... and for me the content disappearing act ... disappeared Smile
  3. Note that once repainted, I can float and re-dock the panel without problem
  4. Note that this only happens the very first time I dock the BibleFacts Floating Window on a blank Layout.

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 3187
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Aug 27 2013 4:04 PM

Jack Caviness:

Unfortunately, I still cannot reproduce this problem. Perhaps you should contact Logos Tech Support.

FYI RE: Tech and beta versions of Logos

Typically Tech will direct anyone on beta software to the beta forums. We can't track everything about the, beta version and do not install it on our machines, so it is best if someone has a problem in the beta version of Logos to post about it in the beta forums.  

 

Posts 10819
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Aug 27 2013 7:45 PM

Tommy Ball:

Jack Caviness:

Unfortunately, I still cannot reproduce this problem. Perhaps you should contact Logos Tech Support.

FYI RE: Tech and beta versions of Logos

Typically Tech will direct anyone on beta software to the beta forums. We can't track everything about the, beta version and do not install it on our machines, so it is best if someone has a problem in the beta version of Logos to post about it in the beta forums.  

Guess I was not thinking about this being the beta forum. Recommended that he contact Tech Support since no one from Logos seemed interested in the problem. Frankly, it gets a bit tiresome to post bug reports and then have them ignored by Logos. I know the excuse that someone from Logos reads these thing but are too busy fixing bugs to respond on the forum. That is a lame excuse. It takes less than a minute to hit reply and type "we are aware of the problem and are working on it." The stonewall of no response gives the impression that Logos simply ignores many bug reports.

Posts 1002
LimJK | Forum Activity | Replied: Wed, Aug 28 2013 1:28 AM

Tommy Ball:

FYI RE: Tech and beta versions of Logos

Typically Tech will direct anyone on beta software to the beta forums. We can't track everything about the, beta version and do not install it on our machines, so it is best if someone has a problem in the beta version of Logos to post about it in the beta forums.  

Angela Murashov:

5.1a Release Candidate 2 (5.1.1.0591) is available for download. An RC is considered a stable version.

Tommy,

Sorry, I posted here:

  • because Logos said RC is considered a stable version, I am out of beta for a while now.
  • This issue was reported quite a while back (on a much earlier thread that went missing), always on Stable version
  • I think I have email to tech@logos.com before

I was just hoping that information provided here will give your developers some lead into fixing this Smile

PS: That being said, I am very appreciative of how Mac Version has improved, I am using it most of the time now Smile without starting parallels and Windows (that reduces my battery power)

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 3187
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Aug 28 2013 9:51 AM

LimJK:
Sorry, I posted here:

Don't be sorry. 

LimJK:

  • because Logos said RC is considered a stable version, I am out of beta for a while now.
  • This issue was reported quite a while back (on a much earlier thread that went missing), always on Stable version
  • I think I have email to tech@logos.com before

The problem is, for those of us in Tech that do try to get into the forums as much as we can, only have the stable versions of the software installed and can't accurately replicate it. That being said I'll see if I can in 5.1 Sr-3 and report back.

 

Posts 3187
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Aug 28 2013 10:06 AM

LimJK:

To recreate the problem:

  • Start BibleFacts from (Tools or Shortcut Bar) into a floating window
  • Let us use "Ephesus"
  • Everything displayed as it should be
  • Dock this tab (right mouse button click on tab - select dock this tab)
  • .... Panel is dock, however, content disappeared
  • .... it is still blank if you enter the same place again 

I was unable to replicate the behavior in 5.1 SR-3. I attempted with Ephesus, Rome, and Corinth. With all three locations the map showed up perfectly after docking via the context menu. If you post logs of the behavior I can submit them to development with a link to this thread. 

 

Posts 1002
LimJK | Forum Activity | Replied: Wed, Aug 28 2013 9:06 PM

Tommy Ball:

I was unable to replicate the behavior in 5.1 SR-3. I attempted with Ephesus, Rome, and Corinth. With all three locations the map showed up perfectly after docking via the context menu. If you post logs of the behavior I can submit them to development with a link to this thread. 

Tommy,

I found something interesting Smile ... as I was trying to get as clean a log as possible without all the Home page related activities. I went it to Program Settings, to start up Logos with a BLANK LAYOUT.  Guess what ... the problem disappeared.

I Just want to make sure ... I went back to turn on HOME Page ... Yes the problem in my Original Post still exists.

This is my setting for Home page

This is my log

0576.LogosLogs.LimJK.20130829-115231.zip

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 3187
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Aug 29 2013 9:20 AM

Ahhhhh, now I can repro! Thanks for the additional info, LimJK. I'll sumbit to Dev.

 

Posts 1002
LimJK | Forum Activity | Replied: Thu, Aug 29 2013 10:13 AM

Tommy Ball:

Ahhhhh, now I can repro! Thanks for the additional info, LimJK. I'll sumbit to Dev.

Tommy,

I am glad we finally catch the bug Smile

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 1471
Angela Murashov | Forum Activity | Replied: Wed, Sep 11 2013 5:05 PM

LimJK:
.... Panel is dock, however, content disappeared

This will be fixed in 5.1b Beta 1.

Posts 1002
LimJK | Forum Activity | Replied: Wed, Sep 11 2013 9:33 PM

Angela Murashov:

This will be fixed in 5.1b Beta 1.

Smile Thanks Angela Yes

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 1002
LimJK | Forum Activity | Replied: Tue, Sep 24 2013 3:53 PM

Angela Murashov:

This will be fixed in 5.1b Beta 1.

Angela,

Thanks while this fixed the specific bug I reported.

However, I noticed there were a number of crashes ... unfortunately, I was unable to reproduce the crash in a consistent manner to report it as a bug for a few days. (I keep it in this thread as I thought it is related ... feel free to move it).

This morning, I think I found something that I can reproduced.

  • Open BibleFacts in a New Tab (I have "Ephesus" in the reference box ... my last use of BibleFacts)
  • Enter "Zion" ... select "Jerusalem (Mount Zion)" from the drop down list
  • Enter ... crashed
  • ... I have repeated this many time with various variation (such as open in floating window first, did the above and then Dock in a Tab) ... all crashed.

This is the log immediately after the crash

3288.LogosLogs.LimJK.20130924-090500.zip

This is the log immediately restarting Logos after crash (to catch the Crash Report ... before it get deleted by a new Logos session)

0184.LogosLogs.LimJK.20130924-090641.zip

JK

MacBookPro Retina 15" Late 2013 2.6GHz RAM:16GB SSD:500GB macOS Sierra 10.12.3 | iPhone 7 Plus iOS 10.2.1

Posts 1471
Angela Murashov | Forum Activity | Replied: Tue, Sep 24 2013 4:05 PM

Thank you for reporting this crash. I can reproduce this on Mac in 5.1b and I have created a case for Development. 

Page 1 of 2 (22 items) 1 2 Next > | RSS