Page 1 of 1 (12 items)
This post has 11 Replies | 2 Followers

Posts 18
Laurent Tran-Qui | Forum Activity | Posted: Fri, Nov 8 2013 1:10 AM

Hi

I would like to know why the Logos app is so slow on tablets: android and iPad Air

I am a very heavy user of Logos, and own a huge library. 

I have used many Android tablets over the year, with the latest one being the Asus Transformer TF 300 and the Nexus 7 and Galaxy Note 2.

Being also a tech guy, I find the Logos app to be so slow. Each click needs 1 sec to get the result (including the new window's sliding). For example, when I want to highlight, it needs like 5 clicks to get it done, losing about 4 seconds to highlight and the loss of my attention as a consequence. 

Because i thought that the speed issue was due to the hardware, I just purchased the msot powerful tablet on the market: the iPad Air. But to my dismay, I discover that the app is still so slow, because of all the clicks to get a task done, and all the windows which need 1 second for sliding into the screen.

Could it be possible to remove the windows slidings (slows performance) so the windows appear right away, at the blink of the eye.

And even better: could it be possible to have a Highlighting panel always available on the side of the screen, so that I could highlight in just 1 click. This request would be my top priority request. 

Thanks for your response.

Posts 978
LogosEmployee
Dave Dunkin (Faithlife) | Forum Activity | Replied: Fri, Nov 8 2013 8:08 AM

Thanks for the suggestion. This is already on our radar and we will me making improvements in this area in the near future.

Posts 18
Laurent Tran-Qui | Forum Activity | Replied: Fri, Nov 8 2013 8:19 AM

Thanks for the reply Dave.

You give me hope for the future.Smile

Posts 124
Randy Murphy | Forum Activity | Replied: Fri, Nov 8 2013 8:25 AM

Yes

Posts 1
Bud Massey | Forum Activity | Replied: Wed, Aug 19 2015 2:27 PM

It's it still on the radar?  :)

Posts 27675
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Aug 19 2015 2:31 PM

Welcome! Smile

Bud Massey:
It's it still on the radar?

Is what on the radar?

OSX & iOS | Logs |  Install

Posts 5249
Dan Francis | Forum Activity | Replied: Wed, Aug 19 2015 3:02 PM

I am sure they are always trying to improve the mobile APPs but the clouds based set up makes it always going to be slow unless you are on a very high speed connection, but even when I have LTE full strength it still feels pretty slow to me.

-Dan

Posts 1
Toby Brogden | Forum Activity | Replied: Wed, Sep 28 2016 9:19 PM

Well, here we are in 2016 with the release of 7 and I'm still amazed at how many times I see (Not Responding) or the spinning wheel.

Posts 2054
GaoLu | Forum Activity | Replied: Wed, Sep 28 2016 10:06 PM

James 1:2-4 

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Wed, Sep 28 2016 10:25 PM

Toby Brogden:

Well, here we are in 2016 with the release of 7 and I'm still amazed at how many times I see (Not Responding) or the spinning wheel.

Just to clarify, Logos 7 runs on Windows and Mac Desktops, not on mobile devices; this is the iPhone/iPad Apps forum.

The release of Logos 7 has no bearing on mobile app performance. If you are posting about a Logos 7 performance issue please create a new post on the Logos 7 forum and include any reproduction steps you might have so we can zero in on the issue. If the issue is related to the mobile apps, please create a new post on either this thread or the Android Apps thread and include reproduction steps.

Posts 1
Peter Haring | Forum Activity | Replied: Sat, Oct 20 2018 4:46 AM

I’m running a 10.5 inch iPad Pro and the app is still remarkably sluggish.  I get the spinning gear wheel on a daily basis.

Does anybody have any thoughts on whether there is anything I can do to speed things up? I’m guessing my internet connection speed isn’t of any consequence if I’ve downloaded most of the resources to the iPad.  Any feedback or thoughts on this would be appreciated.

On a positive note, I enjoy the recent interface improvements.  Very helpful.

Posts 21914
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Oct 20 2018 4:50 AM

Hi Peter - and welcome to the forums.

Sorry to hear you are having performance problems - it works fine on my iPad Pro.

This particular forum is no longer monitored by most people. I suggest you repost in https://community.logos.com/forums/142.aspx and we'll see what we can do to help work out what is going on.

If you can provide some specific examples of what you are doing when you get the spinning wheel that would be helpful

Graham

Page 1 of 1 (12 items) | RSS