Logos 4.0a SR-1 & SR-2 Release Notes

Page 4 of 6 (105 items) « First ... < Previous 2 3 4 5 6 Next >
This post has 104 Replies | 4 Followers

Posts 406
Fred Greco | Forum Activity | Replied: Sat, Jan 2 2010 8:15 AM

I can understand not having full customer service on a holiday weekend.

If that is the case, then I cannot understand releasing ANYTHING on that same weekend!  What was basically done was an SR was sent out (which by definition "Service Release") should be near flawless (since the "Release" was not really broken - check the Release notes) right before everybody ran out the door for the holiday.

Add to that the fact that Logos auto updates, and you have a whole bunch of dedicated users completely messed up right before needing to use the software (for sermon prep) and not a peep from ANYONE at Logos.  Just more and more and more posts from users describing how this SR broken a whole bunch of functionality - and BASIC functionality at that!

It very disconcerting.

Fred Greco
Senior Pastor, Christ Church PCA, Katy, TX
Windows 10 64-bit; Logos 7.1 SR-2 (Reformed Platinum)

Posts 653
Alex Scott | Forum Activity | Replied: Sat, Jan 2 2010 9:14 AM

Fred Greco:

I can understand not having full customer service on a holiday weekend.

If that is the case, then I cannot understand releasing ANYTHING on that same weekend!

That's what I wonder too.

SR2 was obviously rushed out the door before a long weekend without adequate testing, and no means of access to resolve any problems it might encounter.  It looks like there is such a rush to meet the demands of several hundred thousand users to fix each piddling little private inconvenience that they are beginning to get sloppy in their rush to satisfy everybody.

Much as I appreciate all the time and effort that Logos is putting into L4, perhaps it's time for them to step back and slow down a little. 

I also notice that up until now there has been absolutely no response to this problem from Logos, and yet there has been at least one post on these forums from a high ranking Logos person since the problem surfaced.

Longtime Logos user (more than $30,000 in purchases) - now a second class user because I won't pay them more every month or year.

Posts 23
Tony (Manuel) Perez | Forum Activity | Replied: Sat, Jan 2 2010 9:15 AM

Thanks LOGOS. My Library works great. Really no problems to complain about.

Posts 8967
RIP
Matthew C Jones | Forum Activity | Replied: Sat, Jan 2 2010 9:44 AM

Derek R. Iannelli-Smith:
Also, the only other helpful solution would perhaps to be able to provide screen shots... this forum does not allow this...

Derek,, If you use the Insert "Attachments/Media" button (2 spaces to the left of the "Smiley" button) you can insert screen shots. I just used Jing (free version) to do just that with your post.

Logos 7 Collectors Edition

Posts 5572
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Sat, Jan 2 2010 10:13 AM

Fred Greco:

I can understand not having full customer service on a holiday weekend.

If that is the case, then I cannot understand releasing ANYTHING on that same weekend!  What was basically done was an SR was sent out (which by definition "Service Release") should be near flawless (since the "Release" was not really broken - check the Release notes) right before everybody ran out the door for the holiday.

Add to that the fact that Logos auto updates, and you have a whole bunch of dedicated users completely messed up right before needing to use the software (for sermon prep) and not a peep from ANYONE at Logos.  Just more and more and more posts from users describing how this SR broken a whole bunch of functionality - and BASIC functionality at that!

It very disconcerting.

I'm one of those reporting problems (http://community.logos.com/forums/t/8544.aspx) but I can still do most of what I need. I'm not upset personally, nor disconcerted. Help will come, and it will be stellar, as it always is.

This release was supposed to be a very minor update to correct an issue with a Dec31 bug. Apparently something else happened, either with this release, or with the transition to 2010 that is causing a problem. Not everyone is having the problem, so it's quite baffling as to what exactly is going on.

Your install issues are not likely related to this (could be, but I don't think so). A few have had install issues, often with installations on a networked computer, or with things like WindowBlinds running, or other interface 'improvers,' as well as overly aggressive anti-virus/firewall programs, etc. Your issues will be worked out as well, but it will take someone with more insight than we have (obviously).

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 5
Derek R. Iannelli-Smith | Forum Activity | Replied: Sat, Jan 2 2010 11:21 AM

Richard... I must have missed it... do you work for Logos...? if not, you just acerbated the situation and made me even more stimulated onto love and good deeds in wasting my time comparing this to dell and microsoft....  the point... customer service....

pt2 .... if you read previous post... I comment that I have done all that already..... called, left emails, sent screenshots, reported through faulty software...  in all fairness, fairness is I paid for something and it does not work......  and if dell and microsoft pull that with me, they lose my business....  There is alot more at stake then fairness... Christ paying for my sins was not fair, facing God's wrath is not fair, and my mom not hugging me enough is not fair.... however, I am still responsible...  that is what I am requesting... responsibility...  I have been responsible to use every venue at my disposal to reach logos....  (email, letters, screen shots, send from the software, and posting in forums)....  I am NOT responsible FOR Logos lack of response.  I am also responsible for how I respond to being sinned against...  In all fairness,  if your not an employee or can provide a solution to my problem... go post on the "Why can't we all just get along" forum and let us get back to solving the problem...  ;) that is fair.... 

I wrote an article about this very thing this year:  http://computerrepairblog.com/nightmare-clients-christians-are-not-necessarily-the-best-to-do-business-with.html

My brothers post below... says it better than I do.... thank you

Posts 406
Fred Greco | Forum Activity | Replied: Sat, Jan 2 2010 11:25 AM

Richard,

I'm sure at some point it will be fixed.  But as someone who has actively across the net tried to help people and remove concerns about Logos (as a good friend of mine trashed Logos 4 install procedure on a very high traffic blog), and as someone who has repeatedly understood the changes in philosophy and some functionality based on Bob's explanations, I am really perturbed at this.

I have not complained about any old Logos 3 functionality lost (except maybe CBV).  But this problem is not a result of moving to a new platform, or of a different philosophy, or of different ways to do things.  It is plain and simple - incredibly bad business practice.  You should never, never, NEVER push out an update right before you have absolutely no plans to support it for 72 odd hours.  That is business 101.  Even having one or two people responding on forums is not normal support.  But Logos did not even do that.  They basically dumped out something that fixed a minuscule set of problems for a minuscule set of users, and then when it basically broke Logos for a number of high volume customers, they did nothing.

It will likely get worse unless Logos is monitoring the forums now - since they are West Coast, I would not expect any fixes until late on Monday or even Tuesday.  That is like 5-6 days of breakage. Until then, no acknowledgment of the problem, no ETA, no ability to go back to an old version (THAT is a fix they could have implemented in one hour or so with a link to an old installer).  Very sad.

Fred Greco
Senior Pastor, Christ Church PCA, Katy, TX
Windows 10 64-bit; Logos 7.1 SR-2 (Reformed Platinum)

Posts 5
Derek R. Iannelli-Smith | Forum Activity | Replied: Sat, Jan 2 2010 11:31 AM

Fred, good points and said with gentleness....  thank you for being a peacemaker!

Posts 2778
J.R. Miller | Forum Activity | Replied: Sat, Jan 2 2010 11:39 AM

Derek R. Iannelli-Smith:
acerbated
huh ???  I don't know what that word is so I am not even sure how to interpret the rest of your comment. Hmm

My Books in Logos & FREE Training

Posts 3683
BillS | Forum Activity | Replied: Sat, Jan 2 2010 11:46 AM

I think he meant exacerbated (made it worse)...

Grace & Peace,
Bill


Asus GF63 8RD, I-7 8850H, 32GB RAM, 1TB SSD, 2TB HDD, NVIDIA GTX 1050Max
Samsung S9+, 64GB
Fire 10HD 64GB 7th Gen

Posts 28237
Forum MVP
MJ. Smith | Forum Activity | Replied: Sat, Jan 2 2010 11:46 AM

Fred Greco:
You should never, never, NEVER push out an update right before you have absolutely no plans to support it for 72 odd hours.

This is true. Unfortunately, this occassionally happens. The programmer says in good faith, this line is all I changed ... and what gets pushed out has additional code changes that were not intended. Usually because everyone thought they could savely bypass some of the testing and QA. I think we can all forgive Logos on this once. A repeat would be much more serious.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 3683
BillS | Forum Activity | Replied: Sat, Jan 2 2010 11:47 AM

MJ. Smith:
this line is all I changed

hehe... been there, done that.Big Smile

Grace & Peace,
Bill


Asus GF63 8RD, I-7 8850H, 32GB RAM, 1TB SSD, 2TB HDD, NVIDIA GTX 1050Max
Samsung S9+, 64GB
Fire 10HD 64GB 7th Gen

Posts 5572
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Sat, Jan 2 2010 11:50 AM

Derek R. Iannelli-Smith:
Richard... I must have missed it... do you work for Logos...? if not, you just acerbated the situation and made me even more stimulated onto love and good deeds in wasting my time comparing this to dell and microsoft....  the point... customer service....

Derek, I'm sorry I offended you with my absurd comparison.

I did read your posts and see that you are quite upset with Logos right now.

I had a more lengthy response to that which I just deleted, but let me just say this:

I don't own any other software that has better support than Logos. In my experience this is a company that will always treat it's customers as best as it is able. Further that support has always been very good, very complete and very professional. I'm sure you find this to be the case as well - even if that experience is delayed until after the holidays.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 1353
PL | Forum Activity | Replied: Sat, Jan 2 2010 12:07 PM

Richard DeRuiter:

This release was supposed to be a very minor update to correct an issue with a Dec31 bug. Apparently something else happened, either with this release, or with the transition to 2010 that is causing a problem. Not everyone is having the problem, so it's quite baffling as to what exactly is going on.

 

Didn't someone mention Y2K... 10th anniversary? Smile

Right now I'm using the computer where Logos is broken by SR-2.  I can still use ESV Int. and  NLT Int. (NT only) -- if that helps anyone.

Peter

Posts 5
Derek R. Iannelli-Smith | Forum Activity | Replied: Sat, Jan 2 2010 12:13 PM

Richard,

I appreciate what your trying to do and I understand reading my rants that everyone may assume that, I just woke up this weekend and had a hair up my butt, however since my upgrade purchase (Nov) I have been attempting to contact Logos in all venues offered and mentioned.  I have been a customer since 2003.  Been there done that...  again, the point here is SOLUTION, RESPONSIBILITY, and INTEGRITY, not your qualifications, your gold star, etc.... 

Again I appreciate yours and others efforts.... but I need a solution and fix and like our brother said, it appears it may not be until tuesday or wednesday, or thursday and all I am doing by responding and reading these stupid posts is getting more and more aggrivated because it is not solving my problem.  This is my last posting and here is my point again in finality....

I am a HIGH VOLUME customer and have been for quite some time, my software is NOT WORKING, and the DVD that was sent fails, and the link to the 'new' fix also fails out.  I am adept at cleaning out all the registry, hidden files, and leftover stuff and fresh installs has accumulated to about 4-6 hours of time without a result which is WORKING Logos 4.  I do not need a bandaid, or hit a control key to send us diagnostic logging, or have you rebooted your computer bandaid responses.  It is quite clear there is something wrong and I am not the only person experiencing it (I have a vendor I deal with that regularly says to us, "That is really strange, it is not happening to anyone else." and finally had enough of it this year and told him to stop saying that especially after releasing the fix 2 weeks later).

Dear Logos,

Love your software, excited about the upgrade.  Please fix it so I can use it or refund my money until it is fixed.  I did not sign up for BETA Testing, I paid for final product.  Until then, I am going back to 3, and will redownload all my purchases which worked just fine.  I look forward to receiving a WORKING DVD (of which I already paid) version 4 (to include the fixes I have requested multiple times)  and please respond to me personally at my account or my email address you have on file.  I am not interested in a Gold Star forum postee, or customer service agent from another country, I look forward to being addressed personally and as a valuable customer I am who has spent over 2k with you.  I realize that I have been forceful and strong with my responses, and it had been my hope that they would have solicted action.  No response is a response. 

I hope you enjoyed your holiday and break, and do not envy that your walking in on Monday to this great litnay of responses to SR-1 and SR-2.  I received Logos 4 as a holiday gift (Nov-Dec) and have not had an opportunity to use it to its fullest because I have been addressing nonfunctional issues, repairing indexes, installing, reinstalling, waiting for it to index, having it fail, no responses from support, and posting in forums instead of Bible Study.  I look forward to hearing from you...

Posts 1983
Mark | Forum Activity | Replied: Sat, Jan 2 2010 12:30 PM

Darek

Your post reflects what many are feeling but not expressing.

Posts 28237
Forum MVP
MJ. Smith | Forum Activity | Replied: Sat, Jan 2 2010 12:52 PM

Derek R. Iannelli-Smith:
Again I appreciate yours and others efforts.... but I need a solution and fix

Unfortunately, your tone is justified. I truly feel for those who have not gotten up and running easily. My hope is that Logos' tech staff will become more adept at the unusual cases as they gain experience and that the development staff will take to heart the problems caused the users in this fiasco. We can only wait and see the response from Logos.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 3683
BillS | Forum Activity | Replied: Sat, Jan 2 2010 1:04 PM

MarkSwaim:

Your post reflects what many are feeling but not expressing.

I'm strongly tempted, as well. But we know Logos We know Bob. And therefore, we know that somehow they'll make it right.

Many blessings to you all...

L3 for final sermon prep, here I come. Smile

Grace & Peace,
Bill


Asus GF63 8RD, I-7 8850H, 32GB RAM, 1TB SSD, 2TB HDD, NVIDIA GTX 1050Max
Samsung S9+, 64GB
Fire 10HD 64GB 7th Gen

Posts 653
Alex Scott | Forum Activity | Replied: Sat, Jan 2 2010 1:21 PM

Richard - I just want to thank you for all your efforts on these forums.  I don't understand why you have to be subjected to the insulting comments and sarcasm of one particular new member to these forums about your gold star, and where you should go.  I hope you know you are a valued member here and I hope others feel this way too.

Longtime Logos user (more than $30,000 in purchases) - now a second class user because I won't pay them more every month or year.

Posts 5
Derek R. Iannelli-Smith | Forum Activity | Replied: Sat, Jan 2 2010 1:32 PM

I know I said last posting... but I FOUND the fix... and maybe for you....

Hark the herald angels sing!!! maybe!!!  Here are the steps to take to get Logos 4 SR-2 to work correctly with a FRESH INSTALL.

1.  Use Revouninstaller (FREE) in ADVANCED mode to remove all remnants of Logos.  http://www.revouninstaller.com/

2.  Reboot.

3.  Goto 'Search' (Winxp, vista, 7) and do the following searches

      a.  "Libronix" and select all the locations (minus any personally made backups of course... just talking programs junk), and DELETE or 'red' X.

      b.  "Logos" (this is the key and was in my case).... and delete ALL the locations, left behinds, ect that Revo did not find.

4.  Reboot again....  not necessarily needed but I wanted to make sure again that the files were gone, no resident files and nothing was hidden after uninstalls ect.

5.  Goto Latest Update/Install page mentioned previously in these posts and run .exe file.

6.  As of 1624, Jan 2, it is finally downloading the 9.20 GB (currently at 10%, see I told you I had a stubstanital investment in Logos!!!).  I wait with expectant crossed fingers to its completion.... (I have DSL, so it will take a while)..... but it looks like it is going to work....

7.  Don't spend time bantering back and forth in the forum and do something, and provide a solution. (Someone really needs to start a "I love Jesus next to Logos of course" forum as there are some serious diehards who need a place to voice their compliments.... another one with "I am a nitpicker about spell check" so all those folks can throw 'transubstantiation' at each other, and finally... There needs to be a LOGOS official programmer/employee not MVP Gold star poster... monitoring these forums,  some of us have more important things to do than post responses to non solutions...)

Page 4 of 6 (105 items) « First ... < Previous 2 3 4 5 6 Next > | RSS