Page 1 of 1 (12 items)
This post has 11 Replies | 2 Followers

Posts 261
LogosEmployee
Gabe Martin | Forum Activity | Posted: Wed, Jun 18 2014 3:49 PM

The Android Reader Suite v4.4+ apps will require Android OS 4.0 and higher. Current Android Reader Suite v4.3 apps will continue to support Android OS 2.3/3.x devices for a while longer, but only for critical bug fixes and will not receive new features.

Android 2.3 and 3.x were released over three years ago and are in use by a small percentage of users.

Upcoming versions of other Logos Android apps, including Faithlife Mobile, will also require Android 4.0 or higher.

Note: This announcement also affects the original Kindle Fire, which runs a modified version of Android 2.3

Posts 6776
Forum MVP
Lynden Williams | Forum Activity | Replied: Fri, Jun 20 2014 7:23 AM

Thanks Gabe. It was inevitable. If only my rich uncle would upgrade my phone. Glad I can receive the newer apps on Ice Cream Sandwich. 

Lynden Williams Communications

Posts 25772
Forum MVP
Graham Criddle | Forum Activity | Replied: Fri, Jun 20 2014 7:30 AM

Hi Gabe

Gabe Martin:
The Android Reader Suite v4.4+ apps will require Android OS 4.0 and higher. Current Android Reader Suite v4.3 apps will continue to support Android OS 2.3/3.x devices for a while longer, but only for critical bug fixes and will not receive new features.

Adding my thanks to Lynden's for the heads up on this.

It has convinced me I actually need to go ahead and replace my phoneSmile

Graham

Posts 12493
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Jun 20 2014 7:49 AM

 

Gabe Martin:

Note: This announcement also affects the original Kindle Fire, which runs a modified version of Android 2.3

It seems I need to rethink the Boox Lynx T68 thing. But you're asking us to throw money into new hardware that otherwise would surely have ended up as Logos books, you know that? 

Running Logos 9 latest (beta) version on Win 10

Posts 2072
Robert M. Warren | Forum Activity | Replied: Fri, Jun 27 2014 6:40 PM

Hey, if the Galaxy S was good enough for the Apostle Paul, it's good enough for me.

Windows 10 (L9 Beta) | Android 9 (phone - L9 Beta) | Fire OS 7 (tablet - L9 Stable)

There are four lights

Posts 27860
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Jul 5 2014 6:01 PM

Gabe Martin:
The Android Reader Suite v4.4+ apps will require Android OS 4.0 and higher. Current Android Reader Suite v4.3 apps will continue to support Android OS 2.3/3.x devices for a while longer, but only for critical bug fixes and will not receive new features.

Oh, well... I don't need any updates to Vyrso 4.3.x but will downloading of resources be impacted in the future? What else may be impacted?

Dave
===

Windows 11 & Android 8

Posts 593
Drew Hannay | Forum Activity | Replied: Sun, Jul 6 2014 8:48 AM

Dave Hooton:

Oh, well... I don't need any updates to Vyrso 4.3.x but will downloading of resources be impacted in the future? What else may be impacted?

When the resource driver/compiler version increases, the mobile apps need to be updated to support the new version. If the mobile apps aren't updated, then any resources that have been updated/compiled with the new version will no longer work on mobile. If the resource driver version were to be updated, say, tomorrow, I'd think there's a pretty good chance we'd update the apps for 2.3.x one more time to support the new driver version. If it's updated a few months from now...a mobile update seems less likely. Eventually, yes, new resource downloads/updates will stop working.

Posts 2589
Lee | Forum Activity | Replied: Sun, Jul 6 2014 9:39 AM

The whole Android update thing is a contentious issue on many hardware sites.

Couldn't you stretch the compatibility cycle to at least 5 years instead? Is there anything preventing a non-graphical app from doing that?

Posts 593
Drew Hannay | Forum Activity | Replied: Sun, Jul 6 2014 10:50 AM

Lee:

The whole Android update thing is a contentious issue on many hardware sites.

Couldn't you stretch the compatibility cycle to at least 5 years instead? Is there anything preventing a non-graphical app from doing that?

The jump from Android 2.3 to Android 4.0 was probably the biggest change Android has ever experienced. There are many new developer APIs and ways of doing things in Android 4.0+ that just aren't available in Android 2.3. There are several support libraries that let some of this new functionality work on 2.3 devices (and this is the approach Logos has taken until now) but they are buggy and don't provide a great experience for anyone (developers or users). The older devices just aren't capable of handling many of the newer features.

As an example of the cost of developing for Android 2.3, look at this screenshot:

These two dropdown items should show the icons for note documents and reading plan documents next to the menu items. It took me about 10 minutes to get that working on Android 4.0+, but then it didn't work (and was causing crashes!) on Android 2.3, even though all the documentation said that this should work on that platform. I spent an entire day trying to figure out why the icons weren't showing up before eventually tracking it down to a bug in the Android 2.3 source code. I ended up having to remove the icons on all platforms to fix the crashing on Android 2.3. If we didn't support Android 2.3, this task would have taken 10 minutes and looked nicer, but instead it took an entire work day.

That's just one example, I'm sure we could come up with countless others if we tried. Considering the very small percentage of our users running Android 2.3, we've reached the point where the cost exceeds the benefit. It's worth noting that Google hasn't updated any of their apps on Android 2.3 for (at least) several months now.

Posts 2589
Lee | Forum Activity | Replied: Sun, Jul 6 2014 2:59 PM

I agree that dropping 2.x is ok.In addition to what you mentioned there's that whole business with corrupt Hebrew text display, which was only taken care of with 4.x.

I guess my concern rest primarily with the later versions. Once libraries are stabilized, in principle an app like Bible can continue to be compiled for that version indefinitely.

Posts 2910
Jan Krohn | Forum Activity | Replied: Mon, Jul 14 2014 12:20 AM

The problem that I see here is with e-ink devices which mainly still run Android 2.x. I've seen a few Android 4.x devices, but all of them seem to be hugely overpriced.

I'd be fine being stuck with an old version of the app; but not being able to get new resources is not a very bright outlook at all. :-(

Past IT Consultant. Past Mission Worker. Entrepreneur. Seminary Student (VIU).
Christian Debate Forum --- Auferstanden! Blog

Posts 8
Brian Hammonds | Forum Activity | Replied: Thu, Dec 18 2014 9:25 AM

I'm looking for a dedicated E-Reader that can run the Logos Android App, preferably with a large screen. I'm thinking about this: http://www.amazon.com/dp/B00M1RKK1Y/ref=wl_it_dp_o_pC_nS_ttl?_encoding=UTF8&colid=NNQA5816ZXE4&coliid=I2KR2GJ0EDU292.

It runs Android 4.0. But I wanted to check if that meets the new minimum android version for support going forward. Thanks!

Page 1 of 1 (12 items) | RSS