Page 2 of 2 (38 items) < Previous 1 2
This post has 37 Replies | 2 Followers

Posts 2067
Randy W. Sims | Forum Activity | Replied: Fri, Aug 29 2014 9:29 AM

Fredc:

regsvr32 L4SmrtTg.dll

I copy and pasted that into the command line and then ran it as an administrator

Also can you confirm that that is the dll to run if I am running Logos 64 bit with Office 32 bit?

The command I ran, with the same setup you have, is:

regsvr32 "%LOCALAPPDATA%\Logos5\System\L4SmrtTg.dll"

You shouldn't need to run it as administrator.

Posts 4744
Forum MVP
Fred Chapman | Forum Activity | Replied: Fri, Aug 29 2014 10:07 AM

I was fairly certain but I double checked. I am running 32-bit

I have a critical database program on my computer that will not work with 64 bit office

Posts 2067
Randy W. Sims | Forum Activity | Replied: Fri, Aug 29 2014 10:46 AM

Fredc:
I was fairly certain but I double checked. I am running 32-bit

Sorry, I meant my first post above as a general warning to others reading the thread because it tripped me up at first.

Mine wasn't working (not sure at what point it stopped since I haven't really used it much, but it did once work). I did the following (after fumbling over the 64 bit version, thinking I had 64 bit Office):

"%LOCALAPPDATA%\Logos5\System\Logos.exe" /register

regsvr32 "%LOCALAPPDATA%\Logos5\System\L4SmrtTg.dll"

The commands are exactly as I typed them, including quotes. It now works correctly on this system: Windows 8.1 Pro x64, Office 2013 32bit, Logos 5.3b1. It wasn't necessary to edit the registry.

Posts 4744
Forum MVP
Fred Chapman | Forum Activity | Replied: Fri, Aug 29 2014 11:05 AM

Randy W. Sims:

Fredc:
I was fairly certain but I double checked. I am running 32-bit

Sorry, I meant my first post above as a general warning to others reading the thread because it tripped me up at first.

Mine wasn't working (not sure at what point it stopped since I haven't really used it much, but it did once work). I did the following (after fumbling over the 64 bit version, thinking I had 64 bit Office):

"%LOCALAPPDATA%\Logos5\System\Logos.exe" /register

regsvr32 "%LOCALAPPDATA%\Logos5\System\L4SmrtTg.dll"

The commands are exactly as I typed them, including quotes. It now works correctly on this system: Windows 8.1 Pro x64, Office 2013 32bit, Logos 5.3b1. It wasn't necessary to edit the registry.

Perfect! That's the fix!! Thanks Randy

Posts 20
Jeff Weaver | Forum Activity | Replied: Fri, Aug 29 2014 11:28 AM

Randy,

I typed in the commands exactly like you suggested and they appeared to work.But...when I go into Word, it sees the "Action" in Word, when I go to File,Options, Add-ins, it shows the LOGOS entry, but it isn't an available right click option.

Suggestions????Word 32-bit, hopefully 32bit Logos Smart tag.dll, but could be 64 bit. 

WIndows 8.1, 64 bit Pro

THANKS FOR THE HELP!!

Posts 8148
LogosEmployee

Jeff Weaver:
I typed in the commands exactly like you suggested and they appeared to work

Both commands should pop up a message box that has the word "succeeded" or "successfully"; did they?

Jeff Weaver:
Suggestions????

Have you reviewed the other usage notes at https://www.logos.com/articleviewer/530

You must have Logos 5 running at the same time, and neither program can be running elevated (i.e., run as administrator).

Posts 20
Jeff Weaver | Forum Activity | Replied: Fri, Aug 29 2014 1:45 PM

Ran both commands the first time and pretty positive they said succeeded. Ran again and the first command opened Logos 5 and the second said succeeded.

Neither running elevated. 

LOGOS 5 started first and running. Then Word is opened.

Rt Clicking on passage shows Additional Actions, but "LOGOS options" visible.

I have reviewed the notes and "Right Click Enabled" is selected and I ensured "Logos" was checked as well.

Posts 25378
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Aug 30 2014 7:13 AM

Bradley Grainger (Logos):
The Smart Tag works on my development machine with 64-bit Logos 5.3 and 32-bit Word 2013. Here are some troubleshooting steps; everyone's case may be different. You will need to be comfortable editing the registry.

Thanks Bradley,

These steps re-enabled Smart tags.

Dave
===

Windows 10 & Android 8

Posts 611
Graham Owen | Forum Activity | Replied: Sat, Aug 30 2014 7:15 AM

Worked for 32 bit Word 2007 on Windows 7 64 bit, thanks.

God Bless

Graham

Pastor - NTCOG Basingstoke

Posts 995
Richard Wardman | Forum Activity | Replied: Sat, Aug 30 2014 12:50 PM

Randy W. Sims:

Fredc:
I was fairly certain but I double checked. I am running 32-bit

Sorry, I meant my first post above as a general warning to others reading the thread because it tripped me up at first.

Mine wasn't working (not sure at what point it stopped since I haven't really used it much, but it did once work). I did the following (after fumbling over the 64 bit version, thinking I had 64 bit Office):

"%LOCALAPPDATA%\Logos5\System\Logos.exe" /register

regsvr32 "%LOCALAPPDATA%\Logos5\System\L4SmrtTg.dll"

The commands are exactly as I typed them, including quotes. It now works correctly on this system: Windows 8.1 Pro x64, Office 2013 32bit, Logos 5.3b1. It wasn't necessary to edit the registry.

FIXED!!!!!! Thanks for this. I managed to discover that the Logos 5 data folder is still called Logos4, so switching the folder name did the trick. Phew! It's good to have this feature back!!

Posts 25378
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Aug 31 2014 11:11 PM

Dave Hooton:

Thanks Bradley,

These steps re-enabled Smart tags.

I've updated the wiki article with info for 64-bit Logos (plus the smart tag for 64-bit Office).

Dave
===

Windows 10 & Android 8

Posts 2744
Bohuslav Wojnar | Forum Activity | Replied: Mon, Sep 1 2014 12:14 AM

Randy W. Sims:

Fredc:
I was fairly certain but I double checked. I am running 32-bit

Sorry, I meant my first post above as a general warning to others reading the thread because it tripped me up at first.

Mine wasn't working (not sure at what point it stopped since I haven't really used it much, but it did once work). I did the following (after fumbling over the 64 bit version, thinking I had 64 bit Office):

"%LOCALAPPDATA%\Logos5\System\Logos.exe" /register

regsvr32 "%LOCALAPPDATA%\Logos5\System\L4SmrtTg.dll"

The commands are exactly as I typed them, including quotes. It now works correctly on this system: Windows 8.1 Pro x64, Office 2013 32bit, Logos 5.3b1. It wasn't necessary to edit the registry.

Perfect. Works excellent. I assume most people with Win 8.1 system would have MS Office 32bit since that is what Microsoft recommends even for 64bit systems.

Bohuslav

Posts 239
Hans van den Herik | Forum Activity | Replied: Mon, Sep 1 2014 7:12 AM

Same for me. THANKS!

Hans

Posts 15
Brandon B. Carmichael | Forum Activity | Replied: Fri, Sep 19 2014 6:59 PM

I'm wondering if I can get some help with this problem. I'm running L5 and Word 2013 (32 bit). These installations are a week old, having just purchased this computer last week. I've been trying to get the Smart Tags working, going through the wiki and the suggestions on this thread step by step. However, I don't seem to be able to get past step 1.

The first thing which is asked is "Does “HKEY_CLASSES_ROOT\CLSID\{319A0316-DF84-4B3C-8117-349B7E98E613}” exist? If not, run C:\Path\To\Logos5\Logos.exe /register from a Command Prompt (note that your installation folder could be \Logos4)."

This key does not exist. Therefore I ran the c prompt register command. A pop-up notified me that Logos was registered correctly. However, the key "HKEY_CLASSES_ROOT\CLSID\{319A0316-DF84-4B3C-8117-349B7E98E613}” still does not exist. I refreshed the registry, rebooted, and refreshed again. I tried running the "register" command again. All to no avail. Everything else is set up correctly. All of the other registry entries are exactly as they ought to be as listed on the wiki page. I simply cannot get the key "HKEY_CLASSES_ROOT\CLSID\{319A0316-DF84-4B3C-8117-349B7E98E613}” to be created. Any suggestions? Can I just create that key manually? If so, what are the values for it? Thanks for the help. If anything here is unclear, please let me know.

Posts 8148
LogosEmployee

Brandon B. Carmichael:
I'm running L5

Which version?

Brandon B. Carmichael:
However, the key "HKEY_CLASSES_ROOT\CLSID\{319A0316-DF84-4B3C-8117-349B7E98E613}” still does not exist.

That's created for the 64-bit version of Logos (5.3). If you're running Logos 5.2b (32-bit), it won't be created.

Posts 15
Brandon B. Carmichael | Forum Activity | Replied: Sat, Sep 20 2014 4:53 AM

Brad, thanks. I presumed I was running 5.3, the version everyone was discussing. However, I am running 5.2b. Sorry about that. Still no Smart Tags, but I guess this belongs in a different discussion or something.

Thanks!

Posts 25378
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Sep 20 2014 5:27 AM

Brandon B. Carmichael:

Brad, thanks. I presumed I was running 5.3, the version everyone was discussing. However, I am running 5.2b. Sorry about that. Still no Smart Tags, but I guess this belongs in a different discussion or something.

Thanks!

If you worked through all the 64-bit steps in the wiki you will have undone entries for 5.2b.This should be fixed by repairing Logos Bible Software in Control Panel >> Programs and Features (right click and select Repair). Then work through the steps in http://www.logos.com/articleviewer/530

Dave
===

Windows 10 & Android 8

Posts 1
Sam Mathews | Forum Activity | Replied: Sat, Nov 1 2014 5:19 PM

I am using Logos 6. I tried cut and paste prompt on command. I am running Word 2010. I was able to use Smart tags on Logos 5. But after installing Logos 6  the smarttags stopped. I am using 64 bit

Page 2 of 2 (38 items) < Previous 1 2 | RSS