Rebuilding a Book after Upload - 5.3 Beta 1

Page 1 of 1 (6 items)
This post has 5 Replies | 1 Follower

Posts 171
John Eggen | Forum Activity | Posted: Thu, Sep 4 2014 1:20 PM

Updated to 5.3 Beta 1 and uploaded my personal books.

Today I went in to update one of the resources and add files and when attempting to build the book I receive an error, "Could not remove existing resource. Please close all other open panels and try again."

I've triple checked and the resource is not open in any of my tabs. I'm wondering if this is due to the PB having been uploaded and then trying to rebuild the resource. Has anyone else seen this issue?

Here are the contents of the log for PBB:

[Info] Starting build for PBB:281d3ce88d994a929a7b3bfdcebbab9b
[Error] Error while building book: Could not remove existing resource. Please close all other open panels and try again.
[Error] Exception: LDLS4.Panels.PersonalBookBuilderPanel.PersonalBookBuilderException: Could not remove existing resource. Please close all other open panels and try again.
at LDLS4.Panels.PersonalBookBuilderPanel.PersonalBookConverter.<CreatePersonalBookWork>d__c.MoveNext()
at Libronix.Utility.Threading.AsyncWorkerTask`1.EnumMoveNext()
at Libronix.Utility.Threading.AsyncWorkerTask`1.EnumMoveNextWithCatch()
at Libronix.Utility.Threading.AsyncWorkItem.Verify()
at LDLS4.Panels.PersonalBookBuilderPanel.PersonalBookViewModel.<CreatePersonalBookWork>d__a.MoveNext()

Posts 24360
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Sep 7 2014 3:56 PM

John Eggen:
I've triple checked and the resource is not open in any of my tabs. I'm wondering if this is due to the PB having been uploaded and then trying to rebuild the resource. Has anyone else seen this issue?

It is quite common despite Logos' attempts to resolve it. So restart Logos and try again.

Dave
===

Windows & Android

Posts 171
John Eggen | Forum Activity | Replied: Mon, Sep 8 2014 10:49 AM

Dave Hooton:

It is quite common despite Logos' attempts to resolve it. So restart Logos and try again.

I have tested since restarting Logos and also did a full restart of my machine since my original attempt and still cannot rebuild the book.

Posts 24360
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Sep 9 2014 2:02 PM

Does the problem arise with other PB's? If it occurs with only one PB can you upload the docx file (respecting copyright restrictions)?

Dave
===

Windows & Android

Posts 171
John Eggen | Forum Activity | Replied: Tue, Sep 9 2014 2:09 PM

This PB is a collecting of sermons so there are multiple files and the issue is after building the book trying to update it with additional files.

Randomly though I was trying today to reproduce this issue with a new PB and despite having tried it dozens of times before to rebuild the original book file today it worked. So I guess it's not an issue with the uploaded book. As you said Logos just wasn't working right but now it does.

Posts 24360
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Sep 9 2014 2:13 PM

John Eggen:
despite having tried it dozens of times before to rebuild the original book file today it worked.

I hope the developers take note of this.

Dave
===

Windows & Android

Page 1 of 1 (6 items) | RSS