Bugs in searching Chinese

Page 1 of 1 (7 items)
This post has 6 Replies | 1 Follower

Posts 1054
Kolen Cheung | Forum Activity | Posted: Sun, Sep 21 2014 1:06 AM

Hi. I noticed that searching Chinese is improving. Today I found an example that still has a bug

I try searching 閃電 東, which should have a result in Mt 24:27. But it doesn't results in any. In fact, even if I copy the few words

閃電從東

 from the resource

The Holy Bible. Chinese Union Version. (2005). (Shangti Edition, Traditional Script.). Hong Kong: Hong Kong Bible Society.

It still doesn't return a result.

I then input 東 only and found that Mt 24:27 doesn't show up.

May be the indexing is the problem and if I have time I will try to Rebuild Index. But for the meanwhile I quickly used another computer to perform the search and they agrees. So I guess it is not the index is messed up.

My version of Logos is 5.2b SR-3, running on Mac OS X Mavericks 10.9.5 and Yosemite Beta 3.

Posts 2526
GaoLu | Forum Activity | Replied: Sun, Sep 21 2014 2:57 AM

闪电 seems to be a problem in both 簡化 and 简化??

简化 seems to work for all combinations of the rest of that verse, but not 闪电.

东 works but 東 doesn't.  Needs more research.  That is just a quick observation if correct.

Posts 135
Daniel Liu | Forum Activity | Replied: Sun, Sep 21 2014 11:15 AM

The same result as you are. But I increase one bite for each words, the result is as follow:

Posts 1054
Kolen Cheung | Forum Activity | Replied: Mon, Sep 22 2014 1:23 PM

Thanks.

I tried

閃 電 東

with no result.

In fact I copy and paste 閃電從東 from the bible and search it and it doesn't have any result.

So it's related to that build and the related one only, and not all Logos version/build.

Which are are you using?

Posts 135
Daniel Liu | Forum Activity | Replied: Mon, Sep 22 2014 8:47 PM

I use Logos 5.2b SR-3.  It is a new installed one. I installed on Window 8.1 and Mac 10.9.5.  I do not have problems.

Posts 1054
Kolen Cheung | Forum Activity | Replied: Tue, Sep 23 2014 9:13 AM

Daniel Liu:

I use Logos 5.2b SR-3.  It is a new installed one. I installed on Window 8.1 and Mac 10.9.5.  I do not have problems.

That's weird, it means same build same OS can have different result. Although I got the same problem from two different Mac. I am thinking it might be history-dependent and will build the index again.

Posts 34
Matt | Forum Activity | Replied: Wed, Sep 24 2014 9:02 PM

FYI: I have the same result searching for 閃電從東on my system:

Windows 7 SR1 running Logos 5.2b SR-3

The Holy Bible. Chinese Union Version. Shangti Edition, Traditional Script. Hong Kong: Hong Kong Bible Society, 2005.

Strange!

Page 1 of 1 (7 items) | RSS