Logos not opening because it is "preparing library"

Page 1 of 1 (4 items)
This post has 3 Replies | 2 Followers

Posts 2
Richard Aasman | Forum Activity | Posted: Wed, Oct 15 2014 11:09 AM

I have Logos 5 on my office computer and laptop. Both have worked fine. Two days ago my laptop gives two messages: downloading updates, and preparing library. This goes on for hours and hours. Meanwhile, Logos will not load and I cannot use it. This was a huge problem yesterday when we examined a candidate for the ministry and I had to examine on OT exegesis. I am running Windows 8.1

Posts 98
J. Kane | Forum Activity | Replied: Fri, Oct 17 2014 10:31 AM

Richard: what you describe happens to me often and for a long time.  I've had Logos since is was Libronix 1.0, a large library (over 4,000 resources), a desktop and laptop both Win 8.1. I pastor so I have about 5 to 9 saved layouts at any one time to reflect what I'm studying. The boot-time was driving me bonkers so I read some forum posts and wound up disabling the home page trying to get a faster boot/load time.  It hasn't worked.

I just came to the office this morning and I haven't used the office computer since Wednesday.  It took 5 minutes for Logos to load... it did the preparing library thing and all that.

All that to say:  I don't know what to tell you.

After-thoughts:  I have found what the reindexing hangs up something when I start.  I go into task manager and stop logos processes and restart program that has helped.

Posts 13428
Mark Barnes | Forum Activity | Replied: Fri, Oct 17 2014 11:29 AM

Richard Aasman:
Two days ago my laptop gives two messages: downloading updates, and preparing library.

Preparing Your Library always happens after resources are added/updated. But it should only take a few seconds for each new resource. If it goes on longer than that, there's obviously a problem.

Firstly, I would suggest killing the LogosIndexer.exe process, and the Logos.exe process. Then try loading Logos again. You'll probably find it goes OK this time. If it doesn't, kill the processes again, then turn on diagnostic logging. Attempt to load Logos, and if it gets stuck again, upload the logs here.

https://wiki.logos.com/Diagnostic_Logging 

This is my personal Faithlife account. On 1 March 2022, I started working for Faithlife, and have a new 'official' user account. Posts on this account shouldn't be taken as official Faithlife views!

Posts 2
Richard Aasman | Forum Activity | Replied: Mon, Oct 20 2014 9:15 PM

Mark

I followed your advice and it worked perfectly. After turning off the indexer, I rebooted. Then there was some downloading and indexing, and everything works fine. Thanks so much for providing me with this help.

Richard

Page 1 of 1 (4 items) | RSS