Bug: Logos Bible Software 5.3 Beta 3 ( indexer crash on Windows 10 Tech Preview

Page 1 of 1 (5 items)
This post has 4 Replies | 2 Followers

Posts 693
Frank Sauer | Forum Activity | Posted: Fri, Oct 17 2014 6:07 PM

I've been running the Tech Preview since it was released and really have had no catastrophic problems with Logos.

Occasionally is takes quite longer when loading in comparison to Win 7 or Win 8.1, but runs smoothly once open.

Smart Tags seem to work fine with Word 2010. (Noted since another user reported them not working in the beta)

The only issue that seems to be consistent is the indexer crashing, so I've attached the logs. Hope it helps in preparing for Windows 10 compatibility.

3324.Logos Log Files.zip

Posts 9069

This is an error that's been reported infrequently before; I'm not sure if it's related to Windows Tech Preview or not.

Does "C:\Users\Frank\AppData\Local\Logos5\Data\y02hfmfm.rig\LibraryIndex\index-build.lxn" exist on your system? Are you able to delete it? (Or is it read-only, or owned by an administrator?)

Posts 667
Jonathan Pitts | Forum Activity | Replied: Sat, Oct 18 2014 7:34 AM

I've had the same problem but with the equivalent file in my BibleIndex folder. On adding new resources indexing would start but then crash.

I noted that the folder contained several additional files named "supplemental", which seemed to be left over from the aborted indexing attempts. (There were not the equivalent files in the LibraryIndex folder—yours may be the other way round.)

Last night, I deleted all the contents of the BibleIndex folder. On opening Logos, the Bible index was rebuilt.

This morning I downloaded a new resource, which seems to have indexed without the crash or left-over files. Hopefully, problem solved.

I'm running Windows 7.

Posts 667
Jonathan Pitts | Forum Activity | Replied: Sat, Oct 18 2014 7:43 AM

Correction: /BibleIndex/supplemental.met was the file I got an error on. All the security permissions in Windows seemed to be correct.

Anyway, deleting the index and rebuilding it might be worth a try. Previously, using the Rebuild Index command in Logos (without deleting the files) did not do the job.

Posts 693
Frank Sauer | Forum Activity | Replied: Sat, Oct 18 2014 8:27 AM

Forgot to update before leaving for work. Ran the rebuild index command before bed and let it run over night. That worked perfectly fine. 

Page 1 of 1 (5 items) | RSS