Page 1 of 1 (14 items)
This post has 13 Replies | 1 Follower

Posts 31
Clive Walters | Forum Activity | Posted: Sun, Oct 19 2014 6:35 AM

All works well, the app setting is to load most recent layout. Everything works fine for me. BUT, click on the HOME page icon: the window opens, but before it is populated, Logos crashes, without any warning, and without offering reporting option.

Re-start does not offer option to report last crash, but loads the latest layout OK. It is definitely repeatable!!

I don't know when (perhaps 5.3 b1) but after patiently waiting upgrades, even latest b3 has not changed. 

Hope you can tell me how to fix, or at least what to do that might ...

Clive

Posts 6490
Forum MVP
Lynden Williams | Forum Activity | Replied: Sun, Oct 19 2014 6:40 AM

Follow the steps here and post logs. This will assist others including Logos staff in diagnosing your problem.

Everything ever written in Religion and Theology formatted for Logos Bible Software.Logos Youtube Channel

Posts 27962
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Oct 19 2014 7:04 AM

Lynden Williams:
Follow the steps here and post logs.

Which steps? Wink

If you are on PC, see this wiki link: https://wiki.logos.com/Diagnostic_Logging 

If you are on MAC, follow the link in my signature line.

Also, it helps if you could give us important details such as which version you are using and what operating system you have installed.

OSX & iOS | Logs |  Install

Posts 6490
Forum MVP
Lynden Williams | Forum Activity | Replied: Sun, Oct 19 2014 7:06 AM

Thanks Bama. I forgot the link. Embarrassed

Everything ever written in Religion and Theology formatted for Logos Bible Software.Logos Youtube Channel

Posts 31
Clive Walters | Forum Activity | Replied: Sun, Oct 19 2014 11:19 PM

Thank you for the guidance.

I have logged the crash file. 

Posts 27962
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Oct 20 2014 5:01 AM

Clive Walters:

Thank you for the guidance.

I have logged the crash file. 

You don't seem to understand what we are asking. You need to tell the app to keep track of what is going on (enable logging). This is turned off by default. Once you have enabled logging, you need to start up Logos, allow the app to crash, grab the log files BEFORE starting the app again, and post them here so that forum members and/or faithlife can take a look.

To attach logs in the forum, it is best to have them zipped (some methods do this for you automatically) and then to use the paper clip icon in the forum formatting pallet.

OSX & iOS | Logs |  Install

Posts 31
Clive Walters | Forum Activity | Replied: Mon, Oct 20 2014 7:11 AM

I have done what I understood to be done, once more.

1. Run the Logging utility.

2. Fire up Logos.

3. trigger the crash (in my case, just hit the HOME icon. Crash follows and the app leaves no trace).

4. Hit ACHIVE LOGS in the Utility.

5. select and attach the ZIP file to this message (via the paperclip icon).

6. Submit this to the Forum. (hope the file is attached).

Posts 31
Clive Walters | Forum Activity | Replied: Mon, Oct 20 2014 7:15 AM

Just to complete: I am running OSX 10.9.5 on a Macbook Pro. 

Apologies for any failure to get things right.

Clive

Posts 1646
SteveF | Forum Activity | Replied: Mon, Oct 20 2014 10:21 AM

Clive Walters:
. (hope the file is attached).

It is not.

If it were there would be a hyperlink.

Regards, SteveF

Posts 27962
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Oct 20 2014 12:00 PM

Clive Walters:
Apologies for any failure to get things right.

See this wiki article about attaching logs: https://wiki.logos.com/Uploading_Logs 

OSX & iOS | Logs |  Install

Posts 31
Clive Walters | Forum Activity | Replied: Mon, Oct 20 2014 1:30 PM

Let me try again. For the first time a link address has been inserted in the message pane!. This is the first time I have used this feature, sorry to be so thick.

I think I expected some kind of acknowledgement that the file was connected. Instead, it just gets sent ... and this time I waited until transmission was probably completed.

3005.LogosLogs.clive.20141020-212119.zip

Posts 31
Clive Walters | Forum Activity | Replied: Thu, Oct 23 2014 9:45 PM

Just downloaded the 5.3 b4. Sadly, no change - clicking the Home page icon causes a crash of Logos without leaving a trace. I don't know if anyone has picked up the link provided last time. Or maybe I still haven't got it right. I can't revert to last full version. when I tried it told me there were changes in the file structure or format. Silence is creating anxiety.

Clive

Posts 8113
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Thu, Oct 23 2014 11:20 PM

I believe this crash is caused by a corrupt preference; you should be able to fix it by deleting this file:

/Users/clive/Library/Application Support/Logos4/Documents/xpjuo4cy.3j1/UserPreferences2/PreferencesManager.db

Posts 31
Clive Walters | Forum Activity | Replied: Fri, Oct 24 2014 5:06 AM

Phew! Welcome back "HOME' screen - I missed you.

Actually using Logos5. The excellent FREE 'FindFile' application permits searching for hidden files. Found it in seconds. Logos back on track!

Thanks again Bradley.

Clive

Page 1 of 1 (14 items) | RSS