Same crash, different (Send Searches here) angle Logos 6 SR-3

Page 1 of 1 (3 items)
This post has 2 Replies | 1 Follower

Posts 47
Jason Van Vliet | Forum Activity | Posted: Thu, Nov 6 2014 8:45 AM

Hello,

I reported a crash here in this thread and in the end we more or less concluded that the cause was some corruption in one of my layout, but as it turns out I think the issue is actually quite a different matter. For this reason I'm starting a new thread.  I hope that's within the bounds of forum etiquette but I simply want to ensure that the issue doesn't get lost.  (By the way, this is all done on Windows 8.1)

 Maybe someone can confirm that these steps result in a crash because they do for me.

  1. Open a Search window, go to Basic search, and pick the "Search Everything", and also turn on the "Send searches here" option for that same search window (it's in the drop down menu from the magnifying glass icon)
  2. Run a Search Everything on a word like "redeem" or "justify" and let the results populate.
  3. Under the first section where some Bible results appear, click on the "Search Bible" link => CRASH
  4. Alternatively, scroll down to the Media section and click on "Search Media for '[your word]'" => CRASH

All other links in the Search Everything result panel work (e.g., opening more Factbook results, or Search for more resources in the Books.logos.com section), but the two mentioned in #3 and #4 result in a crash.

Why?  I suppose it's linked to the "Send searches here" option, because if that option is not set on, everything works as expected.  However, when the option is set on, Logos is forcing itself to display new search results in the same window as the present ("Everything") search results.  And evidently, the underlying WPF software does not like have a new search both launched and displayed from within a present search window.

I'm sure Logos will figure out a solution to this problem, but if others can confirm that they experience the same issue it might help the developers.

Thanks

Posts 23642
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Nov 6 2014 9:59 AM

Jason Van Vliet:
but if others can confirm that they experience the same issue it might help the developers.

I have followed your steps but neither the Bible search nor media search cause a crash

  • The Bible search doesn't cause any change - probably a consequence of the send searches here setting
  • The media search replaces the basic search with a media search and works fine

However I am running the beta of 6.0a which may be the difference.

Posts 35
Jon Shearer | Forum Activity | Replied: Thu, Nov 6 2014 1:15 PM

Jason,

I followed your directions and had no problem.

I'm on a Macbook Pro running Yosemite (10.10).

Jon 

Page 1 of 1 (3 items) | RSS