Highlighting does not highlight exactly what I want.

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 26
Robert Griffin | Forum Activity | Posted: Mon, Dec 1 2014 4:29 PM

I try to highlight something.  In Logos 6 I find that it might highlight one word correctly for example.  If I want to highlight 2 words together then it will not let me.  It will force me to highlight 3 or 4 words together that I do not want to highlight.  I cannot make it just do the 2 words that I want.  If I want to highlight a few more words then it might make me highlight a whole paragraph together.  This used to work well in previous versions.  I do a lot of highlighting to find things quickly in lexicons so this is very important for me.

Posts 2093
Kenneth Neighoff | Forum Activity | Replied: Mon, Dec 1 2014 4:36 PM

It sounds like you have smart select turned on.  I believe this is the default setting in Logos 6.  To turn it off, go to the Tools menu and then under Utilities click on Program Settings, then under Text Display you will find Smart Text Selection.  Set it to 'NO' and you will be able to highlight as you want to.

Posts 947
Everett Headley | Forum Activity | Replied: Mon, Dec 1 2014 4:36 PM

I had same issue.  Go into Program Settings and Set Smart Text Selection  to No.

Posts 790
James Hiddle | Forum Activity | Replied: Mon, Dec 1 2014 4:41 PM

Thanks for the advice guys. God Bless you always!

Posts 26
Robert Griffin | Forum Activity | Replied: Mon, Dec 1 2014 4:49 PM

Thanks. I tried what you said to do. It worked perfectly.

I think that it would be good if Logos sets the default setting to "No". 

I think that most people will want to control exactly what they want to highlight.  I can't see the benefit of the "Yes" option.

Posts 31421
Forum MVP
MJ. Smith | Forum Activity | Replied: Mon, Dec 1 2014 6:29 PM

Robert Griffin:

I think that it would be good if Logos sets the default setting to "No". 

I think that most people will want to control exactly what they want to highlight.  I can't see the benefit of the "Yes" option.

I initially agreed with you. But given that it now works like Microsoft products, I understand why Logos made the choice it did. I hope their statistics will show if it was a good choice or not.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 635
Ryan | Forum Activity | Replied: Mon, Dec 1 2014 9:54 PM

If you'd like to have the best of both worlds you could always leave smart selection turned on, but when you want to highlight just a few select words hold down the ALT button while you're selecting your text. Holding down ALT temporarily disables the smart selection feature.

Posts 29050
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Dec 1 2014 10:06 PM

MJ. Smith:
But given that it now works like Microsoft products, I understand why Logos made the choice it did.

Uhh... no comment. Stick out tongue

Ryan B:
If you'd like to have the best of both worlds you could always leave smart selection turned on, but when you want to highlight just a few select words hold down the ALT button while you're selecting your text. Holding down ALT temporarily disables the smart selection feature.

I have been told the opposite is also true for those of us who like the "right" way of doing it. (Temporarily turning it on when you have it turned off)

macOS, iOS & iPadOS | Logs |  Install

Posts 19140
Rosie Perera | Forum Activity | Replied: Mon, Dec 1 2014 10:20 PM

alabama24:

Ryan B:
If you'd like to have the best of both worlds you could always leave smart selection turned on, but when you want to highlight just a few select words hold down the ALT button while you're selecting your text. Holding down ALT temporarily disables the smart selection feature.

I have been told the opposite is also true for those of us who like the "right" way of doing it. (Temporarily turning it on when you have it turned off)

Nope, that's not the way it works. I can confirm that holding down the ALT key while you're selecting text does not temporarily turn on smart selection when it is off. The only way to "temporarily" turn it on is to turn it on in Program Settings, and then turn it back off again when you no longer want it. That seems like more trouble than it's worth. I keep it off the whole time.

MJ. Smith:
But given that it now works like Microsoft products, I understand why Logos made the choice it did.

If it really worked the way Microsoft products work (Word, anyway), then double-clicking on a word and then dragging would allow you to select by whole word boundaries, ctrl-clicking then dragging would allow you to select by sentence boundaries, and triple-clicking then dragging would allow you to select by paragraph boundaries. (This works in Word whether or not you have the "When selecting, automatically select entire word" option on.) But double-clicking means something else in Logos, so they can't use that for smart selection.

Posts 29050
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Dec 1 2014 10:52 PM

Rosie Perera:
I can confirm that holding down the ALT key while you're selecting text does not temporarily turn on smart selection when it is off. The only way to "temporarily" turn it on is to turn it on in Program Settings, and then turn it back off again when you no longer want it.

Bradley (I believe, or some other Faithlife employee) said otherwise. The key might not be alt, but control. Don't ask me, I use mac. 

macOS, iOS & iPadOS | Logs |  Install

Posts 24298
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Dec 1 2014 11:00 PM

alabama24:

Rosie Perera:
I can confirm that holding down the ALT key while you're selecting text does not temporarily turn on smart selection when it is off. The only way to "temporarily" turn it on is to turn it on in Program Settings, and then turn it back off again when you no longer want it.

Bradley (I believe, or some other Faithlife employee) said otherwise. The key might not be alt, but control. Don't ask me, I use mac. 

Rosie is absolutely correct in what she is saying.

I think - but am not sure that - this is a change in behaviour from earlier versions and probably a bug. Chris posted at https://community.logos.com/forums/p/93089/647232.aspx#647232 that Alt / Cmd should toggle both ways.

Hopefully someone from Faithlife will be able to comment further.

Posts 19140
Rosie Perera | Forum Activity | Replied: Mon, Dec 1 2014 11:15 PM

Graham Criddle:

Rosie is absolutely correct in what she is saying.

I think - but am not sure that - this is a change in behaviour from earlier versions and probably a bug. Chris posted at https://community.logos.com/forums/p/93089/647232.aspx#647232 that Alt / Cmd should toggle both ways.

Thanks for backing me up.

And sorry, Alabama, for not being clearer. I didn't mean that Alt doesn't do anything. It does work to temporarily disable smart selection. I didn't know it was supposed to work the other way too. But it currently doesn't, at least on Windows. That's all I meant, in case that wasn't obvious.

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Mon, Dec 8 2014 8:52 AM

The behavior has changed slightly recently. Alt/Opt will only work one way as of 6.0a RC 1. More information can be found here: https://wiki.logos.com/Logos_6.0a_RC_1#Smart_Selection

Page 1 of 1 (13 items) | RSS