Logos 6 fails completely on Windows 7

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 54
Andrew | Forum Activity | Posted: Tue, Dec 2 2014 9:01 PM

Running 64-bit Windows 7.

Just upgraded from Logos 5 to Logos 6. It installed, started things, updated things, downloaded a bunch of stuff. then, when I attempted to start it, the start-up image is displayed and then Windows says "Logos Bible Software has stopped working". If I view the problem details, it says:

Problem signature:

  Problem Event Name: CLR20r3

  Problem Signature 01: Logos.exe

Problem Signature 02: 6.0.1.1317

  Problem Signature 03: 547cfd06

  Problem Signature 04: LogosIndexer

  Problem Signature 05: 6.0.1.1317

  Problem Signature 06: 547cfc3f

  Problem Signature 07: c5

  Problem Signature 08: 6f

  Problem Signature 09: System.DllNotFoundException

  OS Version: 6.1.7601.2.1.0.256.27

  Locale ID: 1033

  Additional Information 1: 407d

  Additional Information 2: 407d44cfad84bab60e2bab1da2aa3158

  Additional Information 3: 8c02

  Additional Information 4: 8c02dbfcb73256139143d2c761ec7b41

I then click on "close the program". Next, I took a look at the event viewer and I see a few messages logged.

.NET Runtime

Application: Logos.exe

Framework Version: v4.0.30319

Description: The process was terminated due to an unhandled exception.

Exception Info: System.DllNotFoundException

Stack:

   at Libronix.DigitalLibrary.NativeMethods.EnableMessageLogging(Libronix.DigitalLibrary.LogMessageCallback)

   at LDLS4.Indexer.Logos4ApplicationUtility.InitializeLogging()

   at LDLS4.OurApp.Main(System.String[])

******************************************************

Next event:

Faulting application name: Logos.exe, version: 6.0.1.1317, time stamp: 0x547cfd06

Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp: 0x5315a05a

Exception code: 0xe0434352

Fault offset: 0x000000000000940d

Faulting process id: 0xac8

Faulting application start time: 0x01d00eb47db5f8ba

Faulting application path: C:\Users\Andrew Pitonyak\AppData\Local\Logos5\System\Logos.exe

Faulting module path: C:\Windows\system32\KERNELBASE.dll

Report Id: bc9d3afc-7aa7-11e4-952b-000c29fc99a9

*************************************************

I applied all available updates prior to running, so I am up to date. I do not see any logs created, and I did run the JS to enable logging.

Any thoughts on how to make this work?

This failed on my first try, so, I uninstalled everything LOGOS that I could find from the machine. I even deleted any directory that appeared to be related and then I installed again. This entire super friendly program that does everything for me is not proving very helpful Crying

Posts 24847
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Dec 2 2014 11:10 PM

Try installing the 2012 Re-distributable.

Dave
===

Windows & Android

Posts 7983
LogosEmployee

This is usually caused by a failed installation (although we're still not entirely sure why; it's an infrequent problem).

We've had success in the past with the following:

  • Uninstall Logos 6 Prerequisites from Control Panel
  • Re-run LogosSetup.exe (from the link in your order email); this will reinstall the prerequisites and the missing files

If this doesn't work, I recommend calling our CS department tomorrow morning.

Posts 7983
LogosEmployee

Dave Hooton:

Try installing the 2012 Re-distributable.

FYI, Logos 6 uses the Visual C++ 2013 libraries; the VC++ 2012 redistributable is unlikely to help. (And I suspectbut don't know—that it's not the missing file.)

Posts 24847
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Dec 3 2014 12:16 AM

Thanks, Bradley

Dave
===

Windows & Android

Posts 54
Andrew | Forum Activity | Replied: Wed, Dec 3 2014 5:46 AM

Thanks for the replies.

That did not help.... Need to leave, will call them when I am in next unless someone has something else that I can try (probably won't be around this computer while tech support is open for a day or two).

Posts 54
Andrew | Forum Activity | Replied: Thu, Dec 4 2014 2:44 PM

And the final answer..... is that I did not have some Multi-Media player bundle installed and some DLL from that bundle is loaded on startup. Things are now working. Good job to tech support figuring that out! Thanks guys!

Posts 54
Andrew | Forum Activity | Replied: Thu, Dec 4 2014 4:03 PM

Of course, now, a bunch of my books are no longer available.... so, I type "update resources" into the bar to the right of tools, it updates a bunch of stuff, I restart, the stuff is still not there, so, I do it again. Grrrrr....

Posts 25
Bayard Bastedo | Forum Activity | Replied: Fri, Dec 5 2014 11:32 AM

It's not Windows 7. I have Win 7 64-bit, no problems. It's not Windows 7.

Bayard Bastedo

Posts 54
Andrew | Forum Activity | Replied: Sat, Dec 6 2014 6:21 AM

The point of the title was to provide enough information in the title that someone understood the problem and the OS. I can assure you that the OS is Windows 7 and that the problem was directly related to the configuration in Windows 7. I had found other posts with similar problems, but they were directly related to Mac. The intent was not to imply that Logos 6 is not able to run on any Windows 7 computer anywhere, but provide a pointer for someone trying to figure out which posts to read to understand that if their issue is on another OS this might not apply.

Of course, based on what I know now, I think that I could configure any Windows 7 computer so that it is not able to run Logos 6 (remove the media pack). Smile

Posts 1830
Kenneth Neighoff | Forum Activity | Replied: Sat, Dec 6 2014 6:35 AM

I am also running Logos 6 on Windows 7 64 bit with no problems. 

Posts 24847
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Dec 6 2014 1:17 PM

Kenneth Neighoff:

I am also running Logos 6 on Windows 7 64 bit with no problems. 

Kenneth, I could say the same. But does that help Andrew when he clearly has a problem (now solved!).

Dave
===

Windows & Android

Posts 54
Andrew | Forum Activity | Replied: Sat, Dec 6 2014 7:26 PM

I tolerate Logos because their support is so good Geeked  (this is where I should tip my hat to the support staff).

Well, that and all those wonderful resources!

Page 1 of 1 (13 items) | RSS