Visual Filter Not Working

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 71
John R. Gentry | Forum Activity | Posted: Fri, Dec 5 2014 5:11 AM

I spent a few minutes searching through the previous posts, but the forum wouldn't allow me to search for an exact string using quotation marks (kept giving me an error), so it is possible this had already been posted. If so, I apologize for the duplication.

I have a visual filter setup showing me 2nd person imperative verbs. I just updated to Logos 6 and it is no longer working properly (see attached screen shot). I have deleted the old filter and created a new one in Logos 6 with the same results.

Posts 71
John R. Gentry | Forum Activity | Replied: Fri, Dec 5 2014 5:34 AM

Alright, I figured out my own temporary solution. Smile I don't remember for certain, but I'm pretty sure my original filter was created via a search. I know when I recreated the filter in Logos 6 it was via a search. Apparently something about the syntax of going from a search to a visual filter got lost in translation, or, more precisely, was added in translation. However, when I setup a new visual filter using the documents menu and clicking on new visual filter, it seems to work just fine now. Although I was able to get mine working, it would be a pain for everyone to have to delete all of their visual filters and recreate them in Logos 6, so this is still a bug; I've just come up with a temporary work around.

Posts 2
Nam Park | Forum Activity | Replied: Sat, Dec 6 2014 9:35 PM

The fix for me was to rebuild the index.

You just have to type "rebuild index" in the command box. Then wait a very long time. But its worth it when all your visual filters start working again!

Hope that helps.

Posts 149
Robert Dean, Jr | Forum Activity | Replied: Mon, Dec 8 2014 1:51 PM

That did not help me. My visual filters only show up in the ESV, not in any other text. And yes, I have clicked on the option for them to show up in all similar resources. I've tried creating them anew in L6, but they still don't show up. However, they all show up with no problem in the ESV.

Posts 24903
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Dec 8 2014 1:55 PM

Robert Dean, Jr:
That did not help me. My visual filters only show up in the ESV, not in any other text

Can you post a screenshot showing your visual filter definition?

Posts 149
Robert Dean, Jr | Forum Activity | Replied: Wed, Dec 10 2014 7:14 AM

Posts 24903
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Dec 10 2014 10:35 AM

Thanks for the screenshot

I have created a visual filter with the same details (just the first row) and it works fine for non-ESV Bibles

Can you double-check Visual Filters in something other than the ESV to see if it is enabled? I called mine "L6 Morph" and it shows as enabled near the bottom of the NIV Visual Filter list

Posts 149
Robert Dean, Jr | Forum Activity | Replied: Sun, Dec 14 2014 8:02 PM

Yes, I have done this with tech support people at Logos. We work through the system, it DOES NOT WORK. I have no VISUAL FILTER line item in my visual filter drop-down menu except in ESV. NONE.  Only appears in ESV. Not my first rodeo. Been working visual filters since Logos 3. Everything is fine in ESV, but won't show up elsewhere. I work with these daily. I am ready to ask for a refund and return to L5 so I can get some more work done. Extremely frustrated is an understatement. 

Posts 24903
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Dec 14 2014 11:24 PM

Robert Dean, Jr:
. I have no VISUAL FILTER line item in my visual filter drop-down menu except in ESV. NONE.  Only appears in ESV

What happens if you run a morph search - as you have in your filter - against the NIV?

Does this show results?

If so, what happens if you then create a Visual Filter from that search?

Posts 149
Robert Dean, Jr | Forum Activity | Replied: Mon, Dec 15 2014 12:55 AM

I ran the morph search in NIV, NKJV, and the NET. It created a similar and correct list in all three versions. I then created a visual filter from that list. When I opened up each of those texts, and clicked on the three dots visual filter drop-down menu, the line item for VISUAL FILTERS does NOT appear.

Posts 24903
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Dec 15 2014 1:09 AM

Robert Dean, Jr:
I then created a visual filter from that list. When I opened up each of those texts, and clicked on the three dots visual filter drop-down menu, the line item for VISUAL FILTERS does NOT appear.

What happens if, instead of creating a morph visual filter, you create one based on a Bible search just looking for surface text?

Does this filter appear in the drop-down menu?

Posts 149
Robert Dean, Jr | Forum Activity | Replied: Mon, Dec 15 2014 7:19 AM

 I rebuilt the index for the third time since this began (the first time I was instructed to "rebuild Bible index"). For whatever reason, this time it worked and the visual filters are now restored to other Bible versions.

Thanks for the help.

Posts 24903
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Dec 15 2014 7:26 AM

Robert Dean, Jr:
For whatever reason, this time it worked and the visual filters are now restored to other Bible versions.

That's good news - thanks for reporting back

Robert Dean, Jr:
Thanks for the help.

You are welcome.

Page 1 of 1 (13 items) | RSS