Highlighter Custom Shortcut Key "y" Sometimes not working

Page 1 of 1 (19 items)
This post has 18 Replies | 2 Followers

Posts 2315
GaoLu | Forum Activity | Posted: Fri, Dec 5 2014 5:40 PM

Logos Bible Software 6.0b Beta 1  6.0.2.0017

For some reason, my custom shortcut key (y key) for the ordinary yellow highlighter occasionally does not work. I can try multiple times without success. Highlighting from the palate does work at such times.

Most of the time it works just fine.  

Posts 19139
Rosie Perera | Forum Activity | Replied: Fri, Dec 5 2014 5:45 PM

Is it possible you have some other software installed/running that has intercepted the y key? If you try reassigning that yellow highlighter to another shortcut key temporarily, can you reproduce the same problem when you press that other key?

Posts 2315
GaoLu | Forum Activity | Replied: Fri, Dec 5 2014 6:45 PM

I am fiddling to check it out.  I don't think any other program is capturing my "y" key.  I tried using other shortcut keys such as my "r" for red highlight.  It works.  But that may incident- specific rather than key-specific.  

I haven't tested this well...the awareness has been slowly creeping up on me of the interesting behavior.  

Example:

In the Mobile Ed BI100 course I open a Required Reading Book FSB.  The text is already highlighted. I try to highlight a selection over the top of the "Reading highlight."    Often it works, sometimes not.  In doing this, I also seem to have created a minor corruption of the BI100 Readings file--by creating  and extra "FSB" entry.  I think.  It adds a little yellow note icon smack in the middle the text.  That may be because I highlighted in red, then deleted the red highlight to change it back to yellow. In deleting the red highlight I deleted the Readings highlight, or re-adjusted it.   To fix that, I guess i have to remove and reconstruct the entire reading highlight in the BI100 Reading file.  One fix might be to delete and download a fresh copy of the notes file--but then I lose any highlighting that I have added to that file.  

 

I realize this is really two different issues occurring: 1) My "Y" highlight custom shortcut and 2) the matter of inadvertently deleting highlighting  (and not easily repairing)  from the Notes file associated with BI-100.

Posts 3047
Doc B | Forum Activity | Replied: Fri, Dec 5 2014 7:41 PM

Gao Lu:
occasionally does not work

Reminds me of the Ebn-Ozn song from the 80s- A,E,I,O,U and Sometimes Y.

One of the things about Logos is it is a memory hog. I've had issues similar to this in the past where the real problem was memory issues and the feature was simply very slow in responding. I would toggle it, and before it responded toggle it again (effectively turning it off).

One of the times it isn't working, try it, then go get something to drink. Come back in a couple minutes and see if it kicked in.

My thanks to the various MVPs. Without them Logos would have died early. They were the only real help available.

Faithlife Corp. owes the MVPs free resources for life.

Posts 8899
fgh | Forum Activity | Replied: Fri, Dec 5 2014 10:02 PM

Wireless keyboard with the battery running out?

(I've been having the same problem in another program, and I'm pretty sure it's the battery.)

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 2315
GaoLu | Forum Activity | Replied: Sat, Dec 6 2014 12:43 AM

Doc B:

Gao Lu:
occasionally does not work

Reminds me of the Ebn-Ozn song from the 80s- A,E,I,O,U and Sometimes Y.

One of the things about Logos is it is a memory hog. I've had issues similar to this in the past where the real problem was memory issues and the feature was simply very slow in responding. I would toggle it, and before it responded toggle it again (effectively turning it off).

One of the times it isn't working, try it, then go get something to drink. Come back in a couple minutes and see if it kicked in.

You know what, I think you are onto something there. Thanks!

I am not on a laptop, but my keyboard likely has pizza and cookie crumbs and coffee splashes in its innards, which is not helping.    

Posts 2315
GaoLu | Forum Activity | Replied: Sun, Dec 7 2014 5:11 AM

One more thought: I may be losing my marbles, but I think this behavior may be associated with using the Alt + Drag, 

Posts 635
Ryan | Forum Activity | Replied: Sun, Dec 7 2014 11:20 AM

As I was reading the thread I was going to suggest it being linked to using the Alt + drag (circumventing the smart selection.) I have the same problem with my orange highlighter which has the shortcut "O."  Often times when I try to do the alt + drag and then press O, even though I'm not still holding down the alt button, it still tries to open a document (which is what Alt + O does).

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Mon, Dec 8 2014 9:03 AM

Ryan B:

As I was reading the thread I was going to suggest it being linked to using the Alt + drag (circumventing the smart selection.) I have the same problem with my orange highlighter which has the shortcut "O."  Often times when I try to do the alt + drag and then press O, even though I'm not still holding down the alt button, it still tries to open a document (which is what Alt + O does).

If you are still experiencing this, I would like to know as it should have been fixed in 6.0a SR-1 and in 6.0b Beta 1 (see end of thread here: https://community.logos.com/forums/p/94034/661578.aspx)

Thanks!

Posts 635
Ryan | Forum Activity | Replied: Mon, Dec 8 2014 9:35 AM

Hi Chris,

I'm running 6.0a SR-2 and I still experience it. It doesn't always happen and I notice it happens most frequently with BI181 Mobile Ed (much more frequent here than other resources - though I'm spending a lot of time here lately so it could just be the sample size I'm pulling from.)

Ryan

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Tue, Dec 9 2014 10:36 AM

I've downloaded that resource and tried to reproduce the issue, but have not had any luck. Can you provide reliable reproduction steps for the issue? The only way I get the application to think I want to open a document is if I press Alt and 'O' simultaneously, which is the correct behavior. If I release Alt before pressing 'O', I cannot reproduce the issue at all.

Thanks!

Posts 1614
Forum MVP
Veli Voipio | Forum Activity | Replied: Tue, Dec 9 2014 10:53 AM

I did not know about this shortcut feature before, but I tried it right away.

Generally it seems to work, but when I am in a layout mode, activating the highlighting palette active, or deactivating that palette, or closing that palette may switch that shortcut off.

Gold package, and original language material and ancient text material, SIL and UBS books, discourse Hebrew OT and Greek NT. PC with Windows 8.1

Posts 635
Ryan | Forum Activity | Replied: Tue, Dec 9 2014 12:21 PM

Hi Chris,

I know it isn't helpful to hear but the problem for me is very intermittent so it's hard for me to give you steps to reproduce. If it helps, I notice it mostly (only?) happens when I'm highlighting in mobile ed resources and usually when I am highlighting the course notes on one monitor while the video is playing in full screen on the other monitor.

Posts 2315
GaoLu | Forum Activity | Replied: Tue, Dec 9 2014 1:18 PM

I am still experiencing this.  I am traveling now, on a different computer--a laptop.  Same thing happening. Reassigning the keyboard shortcut produces the same result.  I have tried different keys.  The result is intermittent, but frequent enough that I keep the highlight window open in case the shortcut does not work.  

1.  I do not think any other program is intercepting the key.  

2.  It seems to have something to do with highlighting text already highlighted by a Reading File.

3.  It seems to be associated with Alt + Drag.

Nothing new here, but some possible consistent clues.   

Posts 162
LogosEmployee
Chris Culy (Faithlife) | Forum Activity | Replied: Wed, Dec 10 2014 8:53 AM

Gao and Ryan, if you are able to take screencasts of the app while your issues are occurring, that would be very helpful. I'm not quite sure if you are reporting the same issue or different issues (or even multiple issues each).

Unfortunately, without a consistent way to reproduce the problem, there is no way to reliably fix it. Please let me know if you have a screencast or more detailed information. Thank you.

Posts 2315
GaoLu | Forum Activity | Replied: Fri, Dec 12 2014 11:37 PM

I will try.  I am on the road right now.  Might be a bit.  

Posts 635
Ryan | Forum Activity | Replied: Mon, Dec 15 2014 2:40 AM

Chris Culy (Faithlife):

Gao and Ryan, if you are able to take screencasts of the app while your issues are occurring, that would be very helpful. I'm not quite sure if you are reporting the same issue or different issues (or even multiple issues each).

Unfortunately, without a consistent way to reproduce the problem, there is no way to reliably fix it. Please let me know if you have a screencast or more detailed information. Thank you.


Hi Chris,

Today I noticed the problem much more prevalent (around 70% of the time) so I thought I'd make the sceencast you asked for. After many, many tries, I finally got a half-way decent screencast. (Something about it being dual monitors or the video going at the same time caused many recording/playback problems. This is the best screencast I could get.)

http://www.screencast.com/t/3m7cWAm5MBD8

In it you'll see the video playing on the right (the video monitor) and the coursework on the left (the main monitor). I make two highlights in the screencast. The first is a normal highlight with smart select on. The second is with me pressing ALT+ dragging the mouse to temporarily disengage the smart select. I then remove my finger from the ALT button and press "o" which is my shortcut for orange highlighter. You can see the document menu open (which is what ALT + O does.)

I apologize for the poor quality but I hope it helps.

Posts 1614
Forum MVP
Veli Voipio | Forum Activity | Replied: Mon, Dec 15 2014 4:24 AM

I also feel it might be a timing problem, something in the graphics sw/hw . Nowadays I press the "y" slighly longer than I would do otherwise, but I am not sure

Gold package, and original language material and ancient text material, SIL and UBS books, discourse Hebrew OT and Greek NT. PC with Windows 8.1

Posts 493
Brian W. Davidson | Forum Activity | Replied: Fri, Dec 19 2014 10:54 AM

I just experienced the same problem — pressing the shortcut key for highlighting wasn't working. I looked for this thread and saw someone mentioned holding the key down longer. I tried this and it worked. I held down "y," my yellow highlighter shortcut, for about a second or so and it worked, whereas simply pressing the key would not. The book I was reading was opened in its own separate window, and I'm running 6.0a SR5.

Macbook Pro (mid 2014), OSX 10.10.1, 2.3 i7, 256 SSD, 16GB RAM, Graphics: Intel Iris Pro 1536 MB 

Page 1 of 1 (19 items) | RSS