[resolved] 6.3 Beta 1 massacred my Verbum install

Page 1 of 1 (14 items)
This post has 13 Replies | 2 Followers

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Posted: Wed, Apr 15 2015 1:26 PM

I updated to 6.3 Beta 1, and I no longer have Verbum installed. The installer simply eliminated my installation!!! Amazing.

I would upload logs, but I don't have any. It didn't make any.

I am left with 178MB in my Verbum folder, all resources, EXEs completely gone. Verbum no longer appears in installed apps. I will need to install from scratch.

Posts 3297
David Taylor Jr | Forum Activity | Replied: Wed, Apr 15 2015 1:41 PM

That's odd.

Teacher, Ministry Leader, Student, Author, Husband

How to upload logs

Visit My Site: Reformed Truths

Posts 32544
Forum MVP
MJ. Smith | Forum Activity | Replied: Wed, Apr 15 2015 1:44 PM

Ouch! Thanks for the warning

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Wed, Apr 15 2015 1:49 PM

Fr Devin Roza:

I updated to 6.3 Beta 1, and I no longer have Verbum installed. The installer simply eliminated my installation!!! Amazing.

I would upload logs, but I don't have any. It didn't make any.

I am left with 178MB in my Verbum folder, all resources, EXEs completely gone. Verbum no longer appears in installed apps. I will need to install from scratch.

Yikes Indifferent I'm so sorry about that... We didn't run into in testing (somehow). We're pulling the installer from the update channel for now as we look into the cause. You should be able to manually reinstall, if we pull the download link before you're able to get it, email me at dylan DOT rondeau AT faithlife.com and I'll send you the installer.

Again, so sorry that happened. Sad

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Replied: Wed, Apr 15 2015 1:50 PM

I reinstalled. The program won't open at all. The only logs that are created are the VerbumIndexer.log, which I attach. I also ran the "Repair" option. No luck. Next step will be uninstall and reinstall.

All resources still completely gone. 

My Verbum install folder is now up from 178MB to 419MB. Ouch.

4130.VerbumIndexer.zip

Makes me wonder if Verbum is included in the pre-beta testing phases. 

Posts 42
LogosEmployee
Bryan Albert | Forum Activity | Replied: Wed, Apr 15 2015 1:52 PM

That's awful. We certainly want to investigate this. 

Could you please check your Temp folder for logs? If logging isn't enabled, the installer writes the log files to your temp folder's "Logos Log Files" folder (for example, "C:\Users\you\AppData\Local\Temp\Logos Log Files"). 

Thanks,

Bryan

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Replied: Wed, Apr 15 2015 1:54 PM

Here are all other available logs from the "My Documents" folder. These are all from before the install of Beta 1, but maybe they can be of some interest. (also note that two posts above there is the VerbumIndexer log - that one is post Beta 1 install).

5270.Verbum Log Files.zip

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Replied: Wed, Apr 15 2015 2:02 PM

Bryan Albert:

Could you please check your Temp folder for logs? If logging isn't enabled, the installer writes the log files to your temp folder's "Logos Log Files" folder (for example, "C:\Users\you\AppData\Local\Temp\Logos Log Files"). 

I don't have a Logos or Verbum folder in the Appdata\Local\Temp folder. The closest thing was the attached file, found in the main Temp folder, that seems to be a log of a Windows Update that I ran when restarting the computer after the Beta 1 install. There is some mention of Verbum inside. 

6545.MSI4d899.zip

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Replied: Wed, Apr 15 2015 2:07 PM

I just ran "repair" twice more, and similar logs were created. Neither really repaired the installation correction, as I can't actually successfully start Verbum, but here are the two logs, from the Appdata\local\temp folder.

0511.Temp.zip

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Replied: Wed, Apr 15 2015 2:31 PM

Fresh install begun of stable build, after uninstalling previous install... downloading resources.

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Replied: Mon, Apr 20 2015 1:38 AM

A friend of mine who happened to be on the Verbum beta track (and who I forgot to warn...) asked me about a "bug" he experienced last night where Verbum told him an update was available, he installed it, but it didn't really seem to do much, and that now he doesn't even have Verbum anymore. i.e., exactly the same experience I had. He'll have to reinstall from scratch.

It would be great if Faithlife could comment on their commitment to pre-beta test Verbum. This other person having the identical experience makes me worry that I was actually the very first person inside or outside of Faithlife to run a Verbum upgrade to the 6.3 Beta 1.

Of course, I'm not so worried about whether that is in fact the case or not, as I am about Faithlife's future commitment to give Verbum a normal internal pre-beta testing before releasing it to the public.

Posts 42
LogosEmployee
Bryan Albert | Forum Activity | Replied: Mon, Apr 20 2015 9:54 AM

We were able to reproduce the problem and fix it; the upgrade to Beta 2 should go much better!

I'm not sure how we missed this problem in testing, and I'm really sorry about that. Beta 1 certainly shouldn't have been shipped without our first having tested for and found this problem. Our testing process does include shipping Verbum to our internal testing channels and testing areas that we think could affect Verbum (such as installation in this case). We're looking into what went wrong there. 

We pulled the Verbum 6.3 Beta 1 as soon as we heard about your issue. I'm sorry it affected your friend as well. His system must have pulled down the update before we pulled it. 

Posts 1526
Forum MVP
Fr Devin Roza | Forum Activity | Replied: Mon, Apr 20 2015 10:00 AM

Thanks Bryan, I'm glad to hear you were able to figure it out and are looking into the procedure to see if anything needs to be improved.

And, yes -- my friend doesn't hit the "restart Verbum" button too often, so I do think he pulled it down right when it came out before you pulled it, and then just didn't install it until last night. 

Looking forward to a successful beta 2!

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Tue, Apr 21 2015 2:51 PM

Fr Devin Roza:
I updated to 6.3 Beta 1, and I no longer have Verbum installed. The installer simply eliminated my installation!!! Amazing.

6.3 Beta 2 has just shipped, and I can personally confirm that I was able to update 4 different installations to Beta 2 successfully. Again, I'm so sorry about the "experience" of Beta 1, and we're working on improving our update testing process for Verbum going forward.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Page 1 of 1 (14 items) | RSS