[resolved] v6.3: Ramifications of not having a System folder (Windows)

Page 1 of 1 (20 items)
This post has 19 Replies | 2 Followers

Posts 23606
Forum MVP
Dave Hooton | Forum Activity | Posted: Thu, May 7 2015 9:52 PM

With version specific folders e.g. \6.3.0.0029 replacing the \System folder:-

  • Smart Tags don't work
    • the path to LogosCom.exe has changed and is dynamic
    • the path to L4SmrtTg.dll has changed and is dynamic
  • Utilities like Logos Library Reporter don't work
    • consider creating a symbolic link for backwards compatibility as per Windows Documents folders

Dave
===

Windows & Android

Posts 23606
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, May 12 2015 9:10 PM

Comments, please FL.

Dave
===

Windows & Android

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Wed, May 13 2015 7:58 AM

Dave Hooton:

Comments, please FL.

There was internal discussion on this, and a dev case was made, but it looks like no one replied to the thread. Sorry about that. 

I'll check with Bryan on how this is being handled.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 9218
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, May 13 2015 8:26 AM

Dylan Rondeau:

Dave Hooton:

Comments, please FL.

There was internal discussion on this, and a dev case was made, but it looks like no one replied to the thread. Sorry about that. 

I'll check with Bryan on how this is being handled.

You may note that while Smart Tags is not an officially supported feature, it seems to belong to the workflow of many many users and I think I have seen threads for every permutation of Logos release and version of Word out there in the forums over the last half year or so (of course Bradley will know in much more detail). Breaking this without need should be avoided for the final release of 6.3 - and I know this is scheduled for Monday...

Running Verbum 7 and Logos 8 latest (beta) version on Win 10

Posts 42
LogosEmployee
Bryan Albert | Forum Activity | Replied: Wed, May 13 2015 9:20 AM

I'm currently working on the COM registration and should have it finished before we ship 6.3.

Posts 23606
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, May 13 2015 6:41 PM

A symbolic link would fix all issues. I created one and then re-created it without first having to delete it.

Dave
===

Windows & Android

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Tue, May 26 2015 1:01 PM

Bryan Albert:

I'm currently working on the COM registration and should have it finished before we ship 6.3.

This got delayed, but it should be fixed in 6.3 SR-1, which is now available.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 23606
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, May 26 2015 8:13 PM

Smart tags now works.

Dave
===

Windows & Android

Posts 143
T.P. Johnston | Forum Activity | Replied: Tue, Jun 2 2015 4:02 AM

I had posted in the Logos5 Forum about this as a reply to a post there. Oddly, my SmartTags did NOT stop working until the installation of Logos 6.3 SR-1. Once that was installed, which was supposed to have fixed a problem with SmartTags, mine stopped working. I've tried all the solutions given on the wiki page for Smart Tags and while the Action shows it is available in Word 2010, it simply does not work. This is the case with two separate but identical Windows 7 computers (one at home, one at office). Any advice would be greatly appreciated, as I use Smart Tags with Logos every day.

Posts 887
Richard Wardman | Forum Activity | Replied: Tue, Jun 2 2015 4:07 AM

Smart tags is not working for me! This is so frustrating. I've had to fix it with each release following instructions from a two-year old thread, and now it's disappeared and the fix doesn't work!

Advice?!

Posts 20308
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Jun 2 2015 4:11 AM

Does my suggestion at https://community.logos.com/forums/p/105630/731588.aspx#731588 help move things forward at all?

Posts 887
Richard Wardman | Forum Activity | Replied: Tue, Jun 2 2015 4:18 AM

Graham Criddle:

Does my suggestion at https://community.logos.com/forums/p/105630/731588.aspx#731588 help move things forward at all?

Thanks Graham. Unfortunately that doesn't work. I've tried both folder names but no joy. No error message, and the Logos icon 'highlights' in the taskbar, but that's it. 

Posts 23606
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Jun 2 2015 4:37 AM

T.P. Johnston:
I've tried all the solutions given on the wiki page for Smart Tags and while the Action shows it is available in Word 2010, it simply does not work.

I had asked Faithlife to make changes to the wiki as 6.3 SR-1 made registry changes that appeared to conflict with that advice. None-the-less Smart Tags works for me in v6.3 and v6.4 beta!

Dave
===

Windows & Android

Posts 143
T.P. Johnston | Forum Activity | Replied: Tue, Jun 2 2015 4:54 AM

Looks like Richard and I are in the same situation, and it would seem that Logos SmartTags for us is gone ... but not forgotten!

Posts 887
Richard Wardman | Forum Activity | Replied: Tue, Jun 2 2015 5:05 AM

T.P. Johnston:
Logos SmartTags for us is gone

Say it's not true!!! I use it too often. I need it back. There must be a fix. Someone help us. PLEASE!

Posts 887
Richard Wardman | Forum Activity | Replied: Tue, Jun 2 2015 5:32 AM

Just tried a restart of my computer but still not working.

For information, if it helps, I'm running Windows 7 with Logos 6.3 SR-1 (6.3.0.0056) on the stable channel. 

Posts 23606
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Jun 2 2015 4:06 PM

Richard and T.P.

You have 64-bit Windows OS and 32-bit Office?

What is the value at “HKEY_CLASSES_ROOT\TypeLib\{81490292-5570-4D02-A2AC-7B828DBD0A8A}\1.0\0\win64”

You deleted {81490292-5570-4D02-A2AC-7B828DBD0A8A}\1.0\0\win32 ?

If you look in HKEY_CURRENT_USER for L4SmrtTg.dll (as Value Data) what is its location e.g. Logos5\6.3.0.0056\L4SmrtTg.dll?

Dave
===

Windows & Android

Posts 887
Richard Wardman | Forum Activity | Replied: Wed, Jun 3 2015 1:27 AM

Dave Hooton:
You have 64-bit Windows OS and 32-bit Office?

Yes.

Dave Hooton:
What is the value at “HKEY_CLASSES_ROOT\TypeLib\{81490292-5570-4D02-A2AC-7B828DBD0A8A}\1.0\0\win64”

Not sure I understand this but this is what I see...

Dave Hooton:
You deleted {81490292-5570-4D02-A2AC-7B828DBD0A8A}\1.0\0\win32 ?

I hadn't but now I have!!

Dave Hooton:
If you look in HKEY_CURRENT_USER for L4SmrtTg.dll (as Value Data) what is its location e.g. Logos5\6.3.0.0056\L4SmrtTg.dll?

Still no joy. But do I need to restart?!

Posts 23606
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Jun 3 2015 6:31 AM

That all looks as it should be but i note your success at https://community.logos.com/forums/p/105737/732427.aspx#732427

Dave
===

Windows & Android

Posts 887
Richard Wardman | Forum Activity | Replied: Wed, Jun 3 2015 6:39 AM

Yes! All resolved now. Thanks for your help. 

Page 1 of 1 (20 items) | RSS